summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--PKGBUILD.bak65
3 files changed, 15 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 608b620a6d9a..b372a4825783 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Feb 9 23:06:26 UTC 2016
+# Mon Mar 28 17:31:59 UTC 2016
pkgbase = mingw-w64-qt5-serialport
pkgdesc = Provides access to hardware and virtual serial ports (mingw-w64)
- pkgver = 5.5.1
- pkgrel = 2
+ pkgver = 5.6.0
+ pkgrel = 1
url = https://www.qt.io/
arch = any
license = LGPL
@@ -12,8 +12,8 @@ pkgbase = mingw-w64-qt5-serialport
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.5/5.5.1/submodules/qtserialport-opensource-src-5.5.1.tar.xz
- md5sums = 1065424ad9be54f7635a9a50f35bc187
+ source = https://download.qt.io/official_releases/qt/5.6/5.6.0/submodules/qtserialport-opensource-src-5.6.0.tar.xz
+ md5sums = a9dfcfbf88034ada5b75f0be59030a37
pkgname = mingw-w64-qt5-serialport
diff --git a/PKGBUILD b/PKGBUILD
index da2383df6f34..08095369746d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,13 @@
# Maintainer: Martchus <martchus@gmx.net>
# Contributor: ant32 <antreimer@gmail.com>
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
_qt_module=qtserialport
pkgname="mingw-w64-qt5-serialport"
-pkgver=5.5.1
-pkgrel=2
+pkgver=5.6.0
+pkgrel=1
arch=('any')
pkgdesc="Provides access to hardware and virtual serial ports (mingw-w64)"
depends=('mingw-w64-qt5-base')
@@ -14,13 +17,13 @@ license=('LGPL')
url="https://www.qt.io/"
_pkgfqn="${_qt_module}-opensource-src-$pkgver"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/$pkgver/submodules/qtserialport-opensource-src-$pkgver.tar.xz")
-md5sums=('1065424ad9be54f7635a9a50f35bc187')
+md5sums=('a9dfcfbf88034ada5b75f0be59030a37')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/${_pkgfqn}"
-
+
# don't build examples or tests.
sed -i 's/ examples tests//' qtserialport.pro
@@ -29,7 +32,7 @@ build() {
${_arch}-qmake-qt5 ../${_qt_module}.pro
make
popd
-
+
#mkdir -p static-${_arch}/include/QtSerialPort && pushd static-${_arch}
#${_arch}-qmake-qt5 ../${_qt_module}.pro CONFIG+=static
#make
@@ -44,9 +47,9 @@ package() {
pushd build-${_arch}
make INSTALL_ROOT="${pkgdir}" install
-
+
popd
-
+
#pushd static-${_arch}
#make INSTALL_ROOT="${pkgdir}" install
#popd
diff --git a/PKGBUILD.bak b/PKGBUILD.bak
deleted file mode 100644
index c175d82ed041..000000000000
--- a/PKGBUILD.bak
+++ /dev/null
@@ -1,65 +0,0 @@
-# Maintainer: Martchus <martchus@gmx.net>
-# Contributor: ant32 <antreimer@gmail.com>
-
-_qt_module=qtserialport
-pkgname="mingw-w64-qt5-serialport"
-pkgver=5.5.1
-pkgrel=1
-arch=('any')
-pkgdesc="Provides access to hardware and virtual serial ports (mingw-w64)"
-depends=('mingw-w64-qt5-base')
-makedepends=('mingw-w64-gcc')
-options=('!strip' '!buildflags' 'staticlibs')
-license=('LGPL')
-url="http://qt-project.org/wiki/QtSerialPort"
-_pkgfqn="${_qt_module}-opensource-src-$pkgver"
-source=("http://download.qt-project.org/official_releases/qt/5.5/$pkgver/submodules/qtserialport-opensource-src-$pkgver.tar.xz")
-md5sums=('8a76f051ed28a9c925d32f5864d33e78')
-
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-
-build() {
- cd "${srcdir}/${_pkgfqn}"
-
- # don't build examples or tests.
- sed -i 's/ examples tests//' qtserialport.pro
-
- for _arch in ${_architectures}; do
- mkdir -p build-${_arch}/include/QtSerialPort && pushd build-${_arch}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro
- make
- popd
-
- #mkdir -p static-${_arch}/include/QtSerialPort && pushd static-${_arch}
- #${_arch}-qmake-qt5 ../${_qt_module}.pro CONFIG+=static
- #make
- #popd
- done
-}
-
-package() {
- cd "${srcdir}/${_pkgfqn}"
-
- for _arch in ${_architectures}; do
- pushd build-${_arch}
-
- make INSTALL_ROOT="${pkgdir}" install
-
- popd
-
- #pushd static-${_arch}
- #make INSTALL_ROOT="${pkgdir}" install
- #popd
-
- # The .dll's are installed in both bindir and libdir
- # One copy of the .dll's is sufficient
- rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
-
- ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
- ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.dll.a
- #${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*t.a
- done
-
- # .prl files aren't interesting for us
- find ${pkgdir} -name "*.prl" -delete
-}