summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
-rw-r--r--qtspeech-sha256.txt2
3 files changed, 24 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb1fa91a0bcf..92eb5e5b5e1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-speech-static
pkgdesc = Qt module to make text to speech and speech recognition easy (mingw-w64)
- pkgver = 5.15.1
+ pkgver = 5.15.13+kde+r1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -10,13 +10,13 @@ pkgbase = mingw-w64-qt5-speech-static
license = FDL
license = custom
makedepends = mingw-w64-gcc
+ makedepends = git
depends = mingw-w64-qt5-multimedia-static
depends = mingw-w64-qt5-speech
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.1/submodules/qtspeech-everywhere-src-5.15.1.tar.xz
- sha256sums = 7d2a5f7cf653d711de249ce4689959866d2381c625ced7ed4db7c8baaa140edc
+ source = git+https://invent.kde.org/qt/qt/qtspeech#commit=9b3738febbc751820ede496e8d619c5be56548dc
+ sha256sums = 67ded86b1764281213833d910c5771580087fc478c3bde99a9ed4ed555ca6db6
pkgname = mingw-w64-qt5-speech-static
-
diff --git a/PKGBUILD b/PKGBUILD
index 030dc3a0dfee..8964e5d44615 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qtspeech
pkgname=mingw-w64-qt5-speech-static
-pkgver=5.15.1
+pkgver=5.15.13
pkgrel=1
arch=('any')
pkgdesc="Qt module to make text to speech and speech recognition easy (mingw-w64)"
@@ -20,18 +20,31 @@ makedepends=('mingw-w64-gcc')
#optdepends=('mingw-w64-flite: flite TTS backend' 'mingw-w64-speech-dispatcher: speech-dispatcher TTS backend')
#makedepends=('mingw-w64-gcc' 'mingw-w64-flite' 'mingw-w64-speech-dispatcher')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=9b3738febbc751820ede496e8d619c5be56548dc
+_basever=${pkgver%%+*}
+pkgver+=+kde+r1
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('7d2a5f7cf653d711de249ce4689959866d2381c625ced7ed4db7c8baaa140edc')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('67ded86b1764281213833d910c5771580087fc478c3bde99a9ed4ed555ca6db6')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"
@@ -40,7 +53,7 @@ build() {
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
- make
+ make -j$(nproc)
popd
done
done
@@ -53,7 +66,7 @@ package() {
for _config in "${_configurations[@]}"; do
pushd build-${_arch}-${_config##*=}
- make INSTALL_ROOT="$pkgdir" install
+ make -j$(nproc) INSTALL_ROOT="$pkgdir" install
# use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
if [[ -d 'lib' ]]; then
diff --git a/qtspeech-sha256.txt b/qtspeech-sha256.txt
index 8a507538cec3..6dc6b69c7c97 100644
--- a/qtspeech-sha256.txt
+++ b/qtspeech-sha256.txt
@@ -1 +1 @@
-7d2a5f7cf653d711de249ce4689959866d2381c625ced7ed4db7c8baaa140edc
+67ded86b1764281213833d910c5771580087fc478c3bde99a9ed4ed555ca6db6