summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef4e8df25d29..21f7bf926445 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-speech-static
pkgdesc = Qt module to make text to speech and speech recognition easy (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -10,13 +10,13 @@ pkgbase = mingw-w64-qt5-speech-static
license = FDL
license = custom
makedepends = mingw-w64-gcc
+ makedepends = git
depends = mingw-w64-qt5-multimedia-static
depends = mingw-w64-qt5-speech
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtspeech-everywhere-src-5.15.2.tar.xz
- sha256sums = c810fb9eecb08026434422a32e79269627f3bc2941be199e86ec410bdfe883f5
+ source = git+https://invent.kde.org/qt/qt/qtspeech#commit=08b27c29aadc0cc0303cca97c9a3baa2a690dfe4
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-speech-static
-
diff --git a/PKGBUILD b/PKGBUILD
index 15d23fdce48f..2f1f9592401b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qtspeech
pkgname=mingw-w64-qt5-speech-static
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Qt module to make text to speech and speech recognition easy (mingw-w64)"
@@ -20,18 +20,31 @@ makedepends=('mingw-w64-gcc')
#optdepends=('mingw-w64-flite: flite TTS backend' 'mingw-w64-speech-dispatcher: speech-dispatcher TTS backend')
#makedepends=('mingw-w64-gcc' 'mingw-w64-flite' 'mingw-w64-speech-dispatcher')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=08b27c29aadc0cc0303cca97c9a3baa2a690dfe4
+_basever=$pkgver
+pkgver+=+kde+r1
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('c810fb9eecb08026434422a32e79269627f3bc2941be199e86ec410bdfe883f5')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"