summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Fix-linguist-macro.patch6
-rw-r--r--0002-Avoid-build-error-in-qcollectiongenerator.patch26
-rw-r--r--PKGBUILD16
-rw-r--r--PKGBUILD.sh.ep2
-rw-r--r--qttools-sha256.txt2
6 files changed, 46 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba1712ee1585..029d0cc0c266 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.15.13+kde+r4
+ pkgver = 5.15.14+kde+r4
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -20,9 +20,11 @@ pkgbase = mingw-w64-qt5-tools
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://invent.kde.org/qt/qt/qttools#commit=ba4c633c4a4731ead0c376b908bf5449796f7de1
+ source = git+https://invent.kde.org/qt/qt/qttools#commit=f82ed367d1b80b69d738cfcde534b75854a45476
source = 0001-Fix-linguist-macro.patch
- sha256sums = 52080466c7d03c6a6fd007940ed9cd42b2c73192ea2e76edf81619edff2adecf
- sha256sums = 3c8c553909b394a9d4833116be8a6a6f4a1e267e894fabd925c2519933b25e43
+ source = 0002-Avoid-build-error-in-qcollectiongenerator.patch
+ sha256sums = d27772cc0f51053dde0b3cdb665f50a8e504dab35a2ace4e691002ff5079ef07
+ sha256sums = b542af076bb62c5be68419d05244c25782f22f150c7497611eb44a43ea368282
+ sha256sums = 720a8852ded93d4ee8e3aca8a450b42527d9fb85b4b892e50d836b682eb5ea1a
pkgname = mingw-w64-qt5-tools
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
index bc19c095ab6e..58e5088d745a 100644
--- a/0001-Fix-linguist-macro.patch
+++ b/0001-Fix-linguist-macro.patch
@@ -1,7 +1,7 @@
-From f8d57f24ce2dc49fe0dd8e96343f7e66cc61e65c Mon Sep 17 00:00:00 2001
+From 89592d61a03488d2eff67c42f14bcb65726299c5 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:44:42 +0200
-Subject: [PATCH] Fix linguist macro
+Subject: [PATCH 1/2] Fix linguist macro
- Prevent CMake appending extra 'Qt5::lupdate'/'Qt5::lrelease' to
command line when invoking lupdate/lrelease
@@ -40,5 +40,5 @@ index 0ccf59f3c..01f5f3cd6 100644
DEPENDS ${qm_dep} VERBATIM
)
--
-2.44.0
+2.45.1
diff --git a/0002-Avoid-build-error-in-qcollectiongenerator.patch b/0002-Avoid-build-error-in-qcollectiongenerator.patch
new file mode 100644
index 000000000000..b135b1dbe3f6
--- /dev/null
+++ b/0002-Avoid-build-error-in-qcollectiongenerator.patch
@@ -0,0 +1,26 @@
+From a0b0083a0229c3e1d2ba47705dbadb0f2921d1c2 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Tue, 28 May 2024 22:26:21 +0200
+Subject: [PATCH 2/2] Avoid build error in qcollectiongenerator
+
+Change-Id: I91930bca30a6eff7ea9cac2727ec3af2844cad02
+---
+ src/assistant/qcollectiongenerator/main.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/assistant/qcollectiongenerator/main.c b/src/assistant/qcollectiongenerator/main.c
+index 783a799a1..517aae6fb 100644
+--- a/src/assistant/qcollectiongenerator/main.c
++++ b/src/assistant/qcollectiongenerator/main.c
+@@ -98,7 +98,7 @@ int main(int argc, char *argv[])
+
+ argv[0] = newPath;
+ #ifdef _WIN32
+- const intptr_t ret = _spawnvp(_P_WAIT, newPath, argv);
++ const intptr_t ret = _spawnvp(_P_WAIT, newPath, (const char * const*)(argv));
+ if (ret == -1) {
+ fprintf(stderr, "Error while executing \"%s\" tool.\n", newPath);
+ return 3;
+--
+2.45.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 08db2377e2db..f171fb2c89e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,14 +23,14 @@
_qt_module=qttools
pkgname=mingw-w64-qt5-tools
-pkgver=5.15.13
+pkgver=5.15.14
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c' 'mingw-w64-vulkan-headers')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
-_commit=ba4c633c4a4731ead0c376b908bf5449796f7de1
+_commit=f82ed367d1b80b69d738cfcde534b75854a45476
_basever=${pkgver%%+*}
pkgver+=+kde+r4
makedepends+=('git')
@@ -39,9 +39,11 @@ groups=('mingw-w64-qt5')
url='https://www.qt.io/'
_pkgfqn=${_qt_module}
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
- '0001-Fix-linguist-macro.patch')
-sha256sums=('52080466c7d03c6a6fd007940ed9cd42b2c73192ea2e76edf81619edff2adecf'
- '3c8c553909b394a9d4833116be8a6a6f4a1e267e894fabd925c2519933b25e43')
+ '0001-Fix-linguist-macro.patch'
+ '0002-Avoid-build-error-in-qcollectiongenerator.patch')
+sha256sums=('d27772cc0f51053dde0b3cdb665f50a8e504dab35a2ace4e691002ff5079ef07'
+ 'b542af076bb62c5be68419d05244c25782f22f150c7497611eb44a43ea368282'
+ '720a8852ded93d4ee8e3aca8a450b42527d9fb85b4b892e50d836b682eb5ea1a')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -69,7 +71,7 @@ build() {
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
- make -j$(nproc)
+ make
popd
done
done
@@ -82,7 +84,7 @@ package() {
for _config in "${_configurations[@]}"; do
pushd build-${_arch}-${_config##*=}
- make -j$(nproc) INSTALL_ROOT="$pkgdir" install
+ make INSTALL_ROOT="$pkgdir" install
# use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
if [[ -d 'lib' ]]; then
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 9305a79bee60..9f6cbd27cc10 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -18,7 +18,7 @@
% end
\
-pkgver=5.15.13
+pkgver=5.15.14
pkgrel=1
arch=(<%== include 'fragments/mingw-w64-qt5-non_any_archs' %>)
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
diff --git a/qttools-sha256.txt b/qttools-sha256.txt
index fa10f9c8d102..765096079ce7 100644
--- a/qttools-sha256.txt
+++ b/qttools-sha256.txt
@@ -1 +1 @@
-52080466c7d03c6a6fd007940ed9cd42b2c73192ea2e76edf81619edff2adecf
+d27772cc0f51053dde0b3cdb665f50a8e504dab35a2ace4e691002ff5079ef07