summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Fix-linguist-macro.patch4
-rw-r--r--0002-Prevent-linking-qhelpconverter-against-static-bearer.patch4
-rw-r--r--[-rwxr-xr-x]PKGBUILD10
4 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be0dbc5810dc..bb86e105b4b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.11.0
- pkgrel = 2
+ pkgver = 5.11.1
+ pkgrel = 1
url = https://www.qt.io/
arch = i686
arch = x86_64
@@ -20,12 +20,12 @@ pkgbase = mingw-w64-qt5-tools
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.11/5.11.0/submodules/qttools-everywhere-src-5.11.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.11/5.11.1/submodules/qttools-everywhere-src-5.11.1.tar.xz
source = 0001-Fix-linguist-macro.patch
source = 0002-Prevent-linking-qhelpconverter-against-static-bearer.patch
- sha256sums = 9d93ca84272cdf9031913cb3a6876716aa8a174e91693839f0de0ea3dd3a67d9
- sha256sums = 488e6f75865a6e818851f18ae4d45dd9ef91c02b48b1ce9cfb49ae2805858304
- sha256sums = aa2ef73945159e1c38a4f47938e58ddac3cac8d253c607a2f8c97241e0090842
+ sha256sums = b7fb186f92aedb922c4e7f57ff276bbf90caf0087a2a980f704bad9ac44514fe
+ sha256sums = 834af0d5cc321e0513a856632190a1d96d85452779c2e3e0ead9445d2756e274
+ sha256sums = 2b66137938499e02398005b70a1af54d43ed6c019ca156b3cdafa4940571038c
pkgname = mingw-w64-qt5-tools
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
index 39b881363788..d77df4f0c0d0 100644
--- a/0001-Fix-linguist-macro.patch
+++ b/0001-Fix-linguist-macro.patch
@@ -1,4 +1,4 @@
-From 61e5d85ffe9ad4656b8dc39d763b3c9a83604c81 Mon Sep 17 00:00:00 2001
+From 2a78698b7dc6f991f067c8cce90bf3d9a5ecb159 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:44:42 +0200
Subject: [PATCH 1/2] Fix linguist macro
@@ -38,5 +38,5 @@ index b9959730..75776e0e 100644
DEPENDS ${_abs_FILE} VERBATIM
)
--
-2.17.0
+2.18.0
diff --git a/0002-Prevent-linking-qhelpconverter-against-static-bearer.patch b/0002-Prevent-linking-qhelpconverter-against-static-bearer.patch
index 9103cf999dde..9b2da368358f 100644
--- a/0002-Prevent-linking-qhelpconverter-against-static-bearer.patch
+++ b/0002-Prevent-linking-qhelpconverter-against-static-bearer.patch
@@ -1,4 +1,4 @@
-From 7144128f261005ef0d2b5bcf46e383b252441520 Mon Sep 17 00:00:00 2001
+From a410e171253fd42dd08f3bb9471cb47eec155e4a Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 15 Oct 2017 22:25:22 +0200
Subject: [PATCH 2/2] Prevent linking qhelpconverter against static bearer
@@ -27,5 +27,5 @@ index d60aae7c..99943618 100644
SOURCES += conversionwizard.cpp \
inputpage.cpp \
--
-2.17.0
+2.18.0
diff --git a/PKGBUILD b/PKGBUILD
index 306e4578068f..bc0467f6670a 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,8 @@
_qt_module=qttools
pkgname="mingw-w64-qt5-tools"
-pkgver=5.11.0
-pkgrel=2
+pkgver=5.11.1
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
depends=('mingw-w64-qt5-declarative')
@@ -30,9 +30,9 @@ _pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Fix-linguist-macro.patch'
'0002-Prevent-linking-qhelpconverter-against-static-bearer.patch')
-sha256sums=('9d93ca84272cdf9031913cb3a6876716aa8a174e91693839f0de0ea3dd3a67d9'
- '488e6f75865a6e818851f18ae4d45dd9ef91c02b48b1ce9cfb49ae2805858304'
- 'aa2ef73945159e1c38a4f47938e58ddac3cac8d253c607a2f8c97241e0090842')
+sha256sums=('b7fb186f92aedb922c4e7f57ff276bbf90caf0087a2a980f704bad9ac44514fe'
+ '834af0d5cc321e0513a856632190a1d96d85452779c2e3e0ead9445d2756e274'
+ '2b66137938499e02398005b70a1af54d43ed6c019ca156b3cdafa4940571038c')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
# can not use static MySQL plugin because mariadb-connector-c comes with its own pthread implementation