summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch6
-rw-r--r--PKGBUILD8
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab4eee5a02ae..ed5c7b894271 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jun 8 19:42:46 UTC 2017
+# Thu Jul 6 21:13:14 UTC 2017
pkgbase = mingw-w64-qt5-winextras
pkgdesc = Classes and functions that enable you to use Windows-specific functions (mingw-w64)
- pkgver = 5.9.0
+ pkgver = 5.9.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -21,10 +21,10 @@ pkgbase = mingw-w64-qt5-winextras
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.9/5.9.0/submodules/qtwinextras-opensource-src-5.9.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.9/5.9.1/submodules/qtwinextras-opensource-src-5.9.1.tar.xz
source = 0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch
- sha256sums = 7280ae2a5d7cb563f23c48b5f8c37e340ce63950c6ab9f8fdf95072b3137b08b
- sha256sums = 6af1bdabab3ea822c398082abd32c0749ab4a1ef9a56eece75ca19c4e5c8d546
+ sha256sums = 1acc9ebd85146c75ae8dde20dcf5ffadd04da5d998a452eba055bce10849eef4
+ sha256sums = 5617949df83ce9f378d1043bb8823b0003e8e31ec65b4948b305d59424e42285
pkgname = mingw-w64-qt5-winextras
diff --git a/0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch b/0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch
index bec0c2df9b19..99d1faffbddd 100644
--- a/0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch
+++ b/0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch
@@ -1,4 +1,4 @@
-From f00d75eaf8c61607543563d50630bf8084bf936d Mon Sep 17 00:00:00 2001
+From 91fb69ece1a43dd153ba17b11e08c01b19fe5313 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 9 Feb 2017 01:07:46 +0100
Subject: [PATCH] Fix condition for _WIN32_IE/SHCreateItemFromParsingName
@@ -8,7 +8,7 @@ Subject: [PATCH] Fix condition for _WIN32_IE/SHCreateItemFromParsingName
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/winextras/qwinjumplist.cpp b/src/winextras/qwinjumplist.cpp
-index 9274cc5..962481e 100644
+index 12fa2e5..94b8e81 100644
--- a/src/winextras/qwinjumplist.cpp
+++ b/src/winextras/qwinjumplist.cpp
@@ -41,7 +41,7 @@
@@ -21,5 +21,5 @@ index 9274cc5..962481e 100644
# endif
# ifndef _WIN32_IE
--
-2.11.1
+2.13.2
diff --git a/PKGBUILD b/PKGBUILD
index 62e81d3afabc..c503a9b069ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qtwinextras
pkgname="mingw-w64-qt5-winextras"
-pkgver=5.9.0
+pkgver=5.9.1
pkgrel=1
arch=('any')
pkgdesc="Classes and functions that enable you to use Windows-specific functions (mingw-w64)"
@@ -22,8 +22,8 @@ url='https://www.qt.io/'
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch')
-sha256sums=('7280ae2a5d7cb563f23c48b5f8c37e340ce63950c6ab9f8fdf95072b3137b08b'
- '6af1bdabab3ea822c398082abd32c0749ab4a1ef9a56eece75ca19c4e5c8d546')
+sha256sums=('1acc9ebd85146c75ae8dde20dcf5ffadd04da5d998a452eba055bce10849eef4'
+ '5617949df83ce9f378d1043bb8823b0003e8e31ec65b4948b305d59424e42285')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -31,7 +31,7 @@ _architectures='i686-w64-mingw32 x86_64-w64-mingw32'
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
_configurations+=('CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
- _configurations+=('CONFIG+=shared')
+ _configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
prepare() {
cd "${srcdir}/${_pkgfqn}"