summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea976449dca3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-qt5-winextras
+ pkgdesc = Qt5 for Windows -- QtWinExtras component (mingw-w64)
+ pkgver = 5.4.2
+ pkgrel = 1
+ url = http://qt-project.org/
+ arch = any
+ license = GPL3
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-qt5-base
+ depends = mingw-w64-qt5-declarative
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://download.qt-project.org/official_releases/qt/5.4/5.4.2/submodules/qtwinextras-opensource-src-5.4.2.tar.xz
+ md5sums = 11c3949a279ca6339e70cceed8d45ea2
+
+pkgname = mingw-w64-qt5-winextras
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03c61f787f66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: ant32 <antreimer@gmail.com>
+_qt_module=qtwinextras
+pkgname="mingw-w64-qt5-winextras"
+pkgver=5.4.2
+pkgrel=1
+arch=('any')
+pkgdesc="Qt5 for Windows -- QtWinExtras component (mingw-w64)"
+depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative')
+makedepends=('mingw-w64-gcc')
+options=('!strip' '!buildflags' 'staticlibs')
+license=('GPL3' 'LGPL')
+url="http://qt-project.org/"
+_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
+source=("http://download.qt-project.org/official_releases/qt/5.4/${pkgver}/submodules/${_pkgfqn}.tar.xz")
+md5sums=('11c3949a279ca6339e70cceed8d45ea2')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build()
+{
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro
+ make
+
+ popd
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+
+ make INSTALL_ROOT="${pkgdir}" install
+
+ popd
+ done
+
+ # .prl files aren't interesting for us
+ find "${pkgdir}" -name "*.prl" -delete
+}