summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--0001-Use-CMake-s-default-import-library-suffix.patch43
-rw-r--r--0002-Fix-finding-D-Bus.patch6
-rw-r--r--0003-Fix-using-static-PCRE2-and-DBus-1.patch8
-rw-r--r--0004-Fix-transitive-dependencies-of-static-libraries.patch55
-rw-r--r--0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch6
-rw-r--r--0006-Support-finding-static-MariaDB-client-library.patch14
-rw-r--r--0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch10
-rw-r--r--0008-Fix-passing-QJniEnvironment-to-ANativeWindow_fromSur.patch44
-rw-r--r--PKGBUILD22
-rw-r--r--qtbase-sha256.txt2
11 files changed, 146 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03de0447f536..014b13a22135 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-base
pkgdesc = A cross-platform application and UI framework (mingw-w64)
- pkgver = 6.0.1
+ pkgver = 6.1.0
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -35,7 +35,7 @@ pkgbase = mingw-w64-qt6-base
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.0/6.0.1/submodules/qtbase-everywhere-src-6.0.1.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.1/6.1.0/submodules/qtbase-everywhere-src-6.1.0.tar.xz
source = 0001-Use-CMake-s-default-import-library-suffix.patch
source = 0002-Fix-finding-D-Bus.patch
source = 0003-Fix-using-static-PCRE2-and-DBus-1.patch
@@ -43,14 +43,16 @@ pkgbase = mingw-w64-qt6-base
source = 0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch
source = 0006-Support-finding-static-MariaDB-client-library.patch
source = 0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch
- sha256sums = 8d2bc1829c1479e539f66c2f51a7e11c38a595c9e8b8e45a3b45f3cb41c6d6aa
- sha256sums = 82bfcddb91097e761c5c3cfe66a2153e28446a11e20638c519589dab59bf891b
- sha256sums = 06a54156c5f3145783ee41d5e2dec651f23e207faeb113b9c59ed11b8201bb53
- sha256sums = aba65a351d26cfe2536c1115cce6448e4779998f663b71e5c4dc3fa7c3137f5d
- sha256sums = 820447581d2beda6f383ce8c7a18299b38273d162e62d5820c88dc24f2568a06
- sha256sums = 37af48d96b4265b442eac016928f0be5236f82ed7c5fa8670a389993556ffdee
- sha256sums = 074341ec2aebf7c9100022b9fedb919a426ec58c0456515cffd6131b205a11cd
- sha256sums = fa1ae6268c7b9f773dda4950dce834adf8d5a15ebc672f096e47b554192758c2
+ source = 0008-Fix-passing-QJniEnvironment-to-ANativeWindow_fromSur.patch
+ sha256sums = f7af3c87e96051d09b5abce6c88277c33031bef241ebfe1db4106d33ed0814c4
+ sha256sums = fe716b7d966cf40fafbed2fd67b663c205bb09e3fc1ad607163be187cb5f83c6
+ sha256sums = cb28dfdf82d332fa86e67106cea41ebf7f57ac49a5a7707be25348350b9c0f6e
+ sha256sums = 11a7e4939d171c3e7e8ecb8374fe0caebab2e55c8fd2a1122763caba56414358
+ sha256sums = 8081cf89e48a504a39bb18ea4c5cca92869fb0f1df45e6eda1559b2a0b38ba79
+ sha256sums = b97e12f46baebeea6d9a36f23e856783c6988b92965946e881dfb5e9749739ae
+ sha256sums = 9f2f542a7739024615b690fd5c2265c2ab63e5442eeb712b4df63220945a413e
+ sha256sums = 6990a3d6d8fa771b88092aa02010170d56fd86771e18096f120af16fce0ab691
+ sha256sums = 6498da7e772895ed58289a836c1b79a73750ffc5288fa0c6a03e4853879f00e7
pkgname = mingw-w64-qt6-base
diff --git a/0001-Use-CMake-s-default-import-library-suffix.patch b/0001-Use-CMake-s-default-import-library-suffix.patch
index 8590e0296c93..928c832d23f9 100644
--- a/0001-Use-CMake-s-default-import-library-suffix.patch
+++ b/0001-Use-CMake-s-default-import-library-suffix.patch
@@ -1,22 +1,22 @@
-From 450fa18bf971462b62ddcf4d2166b4b4d8b821e3 Mon Sep 17 00:00:00 2001
+From 4bc7d8f91f0f3695ff167bf9617510942097c82a Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 5 Nov 2020 22:08:10 +0100
-Subject: [PATCH 1/7] Use CMake's default import library suffix
+Subject: [PATCH 1/8] Use CMake's default import library suffix
-Change-Id: Iedc6a7ee8982a62ddd56ad0bf25ba0b8752a666a
+Change-Id: I3dbedaec74683e5bfd008f7f2fd1e046dfb921b2
---
cmake/QtPriHelpers.cmake | 12 ++++++++++--
cmake/QtPrlHelpers.cmake | 8 +++++++-
- cmake/QtTargetHelpers.cmake | 2 --
mkspecs/common/g++-win32.conf | 1 +
mkspecs/features/create_cmake.prf | 5 +++--
- 5 files changed, 21 insertions(+), 7 deletions(-)
+ src/corelib/Qt6CoreMacros.cmake | 1 -
+ 5 files changed, 21 insertions(+), 6 deletions(-)
diff --git a/cmake/QtPriHelpers.cmake b/cmake/QtPriHelpers.cmake
-index e77e98fe76..35639684a4 100644
+index 5498b8a904..59c905eac2 100644
--- a/cmake/QtPriHelpers.cmake
+++ b/cmake/QtPriHelpers.cmake
-@@ -368,9 +368,13 @@ QT.${config_module_name}_private.disabled_features = ${disabled_private_features
+@@ -370,9 +370,13 @@ QT.${config_module_name}_private.disabled_features = ${disabled_private_features
qt_path_join(private_pri_file_path "${target_path}" "${private_pri_file_name}")
list(APPEND pri_files "${private_pri_file_path}")
@@ -31,7 +31,7 @@ index e77e98fe76..35639684a4 100644
${CMAKE_EXTRA_SHARED_LIBRARY_SUFFIXES}
${CMAKE_STATIC_LIBRARY_SUFFIX})
add_custom_command(
-@@ -775,9 +779,13 @@ CONFIG += ${private_config_joined}
+@@ -777,9 +781,13 @@ CONFIG += ${private_config_joined}
list(APPEND inputs "${preliminary_pri_root}/${cfg}/${pri_data_cmake_file}")
endforeach()
@@ -69,19 +69,6 @@ index 0c0b7a2aec..d408245ffc 100644
if(QT_GENERATOR_IS_MULTI_CONFIG)
set(configs ${CMAKE_CONFIGURATION_TYPES})
-diff --git a/cmake/QtTargetHelpers.cmake b/cmake/QtTargetHelpers.cmake
-index 2a0a22f682..90d40e30c5 100644
---- a/cmake/QtTargetHelpers.cmake
-+++ b/cmake/QtTargetHelpers.cmake
-@@ -288,8 +288,6 @@ function(qt_internal_apply_win_prefix_and_suffix target)
-
- # This should cover both MINGW with GCC and CLANG.
- if(NOT MSVC)
-- set_property(TARGET "${target}" PROPERTY IMPORT_SUFFIX ".a")
--
- get_target_property(target_type ${target} TYPE)
- if(target_type STREQUAL "STATIC_LIBRARY")
- set_property(TARGET "${target}" PROPERTY PREFIX "lib")
diff --git a/mkspecs/common/g++-win32.conf b/mkspecs/common/g++-win32.conf
index 67ad1e3b8c..b98c7121f6 100644
--- a/mkspecs/common/g++-win32.conf
@@ -110,6 +97,18 @@ index 24ed125f12..73ebe453d3 100644
} else {
CMAKE_WINMAIN_FILE_LOCATION_DEBUG = qtmain$${QT_LIBINFIX}$${debug_suffix}.lib
CMAKE_WINMAIN_FILE_LOCATION_RELEASE = qtmain$${QT_LIBINFIX}.lib
+diff --git a/src/corelib/Qt6CoreMacros.cmake b/src/corelib/Qt6CoreMacros.cmake
+index 3d1a10ff0a..a6935875c7 100644
+--- a/src/corelib/Qt6CoreMacros.cmake
++++ b/src/corelib/Qt6CoreMacros.cmake
+@@ -447,7 +447,6 @@ function(_qt_internal_apply_win_prefix_and_suffix target)
+
+ # This should cover both MINGW with GCC and CLANG.
+ if(NOT MSVC)
+- set_property(TARGET "${target}" PROPERTY IMPORT_SUFFIX ".a")
+
+ get_target_property(target_type ${target} TYPE)
+ if(target_type STREQUAL "STATIC_LIBRARY")
--
-2.30.0
+2.31.1
diff --git a/0002-Fix-finding-D-Bus.patch b/0002-Fix-finding-D-Bus.patch
index a8f56f0e553d..0294ddf13c16 100644
--- a/0002-Fix-finding-D-Bus.patch
+++ b/0002-Fix-finding-D-Bus.patch
@@ -1,7 +1,7 @@
-From 4e3120dee97c10cf61c3b796b5d353e172c33c75 Mon Sep 17 00:00:00 2001
+From c1ed43ebc4f0cb63832b878f8666f0b8f5366906 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Wed, 7 Oct 2020 12:13:37 +0200
-Subject: [PATCH 2/7] Fix finding D-Bus
+Subject: [PATCH 2/8] Fix finding D-Bus
Change-Id: Ie21eb9cbc6b1b5d9c8b34eea46f54718e5926986
---
@@ -20,5 +20,5 @@ index e227d224e0..bdbcab9eb3 100644
+ set_property(TARGET dbus-1 PROPERTY IMPORTED_IMPLIB ${DBus1_LIBRARY})
+endif()
--
-2.30.0
+2.31.1
diff --git a/0003-Fix-using-static-PCRE2-and-DBus-1.patch b/0003-Fix-using-static-PCRE2-and-DBus-1.patch
index 57236e5e42d3..852b0edc1a17 100644
--- a/0003-Fix-using-static-PCRE2-and-DBus-1.patch
+++ b/0003-Fix-using-static-PCRE2-and-DBus-1.patch
@@ -1,7 +1,7 @@
-From e97b19b49e4eaaf696b7a57cfa02ae7b07080917 Mon Sep 17 00:00:00 2001
+From 927935b0f0783760a6bfa20784354bd3b590d9f0 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 5 Nov 2020 21:13:19 +0100
-Subject: [PATCH 3/7] Fix using static PCRE2 and DBus-1
+Subject: [PATCH 3/8] Fix using static PCRE2 and DBus-1
When making a static build of Qt we're using the static version of these
libraries and must define the corresponding macros.
@@ -13,7 +13,7 @@ Change-Id: I2387b79462b6d183b71f9433dd937f63fc7ef26e
2 files changed, 9 insertions(+)
diff --git a/src/corelib/text/qregularexpression.cpp b/src/corelib/text/qregularexpression.cpp
-index 6cc9011822..76041849b4 100644
+index 72079c1996..42007502af 100644
--- a/src/corelib/text/qregularexpression.cpp
+++ b/src/corelib/text/qregularexpression.cpp
@@ -53,6 +53,11 @@
@@ -44,5 +44,5 @@ index accaa4f5ed..4b11c74caa 100644
# include <dbus/dbus.h>
#else
--
-2.30.0
+2.31.1
diff --git a/0004-Fix-transitive-dependencies-of-static-libraries.patch b/0004-Fix-transitive-dependencies-of-static-libraries.patch
index 42596efe94dc..1b82dd4c5012 100644
--- a/0004-Fix-transitive-dependencies-of-static-libraries.patch
+++ b/0004-Fix-transitive-dependencies-of-static-libraries.patch
@@ -1,23 +1,27 @@
-From c037501e09603ef9ab645b0f9c909acb693ac096 Mon Sep 17 00:00:00 2001
+From 86a27658437d4d79cd010d1dd92f300f48616e45 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 5 Nov 2020 21:59:33 +0100
-Subject: [PATCH 4/7] Fix transitive dependencies (of static libraries)
+Subject: [PATCH 4/8] Fix transitive dependencies (of static libraries)
The dependencies of these libraries are not reliably picked up by their
corresponding find modules. This change allows adding the required
dependencies by setting certain variables, e.g. within the toolchain file.
-Change-Id: I81dbe9eebf1529116417c5bf5332b3f135e854bd
+This change also disables the upstream hack for OpenSSL's dependencies
+as it is even more hacky to hardcode the library names and the casing
+they use doesn't even work when building on GNU/Linux.
+
+Change-Id: I9afee4f1a1debb482ede63421de86adf1c7c5adc
---
- cmake/3rdparty/extra-cmake-modules/find-modules/FindGLIB2.cmake | 2 +-
- cmake/FindMySQL.cmake | 1 +
- cmake/FindWrapDBus1.cmake | 1 +
- cmake/FindWrapOpenSSL.cmake | 2 +-
- cmake/FindWrapSystemFreetype.cmake | 2 +-
- cmake/FindWrapSystemHarfbuzz.cmake | 2 +-
- cmake/FindWrapSystemPNG.cmake | 2 +-
- src/plugins/sqldrivers/psql/CMakeLists.txt | 2 +-
- 8 files changed, 8 insertions(+), 6 deletions(-)
+ .../3rdparty/extra-cmake-modules/find-modules/FindGLIB2.cmake | 2 +-
+ cmake/FindMySQL.cmake | 1 +
+ cmake/FindWrapDBus1.cmake | 1 +
+ cmake/FindWrapOpenSSL.cmake | 4 ++--
+ cmake/FindWrapSystemFreetype.cmake | 2 +-
+ cmake/FindWrapSystemHarfbuzz.cmake | 2 +-
+ cmake/FindWrapSystemPNG.cmake | 2 +-
+ src/plugins/sqldrivers/psql/CMakeLists.txt | 2 +-
+ 8 files changed, 9 insertions(+), 7 deletions(-)
diff --git a/cmake/3rdparty/extra-cmake-modules/find-modules/FindGLIB2.cmake b/cmake/3rdparty/extra-cmake-modules/find-modules/FindGLIB2.cmake
index 8f873c1b45..831ca8e624 100644
@@ -33,17 +37,17 @@ index 8f873c1b45..831ca8e624 100644
endif()
diff --git a/cmake/FindMySQL.cmake b/cmake/FindMySQL.cmake
-index f6c77d2be1..c20e7c9fa5 100644
+index a069a5eb12..0fcba2148e 100644
--- a/cmake/FindMySQL.cmake
+++ b/cmake/FindMySQL.cmake
-@@ -37,6 +37,7 @@ if(MySQL_FOUND AND NOT TARGET MySQL::MySQL)
+@@ -40,6 +40,7 @@ if(MySQL_FOUND)
add_library(MySQL::MySQL UNKNOWN IMPORTED)
set_target_properties(MySQL::MySQL PROPERTIES
IMPORTED_LOCATION "${MySQL_LIBRARIES}"
+ INTERFACE_LINK_LIBRARIES "${MYSQL_DEPENDENCIES}"
INTERFACE_INCLUDE_DIRECTORIES "${MySQL_INCLUDE_DIRS}")
+ endif()
endif()
-
diff --git a/cmake/FindWrapDBus1.cmake b/cmake/FindWrapDBus1.cmake
index bdbcab9eb3..06e9af49f6 100644
--- a/cmake/FindWrapDBus1.cmake
@@ -55,10 +59,19 @@ index bdbcab9eb3..06e9af49f6 100644
+ set_property(TARGET dbus-1 PROPERTY INTERFACE_LINK_LIBRARIES "${DBUS1_DEPENDENCIES}")
endif()
diff --git a/cmake/FindWrapOpenSSL.cmake b/cmake/FindWrapOpenSSL.cmake
-index 6e80862258..47bea72aad 100644
+index a09aa99518..ff13e1e931 100644
--- a/cmake/FindWrapOpenSSL.cmake
+++ b/cmake/FindWrapOpenSSL.cmake
-@@ -14,7 +14,7 @@ if(OpenSSL_FOUND)
+@@ -11,7 +11,7 @@ set(WrapOpenSSL_FOUND OFF)
+ find_package(WrapOpenSSLHeaders ${WrapOpenSSL_FIND_VERSION})
+
+ if(OpenSSL_FOUND)
+- if(WIN32)
++ if(WIN32 AND NOT MINGW)
+ get_target_property(libType OpenSSL::Crypto TYPE)
+ if(libType STREQUAL "ALIAS")
+ get_target_property(writableLib OpenSSL::Crypto ALIASED_TARGET)
+@@ -26,7 +26,7 @@ if(OpenSSL_FOUND)
set(WrapOpenSSL_FOUND ON)
add_library(WrapOpenSSL::WrapOpenSSL INTERFACE IMPORTED)
@@ -107,18 +120,18 @@ index 372a064ff4..a363bfd31b 100644
unset(__png_target_name)
unset(__png_found)
diff --git a/src/plugins/sqldrivers/psql/CMakeLists.txt b/src/plugins/sqldrivers/psql/CMakeLists.txt
-index 62e9619d16..939163bde7 100644
+index b151932da7..7e6b38acd1 100644
--- a/src/plugins/sqldrivers/psql/CMakeLists.txt
+++ b/src/plugins/sqldrivers/psql/CMakeLists.txt
-@@ -19,7 +19,7 @@ qt_internal_add_plugin(QPSQLDriverPlugin
+@@ -16,7 +16,7 @@ qt_internal_add_plugin(QPSQLDriverPlugin
QT_NO_CAST_FROM_ASCII
QT_NO_CAST_TO_ASCII
- PUBLIC_LIBRARIES
+ LIBRARIES
- PostgreSQL::PostgreSQL
+ PostgreSQL::PostgreSQL ${POSTGRESQL_DEPENDENCIES}
Qt::Core
Qt::CorePrivate
Qt::SqlPrivate
--
-2.30.0
+2.31.1
diff --git a/0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch b/0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch
index 47819a3ed40f..acde0a0acbe2 100644
--- a/0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch
+++ b/0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch
@@ -1,7 +1,7 @@
-From f1bb9a297c8df01081b073ad302c949488a7dc81 Mon Sep 17 00:00:00 2001
+From f3ca9d271a0919b086ca6864d9682ae11f05543e Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Mon, 2 Nov 2020 13:47:45 +0100
-Subject: [PATCH 5/7] Fix libjpeg workaround for conflict with rpcndr.h
+Subject: [PATCH 5/8] Fix libjpeg workaround for conflict with rpcndr.h
Otherwise it won't compile against mingw-w64-libjpeg-turbo. This version of
libjpeg seems to take care of the conflict already as long as jconfig.h is
@@ -33,5 +33,5 @@ index beef18f260..72708145f4 100644
#ifdef const
# undef const // remove crazy C hackery in jconfig.h
--
-2.30.0
+2.31.1
diff --git a/0006-Support-finding-static-MariaDB-client-library.patch b/0006-Support-finding-static-MariaDB-client-library.patch
index 042cdd64d010..0e387118614e 100644
--- a/0006-Support-finding-static-MariaDB-client-library.patch
+++ b/0006-Support-finding-static-MariaDB-client-library.patch
@@ -1,31 +1,31 @@
-From f209ca4e8726ae7502e06eaea09b5590b9050804 Mon Sep 17 00:00:00 2001
+From c0e504e5d21cbf6b708dbc34d9e52e9bf56f07b3 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 8 Nov 2020 00:33:12 +0100
-Subject: [PATCH 6/7] Support finding static MariaDB client library
+Subject: [PATCH 6/8] Support finding static MariaDB client library
We need to reverse the order to look for mariadb first (and only then
for mysql) because otherwise it would pick up the static library
"libmysqlclient.a" (provided by mingw-w64-mariadb-connector-c during
the shared build (leading to linker errors).
-Change-Id: I52f0998a67d4850d6684cdda59fc4523b8549476
+Change-Id: I9559b97540f2f928b4dec990d497bf2911ad5b60
---
cmake/FindMySQL.cmake | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/cmake/FindMySQL.cmake b/cmake/FindMySQL.cmake
-index c20e7c9fa5..9346cd55c6 100644
+index 0fcba2148e..ab4f6fdc9e 100644
--- a/cmake/FindMySQL.cmake
+++ b/cmake/FindMySQL.cmake
-@@ -27,7 +27,7 @@ find_path(MySQL_INCLUDE_DIRS
+@@ -27,7 +27,7 @@ find_path(MySQL_INCLUDE_DIR
PATH_SUFFIXES mysql mariadb)
- find_library(MySQL_LIBRARIES
+ find_library(MySQL_LIBRARY
- NAMES libmysql mysql mysqlclient libmariadb mariadb
+ NAMES libmariadb mariadb mariadbclient libmysql mysql mysqlclient
HINTS ${PC_MySQL_LIBDIR})
include(FindPackageHandleStandardArgs)
--
-2.30.0
+2.31.1
diff --git a/0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch b/0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch
index 70155e68f7cb..6327f1f2d232 100644
--- a/0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch
+++ b/0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch
@@ -1,7 +1,7 @@
-From 77ef8904f307f78613f799ad4b9946e23c7910e3 Mon Sep 17 00:00:00 2001
+From e682df25245fd2731bfe0572b2668e47f7ea3e99 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 8 Nov 2020 00:34:09 +0100
-Subject: [PATCH 7/7] Allow overriding CMAKE_FIND_LIBRARY_SUFFIXES to prefer
+Subject: [PATCH 7/8] Allow overriding CMAKE_FIND_LIBRARY_SUFFIXES to prefer
static libraries
Change-Id: Ic29b64b999ed9b5888a8dc1b0961a76009c5e75c
@@ -10,7 +10,7 @@ Change-Id: Ic29b64b999ed9b5888a8dc1b0961a76009c5e75c
1 file changed, 5 insertions(+)
diff --git a/cmake/QtBuildInternals/QtBuildInternalsConfig.cmake b/cmake/QtBuildInternals/QtBuildInternalsConfig.cmake
-index 477f5d21e9..fa394cd895 100644
+index 934c34b01c..bada2aff0c 100644
--- a/cmake/QtBuildInternals/QtBuildInternalsConfig.cmake
+++ b/cmake/QtBuildInternals/QtBuildInternalsConfig.cmake
@@ -1,6 +1,10 @@
@@ -24,7 +24,7 @@ index 477f5d21e9..fa394cd895 100644
######################################
#
# Macros for building Qt modules
-@@ -268,6 +272,7 @@ macro(qt_prepare_standalone_project)
+@@ -285,6 +289,7 @@ macro(qt_prepare_standalone_project)
endmacro()
macro(qt_build_repo_begin)
@@ -33,5 +33,5 @@ index 477f5d21e9..fa394cd895 100644
qt_enable_cmake_languages()
--
-2.30.0
+2.31.1
diff --git a/0008-Fix-passing-QJniEnvironment-to-ANativeWindow_fromSur.patch b/0008-Fix-passing-QJniEnvironment-to-ANativeWindow_fromSur.patch
new file mode 100644
index 000000000000..09fc8b8c6322
--- /dev/null
+++ b/0008-Fix-passing-QJniEnvironment-to-ANativeWindow_fromSur.patch
@@ -0,0 +1,44 @@
+From e668956ba71426d495ca9e117638b8d738fd148f Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sat, 8 May 2021 01:55:19 +0200
+Subject: [PATCH 8/8] Fix passing QJniEnvironment to ANativeWindow_fromSurface
+
+The function ANativeWindow_fromSurface (as declared by
+`$ANDROID_NDK_ROOT/toolchains/llvm/prebuilt/linux-x86_64/sysroot/usr/include/android/native_window_jni.h`
+from version r22.b of the Android NDK) takes a `JNIEnv*` so `.jniEnv()` must be used.
+
+This prevents the following compilation error:
+
+```
+error: no matching function for call to 'ANativeWindow_f
+romSurface'
+ m_nativeWindow = ANativeWindow_fromSurface(env, m_androidSurfaceObject.object());
+ ^~~~~~~~~~~~~~~~~~~~~~~~~
+/opt/android-ndk/toolchains/llvm/prebuilt/linux-x86_64/sysroot/usr/include/android/native_window_jni.h:45:16: note: candidate function not viable: no known conversion from 'QJniEnvironment' t
+o 'JNIEnv *' (aka '_JNIEnv *') for 1st argument
+ANativeWindow* ANativeWindow_fromSurface(JNIEnv* env, jobject surface);
+ ^
+1 error generated.
+```
+
+Change-Id: I70d75cb7edc5875314fcb8a70d51d0ef40442101
+---
+ src/plugins/platforms/android/qandroidplatformvulkanwindow.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/plugins/platforms/android/qandroidplatformvulkanwindow.cpp b/src/plugins/platforms/android/qandroidplatformvulkanwindow.cpp
+index 8f2a37626a..9d4688b52d 100644
+--- a/src/plugins/platforms/android/qandroidplatformvulkanwindow.cpp
++++ b/src/plugins/platforms/android/qandroidplatformvulkanwindow.cpp
+@@ -173,7 +173,7 @@ VkSurfaceKHR *QAndroidPlatformVulkanWindow::vkSurface()
+ return &m_vkSurface;
+
+ QJniEnvironment env;
+- m_nativeWindow = ANativeWindow_fromSurface(env, m_androidSurfaceObject.object());
++ m_nativeWindow = ANativeWindow_fromSurface(env.jniEnv(), m_androidSurfaceObject.object());
+
+ VkAndroidSurfaceCreateInfoKHR surfaceInfo;
+ memset(&surfaceInfo, 0, sizeof(surfaceInfo));
+--
+2.31.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 00533236b4f4..373f88509060 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
# All patches are managed at https://github.com/Martchus/qtbase
pkgname=mingw-w64-qt6-base
-_qtver=6.0.1
+_qtver=6.1.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -37,15 +37,17 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/subm
'0004-Fix-transitive-dependencies-of-static-libraries.patch'
'0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch'
'0006-Support-finding-static-MariaDB-client-library.patch'
- '0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch')
-sha256sums=('8d2bc1829c1479e539f66c2f51a7e11c38a595c9e8b8e45a3b45f3cb41c6d6aa'
- '82bfcddb91097e761c5c3cfe66a2153e28446a11e20638c519589dab59bf891b'
- '06a54156c5f3145783ee41d5e2dec651f23e207faeb113b9c59ed11b8201bb53'
- 'aba65a351d26cfe2536c1115cce6448e4779998f663b71e5c4dc3fa7c3137f5d'
- '820447581d2beda6f383ce8c7a18299b38273d162e62d5820c88dc24f2568a06'
- '37af48d96b4265b442eac016928f0be5236f82ed7c5fa8670a389993556ffdee'
- '074341ec2aebf7c9100022b9fedb919a426ec58c0456515cffd6131b205a11cd'
- 'fa1ae6268c7b9f773dda4950dce834adf8d5a15ebc672f096e47b554192758c2')
+ '0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch'
+ '0008-Fix-passing-QJniEnvironment-to-ANativeWindow_fromSur.patch')
+sha256sums=('f7af3c87e96051d09b5abce6c88277c33031bef241ebfe1db4106d33ed0814c4'
+ 'fe716b7d966cf40fafbed2fd67b663c205bb09e3fc1ad607163be187cb5f83c6'
+ 'cb28dfdf82d332fa86e67106cea41ebf7f57ac49a5a7707be25348350b9c0f6e'
+ '11a7e4939d171c3e7e8ecb8374fe0caebab2e55c8fd2a1122763caba56414358'
+ '8081cf89e48a504a39bb18ea4c5cca92869fb0f1df45e6eda1559b2a0b38ba79'
+ 'b97e12f46baebeea6d9a36f23e856783c6988b92965946e881dfb5e9749739ae'
+ '9f2f542a7739024615b690fd5c2265c2ab63e5442eeb712b4df63220945a413e'
+ '6990a3d6d8fa771b88092aa02010170d56fd86771e18096f120af16fce0ab691'
+ '6498da7e772895ed58289a836c1b79a73750ffc5288fa0c6a03e4853879f00e7')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
diff --git a/qtbase-sha256.txt b/qtbase-sha256.txt
index d7b393f268c0..0232cc39e5e0 100644
--- a/qtbase-sha256.txt
+++ b/qtbase-sha256.txt
@@ -1 +1 @@
-8d2bc1829c1479e539f66c2f51a7e11c38a595c9e8b8e45a3b45f3cb41c6d6aa
+f7af3c87e96051d09b5abce6c88277c33031bef241ebfe1db4106d33ed0814c4