summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--0001-Use-CMake-s-default-import-library-suffix.patch12
-rw-r--r--0002-Fix-finding-D-Bus.patch4
-rw-r--r--0003-Fix-using-static-PCRE2-and-DBus-1.patch10
-rw-r--r--0004-Fix-transitive-dependencies-of-static-libraries.patch4
-rw-r--r--0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch4
-rw-r--r--0006-Support-finding-static-MariaDB-client-library.patch4
-rw-r--r--0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch6
-rw-r--r--0008-Fix-crashes-in-rasterization-code-using-setjmp.patch8
-rw-r--r--PKGBUILD20
-rw-r--r--qtbase-sha256.txt2
11 files changed, 48 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a4bdd91af63..1464380147c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-base
pkgdesc = A cross-platform application and UI framework (mingw-w64)
- pkgver = 6.2.0
+ pkgver = 6.2.1
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -35,7 +35,7 @@ pkgbase = mingw-w64-qt6-base
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.2/6.2.0/submodules/qtbase-everywhere-src-6.2.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.2/6.2.1/submodules/qtbase-everywhere-src-6.2.1.tar.xz
source = 0001-Use-CMake-s-default-import-library-suffix.patch
source = 0002-Fix-finding-D-Bus.patch
source = 0003-Fix-using-static-PCRE2-and-DBus-1.patch
@@ -44,14 +44,14 @@ pkgbase = mingw-w64-qt6-base
source = 0006-Support-finding-static-MariaDB-client-library.patch
source = 0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch
source = 0008-Fix-crashes-in-rasterization-code-using-setjmp.patch
- sha256sums = fdfff0716d093bcb6bcd53746ce1d3c9701a6bf3326d47813866d43949b47769
- sha256sums = 02811ca9f69e29242e817cae9afbcbd6b0eb1377c5f680a835c517b9d82e42ff
- sha256sums = 14524bf028ba07e04a6428e0eb2049d3743571d181d5037f65e2624af5e57bf4
- sha256sums = 25c6fef400bac3b701ddf5d429d74fc744c612e683838cdf44b874bc24d379be
- sha256sums = b0cb32ec2dadc4479c9090f1f9326ff5b26550b94c88380e12ae68c0535f56af
- sha256sums = 00ad6ee9b73a128a94e813cccf17122232063cb0dd503952b8858012da0cc2d3
- sha256sums = f33c044eed6224c4f71c43de5157c8ff1028ccdc3cefa7b26b37e6705ea7483c
- sha256sums = 937833cb719d9ec40b049f4440002c4507666ea53bfd0f4f9af4cc849a9016e3
- sha256sums = 3b40db6950bcbafd0d921b6d9683c03da47581a8b465cda6ac8781135ef8db17
+ sha256sums = 2c5f07b5c3ea27d3fc1a46686ea3fb6724f94dddf1fb007de3eb0bdb87429079
+ sha256sums = be2cb794752635df017e97601646f7cb2f6b22b0a2411ad23d7ada5d685dc97f
+ sha256sums = ef7e3305f8bb11482bb6b9dd5dea16a0bbed293d7b615c75caa10db304862a52
+ sha256sums = 3f80ae4137d875e60043b1d974479bbe9b331beebb794c41b9b4514c2e5e8a9b
+ sha256sums = b27ce3e4082d687524035548ef8a903f272447a5a57a79edc500c0a9ff1d5dcb
+ sha256sums = 1c386bcaede05b6bd1c01e5e41aff157447551733ac9f56428de3cae8761d826
+ sha256sums = af25984f537976cbc457039e5780ca1101a14aac58b12a87e05db712292c6ae8
+ sha256sums = 0f7cefb3cffa69137b1654c342c20a3f7f9299035eb63e8663bfbc61c54117fd
+ sha256sums = 667ecd0b46cd8af6c29a292a1faaa65d868a54155d42d48053f7b66cc70e1142
pkgname = mingw-w64-qt6-base
diff --git a/0001-Use-CMake-s-default-import-library-suffix.patch b/0001-Use-CMake-s-default-import-library-suffix.patch
index cdbebd61f774..11b121ee41e2 100644
--- a/0001-Use-CMake-s-default-import-library-suffix.patch
+++ b/0001-Use-CMake-s-default-import-library-suffix.patch
@@ -1,4 +1,4 @@
-From c704940ba6a38f36b40fa021764ff45ccf37151c Mon Sep 17 00:00:00 2001
+From 586f94dd358cc00e35eb30b09250c597c8b020ef Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 5 Nov 2020 22:08:10 +0100
Subject: [PATCH 1/8] Use CMake's default import library suffix
@@ -13,10 +13,10 @@ Change-Id: I3dbedaec74683e5bfd008f7f2fd1e046dfb921b2
5 files changed, 21 insertions(+), 6 deletions(-)
diff --git a/cmake/QtPriHelpers.cmake b/cmake/QtPriHelpers.cmake
-index ed6513133f..2d8de2011b 100644
+index cb20cfcf43..6983987dd3 100644
--- a/cmake/QtPriHelpers.cmake
+++ b/cmake/QtPriHelpers.cmake
-@@ -401,9 +401,13 @@ QT.${config_module_name}_private.disabled_features = ${disabled_private_features
+@@ -506,9 +506,13 @@ QT.${config_module_name}_private.disabled_features = ${disabled_private_features
qt_path_join(private_pri_file_path "${target_path}" "${private_pri_file_name}")
list(APPEND pri_files "${private_pri_file_path}")
@@ -31,7 +31,7 @@ index ed6513133f..2d8de2011b 100644
${CMAKE_EXTRA_SHARED_LIBRARY_SUFFIXES}
${CMAKE_STATIC_LIBRARY_SUFFIX})
if(MSVC)
-@@ -828,9 +832,13 @@ CONFIG += ${private_config_joined}
+@@ -933,9 +937,13 @@ CONFIG += ${private_config_joined}
list(APPEND inputs "${preliminary_pri_root}/${cfg}/${pri_data_cmake_file}")
endforeach()
@@ -98,7 +98,7 @@ index 24ed125f12..73ebe453d3 100644
CMAKE_WINMAIN_FILE_LOCATION_DEBUG = qtmain$${QT_LIBINFIX}$${debug_suffix}.lib
CMAKE_WINMAIN_FILE_LOCATION_RELEASE = qtmain$${QT_LIBINFIX}.lib
diff --git a/src/corelib/Qt6CoreMacros.cmake b/src/corelib/Qt6CoreMacros.cmake
-index 51fa960c5b..8ccb7dc9c4 100644
+index e2aa89f72c..3250b2f4f8 100644
--- a/src/corelib/Qt6CoreMacros.cmake
+++ b/src/corelib/Qt6CoreMacros.cmake
@@ -495,7 +495,6 @@ function(_qt_internal_apply_win_prefix_and_suffix target)
@@ -110,5 +110,5 @@ index 51fa960c5b..8ccb7dc9c4 100644
get_target_property(target_type ${target} TYPE)
if(target_type STREQUAL "STATIC_LIBRARY")
--
-2.33.0
+2.33.1
diff --git a/0002-Fix-finding-D-Bus.patch b/0002-Fix-finding-D-Bus.patch
index 7a8a1c34ea7d..5fd21e6b272c 100644
--- a/0002-Fix-finding-D-Bus.patch
+++ b/0002-Fix-finding-D-Bus.patch
@@ -1,4 +1,4 @@
-From edfa3c0737be5ace47c0b7380a4da365f763f776 Mon Sep 17 00:00:00 2001
+From 8f42d8487b7c9afb9b8f582e0aba48143bf47536 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Wed, 7 Oct 2020 12:13:37 +0200
Subject: [PATCH 2/8] Fix finding D-Bus
@@ -20,5 +20,5 @@ index e227d224e0..bdbcab9eb3 100644
+ set_property(TARGET dbus-1 PROPERTY IMPORTED_IMPLIB ${DBus1_LIBRARY})
+endif()
--
-2.33.0
+2.33.1
diff --git a/0003-Fix-using-static-PCRE2-and-DBus-1.patch b/0003-Fix-using-static-PCRE2-and-DBus-1.patch
index 6846c84c30c3..b2d83a126796 100644
--- a/0003-Fix-using-static-PCRE2-and-DBus-1.patch
+++ b/0003-Fix-using-static-PCRE2-and-DBus-1.patch
@@ -1,4 +1,4 @@
-From 62540d952c458408ee502168821aaeec1762c2e3 Mon Sep 17 00:00:00 2001
+From 42a00262b863de893a81fd289f39c317c5f0eebc Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 5 Nov 2020 21:13:19 +0100
Subject: [PATCH 3/8] Fix using static PCRE2 and DBus-1
@@ -13,11 +13,11 @@ Change-Id: I2387b79462b6d183b71f9433dd937f63fc7ef26e
2 files changed, 9 insertions(+)
diff --git a/src/corelib/text/qregularexpression.cpp b/src/corelib/text/qregularexpression.cpp
-index e055ae064a..6111bf6248 100644
+index b0728bca4a..2bfe48bd21 100644
--- a/src/corelib/text/qregularexpression.cpp
+++ b/src/corelib/text/qregularexpression.cpp
-@@ -53,6 +53,11 @@
- #include <QtCore/qdatastream.h>
+@@ -57,6 +57,11 @@
+ #endif
#define PCRE2_CODE_UNIT_WIDTH 16
+#ifdef QT_STATIC
@@ -44,5 +44,5 @@ index accaa4f5ed..4b11c74caa 100644
# include <dbus/dbus.h>
#else
--
-2.33.0
+2.33.1
diff --git a/0004-Fix-transitive-dependencies-of-static-libraries.patch b/0004-Fix-transitive-dependencies-of-static-libraries.patch
index 3bd83cd0041b..0ff1a545bca0 100644
--- a/0004-Fix-transitive-dependencies-of-static-libraries.patch
+++ b/0004-Fix-transitive-dependencies-of-static-libraries.patch
@@ -1,4 +1,4 @@
-From 44cca85927e640bc145f15832e774a25647f5800 Mon Sep 17 00:00:00 2001
+From f6e2b65e02ff6c29fe77dbb6b12f50d8a9414068 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 5 Nov 2020 21:59:33 +0100
Subject: [PATCH 4/8] Fix transitive dependencies (of static libraries)
@@ -133,5 +133,5 @@ index 8ed84c9028..807dc34cf7 100644
Qt::CorePrivate
Qt::SqlPrivate
--
-2.33.0
+2.33.1
diff --git a/0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch b/0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch
index cc76a03fb98a..4831fb2bd1c6 100644
--- a/0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch
+++ b/0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch
@@ -1,4 +1,4 @@
-From a6d240cbda91d45efab6b2679fc28be54c1a5dff Mon Sep 17 00:00:00 2001
+From 0757e7a6edc83bcb6def8d705e51ff8b764dc740 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Mon, 2 Nov 2020 13:47:45 +0100
Subject: [PATCH 5/8] Fix libjpeg workaround for conflict with rpcndr.h
@@ -25,5 +25,5 @@ index a17afc0f69..72708145f4 100644
#ifdef const
# undef const // remove crazy C hackery in jconfig.h
--
-2.33.0
+2.33.1
diff --git a/0006-Support-finding-static-MariaDB-client-library.patch b/0006-Support-finding-static-MariaDB-client-library.patch
index 7be397655c58..ed71d790afd1 100644
--- a/0006-Support-finding-static-MariaDB-client-library.patch
+++ b/0006-Support-finding-static-MariaDB-client-library.patch
@@ -1,4 +1,4 @@
-From 9923349598db981325d10c2836c431cbda3095b7 Mon Sep 17 00:00:00 2001
+From c7d311a6364dcf8b83e68025ed269fa3a3beff88 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 8 Nov 2020 00:33:12 +0100
Subject: [PATCH 6/8] Support finding static MariaDB client library
@@ -27,5 +27,5 @@ index 0fcba2148e..ab4f6fdc9e 100644
include(FindPackageHandleStandardArgs)
--
-2.33.0
+2.33.1
diff --git a/0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch b/0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch
index 2cb73c434944..e37f5487ff4b 100644
--- a/0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch
+++ b/0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch
@@ -1,4 +1,4 @@
-From 6139785883e6ceee0369390debd39a90c18d821b Mon Sep 17 00:00:00 2001
+From c398d6b9ca06d723c03d0c7f0f96f34a475d7f53 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 8 Nov 2020 00:34:09 +0100
Subject: [PATCH 7/8] Allow overriding CMAKE_FIND_LIBRARY_SUFFIXES to prefer
@@ -10,7 +10,7 @@ Change-Id: I4c617e0706044d31da1bd56ae51615dc8ed37099
1 file changed, 4 insertions(+)
diff --git a/cmake/QtBuildInternals/QtBuildInternalsConfig.cmake b/cmake/QtBuildInternals/QtBuildInternalsConfig.cmake
-index 89c13afe01..6a21b6e266 100644
+index 472ce4fd0b..3f11c42c5a 100644
--- a/cmake/QtBuildInternals/QtBuildInternalsConfig.cmake
+++ b/cmake/QtBuildInternals/QtBuildInternalsConfig.cmake
@@ -1,6 +1,10 @@
@@ -25,5 +25,5 @@ index 89c13afe01..6a21b6e266 100644
#
# Macros and functions for building Qt modules
--
-2.33.0
+2.33.1
diff --git a/0008-Fix-crashes-in-rasterization-code-using-setjmp.patch b/0008-Fix-crashes-in-rasterization-code-using-setjmp.patch
index 0c820ed99eac..c4c1dda21fe5 100644
--- a/0008-Fix-crashes-in-rasterization-code-using-setjmp.patch
+++ b/0008-Fix-crashes-in-rasterization-code-using-setjmp.patch
@@ -1,4 +1,4 @@
-From a8f1c4b28f9f4d3b9dbebcacfa9ad3047332016f Mon Sep 17 00:00:00 2001
+From 925e67d1b020c19b4f453085765c02320b23f014 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 26 Jun 2021 22:24:12 +0200
Subject: [PATCH 8/8] Fix crashes in rasterization code using setjmp
@@ -28,7 +28,7 @@ Change-Id: I01937d13569dd01ab4cb1f608020544c93bc343c
rename src/gui/painting/{qgrayraster.c => qgrayraster.cpp} (98%)
diff --git a/src/gui/CMakeLists.txt b/src/gui/CMakeLists.txt
-index 905afd4038..e4c23c4714 100644
+index 1e212b25fc..dd8d376024 100644
--- a/src/gui/CMakeLists.txt
+++ b/src/gui/CMakeLists.txt
@@ -165,7 +165,7 @@ qt_internal_add_module(Gui
@@ -40,7 +40,7 @@ index 905afd4038..e4c23c4714 100644
painting/qicc.cpp painting/qicc_p.h
painting/qimagescale.cpp
painting/qmemrotate.cpp painting/qmemrotate_p.h
-@@ -279,6 +279,11 @@ qt_internal_add_module(Gui
+@@ -272,6 +272,11 @@ qt_internal_add_module(Gui
"kernel/qt_gui_pch.h"
)
@@ -248,5 +248,5 @@ index e2326a56c1..7b30969ec8 100644
"Description": "FreeType is a freely available software library to render fonts.",
"Homepage": "http://www.freetype.org",
--
-2.33.0
+2.33.1
diff --git a/PKGBUILD b/PKGBUILD
index a4bbeacd58a7..8761f67d6fe4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
# All patches are managed at https://github.com/Martchus/qtbase
pkgname=mingw-w64-qt6-base
-_qtver=6.2.0
+_qtver=6.2.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -39,15 +39,15 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/subm
'0006-Support-finding-static-MariaDB-client-library.patch'
'0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch'
'0008-Fix-crashes-in-rasterization-code-using-setjmp.patch')
-sha256sums=('fdfff0716d093bcb6bcd53746ce1d3c9701a6bf3326d47813866d43949b47769'
- '02811ca9f69e29242e817cae9afbcbd6b0eb1377c5f680a835c517b9d82e42ff'
- '14524bf028ba07e04a6428e0eb2049d3743571d181d5037f65e2624af5e57bf4'
- '25c6fef400bac3b701ddf5d429d74fc744c612e683838cdf44b874bc24d379be'
- 'b0cb32ec2dadc4479c9090f1f9326ff5b26550b94c88380e12ae68c0535f56af'
- '00ad6ee9b73a128a94e813cccf17122232063cb0dd503952b8858012da0cc2d3'
- 'f33c044eed6224c4f71c43de5157c8ff1028ccdc3cefa7b26b37e6705ea7483c'
- '937833cb719d9ec40b049f4440002c4507666ea53bfd0f4f9af4cc849a9016e3'
- '3b40db6950bcbafd0d921b6d9683c03da47581a8b465cda6ac8781135ef8db17')
+sha256sums=('2c5f07b5c3ea27d3fc1a46686ea3fb6724f94dddf1fb007de3eb0bdb87429079'
+ 'be2cb794752635df017e97601646f7cb2f6b22b0a2411ad23d7ada5d685dc97f'
+ 'ef7e3305f8bb11482bb6b9dd5dea16a0bbed293d7b615c75caa10db304862a52'
+ '3f80ae4137d875e60043b1d974479bbe9b331beebb794c41b9b4514c2e5e8a9b'
+ 'b27ce3e4082d687524035548ef8a903f272447a5a57a79edc500c0a9ff1d5dcb'
+ '1c386bcaede05b6bd1c01e5e41aff157447551733ac9f56428de3cae8761d826'
+ 'af25984f537976cbc457039e5780ca1101a14aac58b12a87e05db712292c6ae8'
+ '0f7cefb3cffa69137b1654c342c20a3f7f9299035eb63e8663bfbc61c54117fd'
+ '667ecd0b46cd8af6c29a292a1faaa65d868a54155d42d48053f7b66cc70e1142')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
diff --git a/qtbase-sha256.txt b/qtbase-sha256.txt
index a71f0eda9937..c8f98b491e99 100644
--- a/qtbase-sha256.txt
+++ b/qtbase-sha256.txt
@@ -1 +1 @@
-fdfff0716d093bcb6bcd53746ce1d3c9701a6bf3326d47813866d43949b47769
+2c5f07b5c3ea27d3fc1a46686ea3fb6724f94dddf1fb007de3eb0bdb87429079