summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--0001-Use-CMake-s-default-import-library-suffix.patch6
-rw-r--r--0002-Fix-finding-D-Bus.patch4
-rw-r--r--0003-Fix-using-static-PCRE2-and-DBus-1.patch4
-rw-r--r--0004-Fix-transitive-dependencies-of-static-libraries.patch15
-rw-r--r--0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch4
-rw-r--r--0006-Support-finding-static-MariaDB-client-library.patch4
-rw-r--r--0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch6
-rw-r--r--0008-Fix-crashes-in-rasterization-code-using-setjmp.patch4
-rw-r--r--PKGBUILD20
-rw-r--r--qtbase-sha256.txt2
11 files changed, 45 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f894e3ba8b3..ea0055a022d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-base-static
pkgdesc = A cross-platform application and UI framework (mingw-w64)
- pkgver = 6.2.2
+ pkgver = 6.2.3
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -35,7 +35,7 @@ pkgbase = mingw-w64-qt6-base-static
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.2/6.2.2/submodules/qtbase-everywhere-src-6.2.2.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.2/6.2.3/submodules/qtbase-everywhere-src-6.2.3.tar.xz
source = 0001-Use-CMake-s-default-import-library-suffix.patch
source = 0002-Fix-finding-D-Bus.patch
source = 0003-Fix-using-static-PCRE2-and-DBus-1.patch
@@ -44,14 +44,14 @@ pkgbase = mingw-w64-qt6-base-static
source = 0006-Support-finding-static-MariaDB-client-library.patch
source = 0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch
source = 0008-Fix-crashes-in-rasterization-code-using-setjmp.patch
- sha256sums = 85ab9180180c2eaf84cd11ae4c6d5a6a69f2f8fd7260aaccfd91a3e7e7232c1a
- sha256sums = 70abdd5f8bfafc46a833a3dc9ea3eea7050cc01ac7b54e0f4b9a25dc44ff4faa
- sha256sums = 3651ea66d40665681cd64d9ec0e600d32ad65adb7922869bd4c02aeb3c1eb66c
- sha256sums = e948083c12aa3c468b2845174ec3ee796bba7ddb2447f44f321b31b7e354152a
- sha256sums = 0736df9ed395025851be441bb422128d046b82847d7e546abbdaf63391cddb43
- sha256sums = d408dba9f000a69aa4a684ec94aba843b2c2f1462562b88f07846480da7e5a54
- sha256sums = a7674e5475f2b3f64926ccf02fb0881e2861beed5643143a87cacd9e940bd699
- sha256sums = 02818bb9ac13c14d18c3bf5a0729666c37b8b0248088e2237c66049c0ad62a10
- sha256sums = 2353af5cfaf83090690d8cd933e349781b45328742fb1c4ad9bcbe51f03aa35a
+ sha256sums = 34d6d0072e197241463c417ad72610c3d44e2efd6062868e9a95283103d75df4
+ sha256sums = a7a41b7bf86616846347eef2fc29cb8927d402b3f96c6bfed72103084a1a6693
+ sha256sums = 9272e36e21c5af94e5cb3c21dfaa693f4f351abf7da3ca8e3c7700ec347256ec
+ sha256sums = 3a2022ec8a9395f7d369fbc3a45434f237d80712a5dcf44261d06e3cd4932e02
+ sha256sums = 9e4ded98abaa44b13982202427b25c4a1839cc1a9ed3b66568e4f7ea36992dcd
+ sha256sums = e365d7ed9560da5f03b4c32788e5eef9f22b0eeeedf2e40bd5c1092c2eca1a87
+ sha256sums = 2ce06fe5f7abbcb497c158d96d3dbe8b25f71bab1d09b110988588853b6ede3b
+ sha256sums = df44dfb678bc91b706987f6e067b75341b6411ec3f89bc05462533153f90b410
+ sha256sums = cbf11ace17ba1ebe0b9195107415c562a666490572d68ea362212c8c22014a1f
pkgname = mingw-w64-qt6-base-static
diff --git a/0001-Use-CMake-s-default-import-library-suffix.patch b/0001-Use-CMake-s-default-import-library-suffix.patch
index 98ba12bd0065..b258d1f59079 100644
--- a/0001-Use-CMake-s-default-import-library-suffix.patch
+++ b/0001-Use-CMake-s-default-import-library-suffix.patch
@@ -1,4 +1,4 @@
-From 6d8a5f0107d7fdcc837f4737decfc44406fb8c14 Mon Sep 17 00:00:00 2001
+From 9df2dbd52b07e1964c3949c2b63970cf304c3bc7 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 5 Nov 2020 22:08:10 +0100
Subject: [PATCH 1/8] Use CMake's default import library suffix
@@ -98,7 +98,7 @@ index 24ed125f12..73ebe453d3 100644
CMAKE_WINMAIN_FILE_LOCATION_DEBUG = qtmain$${QT_LIBINFIX}$${debug_suffix}.lib
CMAKE_WINMAIN_FILE_LOCATION_RELEASE = qtmain$${QT_LIBINFIX}.lib
diff --git a/src/corelib/Qt6CoreMacros.cmake b/src/corelib/Qt6CoreMacros.cmake
-index a30e7ec9fb..8c9927a276 100644
+index 5741e05bf7..39e4b2bd9e 100644
--- a/src/corelib/Qt6CoreMacros.cmake
+++ b/src/corelib/Qt6CoreMacros.cmake
@@ -495,7 +495,6 @@ function(_qt_internal_apply_win_prefix_and_suffix target)
@@ -110,5 +110,5 @@ index a30e7ec9fb..8c9927a276 100644
get_target_property(target_type ${target} TYPE)
if(target_type STREQUAL "STATIC_LIBRARY")
--
-2.34.1
+2.35.0
diff --git a/0002-Fix-finding-D-Bus.patch b/0002-Fix-finding-D-Bus.patch
index 71b9a3c0d3c0..8d76dc5f2240 100644
--- a/0002-Fix-finding-D-Bus.patch
+++ b/0002-Fix-finding-D-Bus.patch
@@ -1,4 +1,4 @@
-From 178c7bcd692d7d8367456aacbec4715a4bd2b845 Mon Sep 17 00:00:00 2001
+From 947f67d520c060d0b7d9915a530dd5465fb09d3e Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Wed, 7 Oct 2020 12:13:37 +0200
Subject: [PATCH 2/8] Fix finding D-Bus
@@ -20,5 +20,5 @@ index e227d224e0..bdbcab9eb3 100644
+ set_property(TARGET dbus-1 PROPERTY IMPORTED_IMPLIB ${DBus1_LIBRARY})
+endif()
--
-2.34.1
+2.35.0
diff --git a/0003-Fix-using-static-PCRE2-and-DBus-1.patch b/0003-Fix-using-static-PCRE2-and-DBus-1.patch
index 7e18fb1cf2db..188cbc20e6d7 100644
--- a/0003-Fix-using-static-PCRE2-and-DBus-1.patch
+++ b/0003-Fix-using-static-PCRE2-and-DBus-1.patch
@@ -1,4 +1,4 @@
-From 99ddd863a93afc92c622f2eba83f15d2b0b96af6 Mon Sep 17 00:00:00 2001
+From 7065ae3429f350e5597ecde9114dff5ce5626937 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 5 Nov 2020 21:13:19 +0100
Subject: [PATCH 3/8] Fix using static PCRE2 and DBus-1
@@ -44,5 +44,5 @@ index accaa4f5ed..4b11c74caa 100644
# include <dbus/dbus.h>
#else
--
-2.34.1
+2.35.0
diff --git a/0004-Fix-transitive-dependencies-of-static-libraries.patch b/0004-Fix-transitive-dependencies-of-static-libraries.patch
index 54d9f2199fb3..b88ddcc9468f 100644
--- a/0004-Fix-transitive-dependencies-of-static-libraries.patch
+++ b/0004-Fix-transitive-dependencies-of-static-libraries.patch
@@ -1,4 +1,4 @@
-From f60b0a86b113e248ba3574633856e59d35d1ea4b Mon Sep 17 00:00:00 2001
+From 72a9795f3610e10bed26b25b46ec7d12f9ad1954 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Thu, 5 Nov 2020 21:59:33 +0100
Subject: [PATCH 4/8] Fix transitive dependencies (of static libraries)
@@ -8,10 +8,9 @@ corresponding find modules. This change allows adding the required
dependencies by setting certain variables, e.g. within the toolchain file.
This change also disables the upstream hack for OpenSSL's dependencies
-as it is even more hacky to hardcode the library names and the casing
-they use doesn't even work when building on GNU/Linux.
+as it is even more hacky to hardcode the library names.
-Change-Id: I9afee4f1a1debb482ede63421de86adf1c7c5adc
+Change-Id: I3baec612ee071eec77f756b18bbb9af87663527c
---
.../3rdparty/extra-cmake-modules/find-modules/FindGLIB2.cmake | 2 +-
cmake/FindMySQL.cmake | 1 +
@@ -59,19 +58,19 @@ index bdbcab9eb3..06e9af49f6 100644
+ set_property(TARGET dbus-1 PROPERTY INTERFACE_LINK_LIBRARIES "${DBUS1_DEPENDENCIES}")
endif()
diff --git a/cmake/FindWrapOpenSSL.cmake b/cmake/FindWrapOpenSSL.cmake
-index 486686d338..1110116013 100644
+index 7b6dccb1d2..550c5134fb 100644
--- a/cmake/FindWrapOpenSSL.cmake
+++ b/cmake/FindWrapOpenSSL.cmake
@@ -11,7 +11,7 @@ set(WrapOpenSSL_FOUND OFF)
find_package(WrapOpenSSLHeaders ${WrapOpenSSL_FIND_VERSION})
- if(OpenSSL_FOUND)
+ if(TARGET OpenSSL::SSL)
- if(WIN32)
+ if(WIN32 AND NOT MINGW)
get_target_property(libType OpenSSL::Crypto TYPE)
if(libType STREQUAL "ALIAS")
get_target_property(writableLib OpenSSL::Crypto ALIASED_TARGET)
-@@ -26,7 +26,7 @@ if(OpenSSL_FOUND)
+@@ -26,7 +26,7 @@ if(TARGET OpenSSL::SSL)
set(WrapOpenSSL_FOUND ON)
add_library(WrapOpenSSL::WrapOpenSSL INTERFACE IMPORTED)
@@ -133,5 +132,5 @@ index d3a6a8588e..743154fc50 100644
Qt::CorePrivate
Qt::SqlPrivate
--
-2.34.1
+2.35.0
diff --git a/0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch b/0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch
index d8dd89f66739..198054360b71 100644
--- a/0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch
+++ b/0005-Fix-libjpeg-workaround-for-conflict-with-rpcndr.h.patch
@@ -1,4 +1,4 @@
-From 4a907550b9abc3f7519cf3c2e990bbc4824e4c2c Mon Sep 17 00:00:00 2001
+From 958130bfc5c3b80a430d89e46a7689e040c38c9e Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Mon, 2 Nov 2020 13:47:45 +0100
Subject: [PATCH 5/8] Fix libjpeg workaround for conflict with rpcndr.h
@@ -25,5 +25,5 @@ index a17afc0f69..72708145f4 100644
#ifdef const
# undef const // remove crazy C hackery in jconfig.h
--
-2.34.1
+2.35.0
diff --git a/0006-Support-finding-static-MariaDB-client-library.patch b/0006-Support-finding-static-MariaDB-client-library.patch
index 84b8d9d40beb..987d7654ce87 100644
--- a/0006-Support-finding-static-MariaDB-client-library.patch
+++ b/0006-Support-finding-static-MariaDB-client-library.patch
@@ -1,4 +1,4 @@
-From 0b0834acba35161a25517494e7d73ec7e889bdd6 Mon Sep 17 00:00:00 2001
+From 2baf3496ba7e51582f2bfd68c68d4712d10949aa Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 8 Nov 2020 00:33:12 +0100
Subject: [PATCH 6/8] Support finding static MariaDB client library
@@ -27,5 +27,5 @@ index 0fcba2148e..ab4f6fdc9e 100644
include(FindPackageHandleStandardArgs)
--
-2.34.1
+2.35.0
diff --git a/0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch b/0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch
index cb5305b0bb5b..d3ba0b22d8f6 100644
--- a/0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch
+++ b/0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch
@@ -1,4 +1,4 @@
-From aad825321c01ccdea8efc289a6e701d1ae11948f Mon Sep 17 00:00:00 2001
+From c679b09bd5e579f0bf33ddd81b022b72324eda40 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 8 Nov 2020 00:34:09 +0100
Subject: [PATCH 7/8] Allow overriding CMAKE_FIND_LIBRARY_SUFFIXES to prefer
@@ -10,7 +10,7 @@ Change-Id: I4c617e0706044d31da1bd56ae51615dc8ed37099
1 file changed, 4 insertions(+)
diff --git a/cmake/QtBuildInternals/QtBuildInternalsConfig.cmake b/cmake/QtBuildInternals/QtBuildInternalsConfig.cmake
-index 472ce4fd0b..3f11c42c5a 100644
+index a10296d45b..cd3c9c3e29 100644
--- a/cmake/QtBuildInternals/QtBuildInternalsConfig.cmake
+++ b/cmake/QtBuildInternals/QtBuildInternalsConfig.cmake
@@ -1,6 +1,10 @@
@@ -25,5 +25,5 @@ index 472ce4fd0b..3f11c42c5a 100644
#
# Macros and functions for building Qt modules
--
-2.34.1
+2.35.0
diff --git a/0008-Fix-crashes-in-rasterization-code-using-setjmp.patch b/0008-Fix-crashes-in-rasterization-code-using-setjmp.patch
index a478e27ac0f6..0489ee803228 100644
--- a/0008-Fix-crashes-in-rasterization-code-using-setjmp.patch
+++ b/0008-Fix-crashes-in-rasterization-code-using-setjmp.patch
@@ -1,4 +1,4 @@
-From 343e997afbad4830ff3ea76179659a4e4dc21556 Mon Sep 17 00:00:00 2001
+From 291f15bce942ecfcb5edffb3bd7a292a57e19779 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sat, 26 Jun 2021 22:24:12 +0200
Subject: [PATCH 8/8] Fix crashes in rasterization code using setjmp
@@ -248,5 +248,5 @@ index e2326a56c1..7b30969ec8 100644
"Description": "FreeType is a freely available software library to render fonts.",
"Homepage": "http://www.freetype.org",
--
-2.34.1
+2.35.0
diff --git a/PKGBUILD b/PKGBUILD
index 56536198f175..b06ea39c20c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
# All patches are managed at https://github.com/Martchus/qtbase
pkgname=mingw-w64-qt6-base-static
-_qtver=6.2.2
+_qtver=6.2.3
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -39,15 +39,15 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/subm
'0006-Support-finding-static-MariaDB-client-library.patch'
'0007-Allow-overriding-CMAKE_FIND_LIBRARY_SUFFIXES-to-pref.patch'
'0008-Fix-crashes-in-rasterization-code-using-setjmp.patch')
-sha256sums=('85ab9180180c2eaf84cd11ae4c6d5a6a69f2f8fd7260aaccfd91a3e7e7232c1a'
- '70abdd5f8bfafc46a833a3dc9ea3eea7050cc01ac7b54e0f4b9a25dc44ff4faa'
- '3651ea66d40665681cd64d9ec0e600d32ad65adb7922869bd4c02aeb3c1eb66c'
- 'e948083c12aa3c468b2845174ec3ee796bba7ddb2447f44f321b31b7e354152a'
- '0736df9ed395025851be441bb422128d046b82847d7e546abbdaf63391cddb43'
- 'd408dba9f000a69aa4a684ec94aba843b2c2f1462562b88f07846480da7e5a54'
- 'a7674e5475f2b3f64926ccf02fb0881e2861beed5643143a87cacd9e940bd699'
- '02818bb9ac13c14d18c3bf5a0729666c37b8b0248088e2237c66049c0ad62a10'
- '2353af5cfaf83090690d8cd933e349781b45328742fb1c4ad9bcbe51f03aa35a')
+sha256sums=('34d6d0072e197241463c417ad72610c3d44e2efd6062868e9a95283103d75df4'
+ 'a7a41b7bf86616846347eef2fc29cb8927d402b3f96c6bfed72103084a1a6693'
+ '9272e36e21c5af94e5cb3c21dfaa693f4f351abf7da3ca8e3c7700ec347256ec'
+ '3a2022ec8a9395f7d369fbc3a45434f237d80712a5dcf44261d06e3cd4932e02'
+ '9e4ded98abaa44b13982202427b25c4a1839cc1a9ed3b66568e4f7ea36992dcd'
+ 'e365d7ed9560da5f03b4c32788e5eef9f22b0eeeedf2e40bd5c1092c2eca1a87'
+ '2ce06fe5f7abbcb497c158d96d3dbe8b25f71bab1d09b110988588853b6ede3b'
+ 'df44dfb678bc91b706987f6e067b75341b6411ec3f89bc05462533153f90b410'
+ 'cbf11ace17ba1ebe0b9195107415c562a666490572d68ea362212c8c22014a1f')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
diff --git a/qtbase-sha256.txt b/qtbase-sha256.txt
index 3cff07eb2fb2..efb9ac9a4de9 100644
--- a/qtbase-sha256.txt
+++ b/qtbase-sha256.txt
@@ -1 +1 @@
-85ab9180180c2eaf84cd11ae4c6d5a6a69f2f8fd7260aaccfd91a3e7e7232c1a
+34d6d0072e197241463c417ad72610c3d44e2efd6062868e9a95283103d75df4