summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Exclude-qmltime-when-cross-compiling.patch33
-rw-r--r--PKGBUILD19
-rw-r--r--PKGBUILD.sh.ep2
-rw-r--r--qtdeclarative-sha256.txt2
5 files changed, 56 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 221591fca14a..aa533f23c012 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-declarative
pkgdesc = Classes for QML and JavaScript languages (mingw-w64)
- pkgver = 6.0.0
+ pkgver = 6.0.1
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -21,8 +21,10 @@ pkgbase = mingw-w64-qt6-declarative
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.0/6.0.0/submodules/qtdeclarative-everywhere-src-6.0.0.tar.xz
- sha256sums = 8535fe31fa3e876b8f2d3954efcdca47b3813adf228c1640608fb9f4c7b2c1a6
+ source = https://download.qt.io/official_releases/qt/6.0/6.0.1/submodules/qtdeclarative-everywhere-src-6.0.1.tar.xz
+ source = 0001-Exclude-qmltime-when-cross-compiling.patch
+ sha256sums = 6e234508d3d624bdeb90e67f09f95b7bb9bc712f60f82f64ddd99132eff5f610
+ sha256sums = c252273963e8508483b1edd09463640fdaee4d4c123dc4f000940f9f237f4e54
pkgname = mingw-w64-qt6-declarative
diff --git a/0001-Exclude-qmltime-when-cross-compiling.patch b/0001-Exclude-qmltime-when-cross-compiling.patch
new file mode 100644
index 000000000000..c0d939b7a690
--- /dev/null
+++ b/0001-Exclude-qmltime-when-cross-compiling.patch
@@ -0,0 +1,33 @@
+From 67c5945fa0c3146d2f69c0c71f6ce5abe00edcc0 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Fri, 5 Feb 2021 02:22:45 +0100
+Subject: [PATCH] Exclude qmltime when cross compiling
+
+as the build script would attempt to set the property of a target
+which does not exist (leading to a configuration error).
+
+This tool seems not really requird and is already disabled when
+compiling for Android or when compiling static libraries anyways.
+That's likely also why upstream did not notice this problem so far.
+---
+ tools/CMakeLists.txt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
+index 8438e8c6fa..23753dd0dc 100644
+--- a/tools/CMakeLists.txt
++++ b/tools/CMakeLists.txt
+@@ -30,7 +30,9 @@ if(QT_FEATURE_qml_preview AND QT_FEATURE_thread AND NOT ANDROID AND NOT WASM AND
+ endif()
+ if(QT_BUILD_SHARED_LIBS AND QT_FEATURE_thread AND TARGET Qt::Quick AND NOT ANDROID AND NOT WASM AND NOT rtems)
+ add_subdirectory(qmlscene)
+- add_subdirectory(qmltime)
++ if(NOT CMAKE_CROSSCOMPILING)
++ add_subdirectory(qmltime)
++ endif()
+ endif()
+ if(QT_BUILD_SHARED_LIBS AND QT_FEATURE_process AND QT_FEATURE_regularexpression AND QT_FEATURE_thread AND TARGET Qt::Quick AND NOT ANDROID AND NOT WASM AND NOT rtems)
+ add_subdirectory(qmlplugindump)
+--
+2.30.0
+
diff --git a/PKGBUILD b/PKGBUILD
index f0385cbedb88..b9ed941acb46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-declarative
-_qtver=6.0.0
+_qtver=6.0.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -17,11 +17,23 @@ optdepends=('qt6-declarative: development tools')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qtdeclarative-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('8535fe31fa3e876b8f2d3954efcdca47b3813adf228c1640608fb9f4c7b2c1a6')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Exclude-qmltime-when-cross-compiling.patch')
+sha256sums=('6e234508d3d624bdeb90e67f09f95b7bb9bc712f60f82f64ddd99132eff5f610'
+ 'c252273963e8508483b1edd09463640fdaee4d4c123dc4f000940f9f237f4e54')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
+
build() {
for _arch in ${_architectures}; do
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
@@ -48,6 +60,7 @@ package() {
find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ [[ -d "$pkgdir/usr/$_arch/share/doc" ]] && rm -r "$pkgdir/usr/$_arch/share/doc"
done
install -d "$pkgdir"/usr/share/licenses
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index f8adb0ceabe2..c8146ece72cb 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,6 +1,6 @@
% layout 'mingw-w64-qt6-module', has_binaries => 1;
\
-_qtver=6.0.0
+_qtver=6.0.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
diff --git a/qtdeclarative-sha256.txt b/qtdeclarative-sha256.txt
index 989eb316149c..ecf5fe19ee9b 100644
--- a/qtdeclarative-sha256.txt
+++ b/qtdeclarative-sha256.txt
@@ -1 +1 @@
-8535fe31fa3e876b8f2d3954efcdca47b3813adf228c1640608fb9f4c7b2c1a6
+6e234508d3d624bdeb90e67f09f95b7bb9bc712f60f82f64ddd99132eff5f610