summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 508a0f3acf8d..1c3a3fd1979a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-rapidjson
pkgdesc = A fast JSON parser/generator for C++ with both SAX/DOM style API (mingw-w64)
pkgver = 1.1.0
- pkgrel = 5
+ pkgrel = 7
url = https://github.com/miloyip/rapidjson
arch = any
license = MIT
@@ -10,13 +10,16 @@ pkgbase = mingw-w64-rapidjson
makedepends = mingw-w64-gcc
makedepends = mingw-w64-cmake
makedepends = ninja
+ makedepends = git
options = !buildflags
options = staticlibs
options = !strip
options = !emptydirs
source = rapidjson-1.1.0.tar.gz::https://github.com/miloyip/rapidjson/archive/v1.1.0.tar.gz
+ source = https://github.com/Tencent/rapidjson/commit/3b2441b8.patch
source = git+https://github.com/google/googletest.git#commit=2fe3bd994b3189899d93f1d5a881e725e046fdc2
- sha256sums = bf7ced29704a1e696fbccf2a2b4ea068e7774fa37f6d7dd4039d0787f8bed98e
- sha256sums = SKIP
+ sha512sums = 2e82a4bddcd6c4669541f5945c2d240fb1b4fdd6e239200246d3dd50ce98733f0a4f6d3daa56f865d8c88779c036099c52a9ae85d47ad263686b68a88d832dff
+ sha512sums = 5002ff20a65b7d057411e39adf7f5a29eddff818d20579900b655df4d838b984a1b68f488232e1990b592943a70943619d924da1c4e1d2ce0d3ef65bc40f75d6
+ sha512sums = SKIP
pkgname = mingw-w64-rapidjson
diff --git a/PKGBUILD b/PKGBUILD
index 99f6aae00f6b..b8b17bd4115d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,20 @@
_reponame=rapidjson
pkgname=mingw-w64-$_reponame
pkgver=1.1.0
-pkgrel=5
+pkgrel=7
pkgdesc='A fast JSON parser/generator for C++ with both SAX/DOM style API (mingw-w64)'
arch=('any')
url='https://github.com/miloyip/rapidjson'
license=('MIT')
-makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'ninja')
+makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'ninja' 'git')
checkdepends=('mingw-w64-wine' 'python')
source=(
"$_reponame-$pkgver.tar.gz::https://github.com/miloyip/$_reponame/archive/v$pkgver.tar.gz"
+ 'https://github.com/Tencent/rapidjson/commit/3b2441b8.patch'
'git+https://github.com/google/googletest.git#commit=2fe3bd994b3189899d93f1d5a881e725e046fdc2')
-sha256sums=('bf7ced29704a1e696fbccf2a2b4ea068e7774fa37f6d7dd4039d0787f8bed98e'
- 'SKIP')
+sha512sums=('2e82a4bddcd6c4669541f5945c2d240fb1b4fdd6e239200246d3dd50ce98733f0a4f6d3daa56f865d8c88779c036099c52a9ae85d47ad263686b68a88d832dff'
+ '5002ff20a65b7d057411e39adf7f5a29eddff818d20579900b655df4d838b984a1b68f488232e1990b592943a70943619d924da1c4e1d2ce0d3ef65bc40f75d6'
+ SKIP)
options=(!buildflags staticlibs !strip !emptydirs)
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -26,6 +28,8 @@ prepare() {
# disable -Werror as it is done in the regular rapidjson package
find -name CMakeLists.txt | xargs sed -e 's|-Werror||' -i # Don't use -Werror
+ patch -p1 -i ../3b2441b8.patch # Fix build with GCC 14
+
# exclude tests which don't run within WINE
sed -e 's:\(filestreamtest\|encodedstreamtest\|prettywritertest\|ostreamwrappertest\)\.cpp:#\0:g' -i test/unittest/CMakeLists.txt
}