summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD38
2 files changed, 27 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c555a10d78c6..6bb07efd3587 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Apr 14 09:28:33 UTC 2017
pkgbase = mingw-w64-rtmpdump
- pkgdesc = Tool to download rtmp streams (mingw-w64)
- pkgver = 2.4.r96.fa8646d
- pkgrel = 3
+ pkgdesc = A toolkit for RTMP streams (mingw-w64)
+ pkgver = 2.4.r99.f1b83c1
+ pkgrel = 1
url = https://rtmpdump.mplayerhq.hu/
arch = any
license = GPL2
@@ -12,12 +10,12 @@ pkgbase = mingw-w64-rtmpdump
makedepends = git
depends = mingw-w64-crt
depends = mingw-w64-gnutls
+ depends = mingw-w64-zlib
options = !strip
options = !buildflags
options = !makeflags
options = staticlibs
- source = git+https://git.ffmpeg.org/rtmpdump#commit=fa8646d
+ source = git+https://git.ffmpeg.org/rtmpdump#commit=f1b83c10d8beb43fcc70a6e88cf4325499f25857
sha256sums = SKIP
pkgname = mingw-w64-rtmpdump
-
diff --git a/PKGBUILD b/PKGBUILD
index 3b1df9896d64..1f4916a3745b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,32 @@
# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
pkgname=mingw-w64-rtmpdump
-pkgver=2.4.r96.fa8646d
-pkgrel=3
-pkgdesc="Tool to download rtmp streams (mingw-w64)"
-arch=('any')
-url="https://rtmpdump.mplayerhq.hu/"
-license=('GPL2' 'LGPL2.1')
-depends=('mingw-w64-crt' 'mingw-w64-gnutls')
-options=('!strip' '!buildflags' '!makeflags' 'staticlibs')
-makedepends=('mingw-w64-gcc' 'git')
-_commit='fa8646d'
-source=("git+https://git.ffmpeg.org/rtmpdump#commit=${_commit}")
-sha256sums=('SKIP')
+pkgver=2.4.r99.f1b83c1
+pkgrel=1
+pkgdesc='A toolkit for RTMP streams (mingw-w64)'
+arch=(any)
+url=https://rtmpdump.mplayerhq.hu/
+license=(
+ GPL2
+ LGPL2.1
+)
+depends=(
+ mingw-w64-crt
+ mingw-w64-gnutls
+ mingw-w64-zlib
+)
+options=(!strip !buildflags !makeflags staticlibs)
+makedepends=(
+ mingw-w64-gcc git
+)
+_commit=f1b83c10d8beb43fcc70a6e88cf4325499f25857
+source=(git+https://git.ffmpeg.org/rtmpdump#commit=${_commit})
+sha256sums=(SKIP)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
pkgver() {
cd rtmpdump
- _ver_name='2.4'
- _ver_commit='c28f1bab7822de97353849e7787b59e50bbb1428'
-
- echo "${_ver_name}.r$(git rev-list --count ${_ver_commit}..HEAD).${_commit}"
+ echo "2.4.r$(git rev-list --count c28f1bab7822de97353849e7787b59e50bbb1428..HEAD).$(git rev-parse --short HEAD)"
}
build() {