summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD51
-rw-r--r--mingw-config.toml29
3 files changed, 58 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 021c7b795721..5a6b7c98bb71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = mingw-w64-rust
- pkgdesc = rust language prebuilt toolchain with mingw target (mingw-w64)
- pkgver = 1.25.0
+ pkgdesc = Systems programming language focused on safety, speed and concurrency (mingw-w64)
+ pkgver = 1.26.0
pkgrel = 1
- url = https://www.rust-lang.org/
- arch = any
+ url = https://www.rust-lang.org
+ arch = x86_64
license = MIT
license = Apache
license = custom
@@ -19,17 +19,17 @@ pkgbase = mingw-w64-rust
depends = libgit2
depends = mingw-w64-gcc
optdepends = wine: for cargo test support
- options = !emptydirs
- options = staticlibs
options = !strip
+ options = staticlibs
+ options = !buildflags
backup = opt/rust/cargo/config
- source = https://static.rust-lang.org/dist/rustc-1.25.0-src.tar.xz
- source = https://static.rust-lang.org/dist/rustc-1.25.0-src.tar.xz.asc
+ source = https://static.rust-lang.org/dist/rustc-1.26.0-src.tar.xz
+ source = https://static.rust-lang.org/dist/rustc-1.26.0-src.tar.xz.asc
source = mingw-config.toml
validpgpkeys = 108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE
- sha256sums = 14fcb82d5959df758aaf422539359300917217fa8420e34bd596e3fb6ed2de87
+ sha256sums = 903b4727ad0c07e0edf9e27d5962c6e6f07f0f3c32e06c0f937bc79a087a32af
sha256sums = SKIP
- sha256sums = 497b75a9dfd0f5890a37b1ab8706c52586c08684e47f281bb740686601a81dd3
+ sha256sums = 8ab05c10084d8e2795aa9d5a954fb05913abc26033c1f9bbf564d0e495f043e4
pkgname = mingw-w64-rust
diff --git a/PKGBUILD b/PKGBUILD
index 3fbd41e9fdaf..6becf49886c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,60 +4,63 @@
# Contributor: Daniel Micay <danielmicay@gmail.com>
# Contributor: userwithuid <userwithuid@gmail.com>
-pkgname=mingw-w64-rust
_pkgname=rust
-pkgver=1.25.0
+
+pkgname=mingw-w64-rust
+pkgver=1.26.0
pkgrel=1
-pkgdesc="rust language prebuilt toolchain with mingw target (mingw-w64)"
-arch=('any')
-url='https://www.rust-lang.org/'
+pkgdesc="Systems programming language focused on safety, speed and concurrency (mingw-w64)"
+arch=('x86_64')
+url="https://www.rust-lang.org"
license=('MIT' 'Apache' 'custom')
-depends=('gcc-libs' 'curl' 'libgit2' 'mingw-w64-gcc')
+depends=('gcc-libs'
+ 'curl'
+ 'libgit2'
+ 'mingw-w64-gcc')
optdepends=('wine: for cargo test support')
-options=(!emptydirs staticlibs !strip)
-provides=()
-conflicts=()
-replaces=()
-makedepends=('rust' 'gdb' 'libffi' 'perl' 'python2' 'nodejs' 'cmake')
-
-source=("https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.xz"{,.asc}
- mingw-config.toml)
-
-sha256sums=('14fcb82d5959df758aaf422539359300917217fa8420e34bd596e3fb6ed2de87'
+makedepends=('rust'
+ 'gdb'
+ 'libffi'
+ 'perl'
+ 'python2'
+ 'nodejs'
+ 'cmake')
+options=('!strip' 'staticlibs' '!buildflags')
+source=("https://static.rust-lang.org/dist/rustc-${pkgver}-src.tar.xz"{,.asc}
+ "mingw-config.toml")
+sha256sums=('903b4727ad0c07e0edf9e27d5962c6e6f07f0f3c32e06c0f937bc79a087a32af'
'SKIP'
- '497b75a9dfd0f5890a37b1ab8706c52586c08684e47f281bb740686601a81dd3')
+ '8ab05c10084d8e2795aa9d5a954fb05913abc26033c1f9bbf564d0e495f043e4')
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
backup=("opt/${_pkgname}/cargo/config")
PKGEXT=".pkg.tar.gz"
prepare() {
- cd "rustc-$pkgver-src"
+ cd "rustc-${pkgver}-src"
- cp "$srcdir"/mingw-config.toml config.toml
+ cp "${srcdir}"/mingw-config.toml config.toml
sed -i "s|\@PREFIX\@|/opt/${_pkgname}|" config.toml
}
build() {
- cd "rustc-$pkgver-src"
+ cd "rustc-${pkgver}-src"
- unset LDFLAGS
export CFLAGS="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
export CXXFLAGS="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
python2 ./x.py build
}
package() {
- cd "rustc-$pkgver-src"
+ cd "rustc-${pkgver}-src"
# rust will build install tools there
- unset LDFLAGS
export CFLAGS="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
export CXXFLAGS="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
# TODO: find a way to disable packaging
# use level 0 to speed up xz packaging
sed -i 's|XzEncoder::new(create_new_file(tar_xz)?, 6)|XzEncoder::new(create_new_file(tar_xz)?, 0)|' "src/tools/rust-installer/src/tarballer.rs"
- DESTDIR="$pkgdir" python2 ./x.py install
+ DESTDIR="${pkgdir}" python2 ./x.py install
# license
install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"{rust,cargo}
diff --git a/mingw-config.toml b/mingw-config.toml
index 6513f16a36aa..add5ab1e0d13 100644
--- a/mingw-config.toml
+++ b/mingw-config.toml
@@ -118,6 +118,10 @@ compiler-docs = false
# Indicate whether submodules are managed and updated automatically.
submodules = true
+# Update submodules only when the checked out commit in the submodules differs
+# from what is committed in the main rustc repo.
+fast-submodules = false
+
# The path to (or name of) the GDB executable to use. This is only used for
# executing the debuginfo test suite.
gdb = "gdb"
@@ -151,8 +155,8 @@ full-bootstrap = false
# default.
extended = true
-# Installs choosen set of extended tools if enables. By default builds all.
-# If choosen tool failed to build the installation fails.
+# Installs chosen set of extended tools if enables. By default builds all.
+# If chosen tool failed to build the installation fails.
tools = ["cargo"]
# Verbosity level: 0 == not verbose, 1 == verbose, 2 == very verbose
@@ -182,6 +186,10 @@ configure-args = []
# essentially skipping stage0 as the local compiler is recompiling itself again.
local-rebuild = false
+# Print out how long each rustbuild step took (mostly intended for CI and
+# tracking over time)
+print-step-timings = false
+
# =============================================================================
# General install configuration options
# =============================================================================
@@ -239,11 +247,6 @@ optimize = true
# compiler.
codegen-units = 0
-# Whether to enable ThinLTO (and increase the codegen units to either a default
-# or the configured value). On by default. If we want the fastest possible
-# compiler, we should disable this.
-thinlto = true
-
# Whether or not debug assertions are enabled for the compiler and standard
# library. Also enables compilation of debug! and trace! logging macros.
debug-assertions = false
@@ -268,6 +271,9 @@ debug-jemalloc = false
# Whether or not `panic!`s generate backtraces (RUST_BACKTRACE)
backtrace = true
+# Build rustc with experimental parallelization
+experimental-parallel-queries = false
+
# The default linker that will be hard-coded into the generated compiler for
# targets that don't specify linker explicitly in their target specifications.
# Note that this is not the linker used to link said compiler.
@@ -299,7 +305,7 @@ codegen-tests = true
# Flag indicating whether git info will be retrieved from .git automatically.
# Having the git information can cause a lot of rebuilds during development.
-# Note: If this attribute is not explicity set (e.g. if left commented out) it
+# Note: If this attribute is not explicitly set (e.g. if left commented out) it
# will default to true if channel = "dev", but will default to false otherwise.
ignore-git = true
@@ -321,11 +327,18 @@ test-miri = false
# bootstrap)
codegen-backends = ["llvm"]
+# This is the name of the directory in which codegen backends will get installed
+codegen-backends-dir = "codegen-backends"
+
# Flag indicating whether `libstd` calls an imported function to handle basic IO
# when targeting WebAssembly. Enable this to debug tests for the `wasm32-unknown-unknown`
# target, as without this option the test output will not be captured.
wasm-syscall = false
+# Indicates whether LLD will be compiled and made available in the sysroot for
+# rustc to execute.
+lld = false
+
# =============================================================================
# Options for specific targets
#