summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--mingw-config.toml2
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb4bcc9982c5..766ab8272404 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-rust
pkgdesc = Systems programming language focused on safety, speed and concurrency (mingw-w64)
- pkgver = 1.43.0
+ pkgver = 1.43.1
pkgrel = 1
url = https://www.rust-lang.org
arch = x86_64
@@ -27,8 +27,8 @@ pkgbase = mingw-w64-rust
options = staticlibs
options = !buildflags
backup = opt/rust/cargo/config
- source = https://static.rust-lang.org/dist/rustc-1.43.0-src.tar.xz
- source = https://static.rust-lang.org/dist/rustc-1.43.0-src.tar.xz.asc
+ source = https://static.rust-lang.org/dist/rustc-1.43.1-src.tar.xz
+ source = https://static.rust-lang.org/dist/rustc-1.43.1-src.tar.xz.asc
source = https://static.rust-lang.org/dist/2020-03-12/rust-std-1.42.0-x86_64-unknown-linux-gnu.tar.xz
source = https://static.rust-lang.org/dist/2020-03-12/rust-std-1.42.0-x86_64-unknown-linux-gnu.tar.xz.asc
source = https://static.rust-lang.org/dist/2020-03-12/rustc-1.42.0-x86_64-unknown-linux-gnu.tar.xz
@@ -37,7 +37,7 @@ pkgbase = mingw-w64-rust
source = https://static.rust-lang.org/dist/2020-03-12/cargo-0.43.0-x86_64-unknown-linux-gnu.tar.xz.asc
source = mingw-config.toml
validpgpkeys = 108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE
- sha256sums = d0899933840369f07394b211cb0b53a5cd4634907633f0bee541133c8b75e309
+ sha256sums = eb0a103c67c4565403d9e6f84a1c708982a5e9e5b3c0d831e4d6f6451795d106
sha256sums = SKIP
sha256sums = 21405992fa02411a7a5bbd88e8218cd3e4609fe18bee687bb5ad6bab81e3f783
sha256sums = SKIP
@@ -45,7 +45,7 @@ pkgbase = mingw-w64-rust
sha256sums = SKIP
sha256sums = fe7e40786f6e013d471f2f8ed51ba268611122065930a6d5a10bf20146997270
sha256sums = SKIP
- sha256sums = f7e2746025bb16ef091e1f9f94e853368bec9ed52480bf8b4818283e81750cbc
+ sha256sums = e9c533229ec32ef55606fde07d7830c54c8bb30d3a691bf5e19c3b709af47d18
pkgname = mingw-w64-rust
diff --git a/PKGBUILD b/PKGBUILD
index 5675427780d7..23f740e78e0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ _cargo=0.43.0
pkgname=mingw-w64-rust
_prefix=opt/rust
-pkgver=1.43.0
+pkgver=1.43.1
pkgrel=1
pkgdesc="Systems programming language focused on safety, speed and concurrency (mingw-w64)"
arch=('x86_64')
@@ -39,7 +39,7 @@ source=("https://static.rust-lang.org/dist/rustc-${pkgver}-src.tar.xz"{,.asc}
noextract=("rust-std-${_rustc}-x86_64-unknown-linux-gnu.tar.xz"
"rustc-${_rustc}-x86_64-unknown-linux-gnu.tar.xz"
"cargo-${_cargo}-x86_64-unknown-linux-gnu.tar.xz")
-sha256sums=('d0899933840369f07394b211cb0b53a5cd4634907633f0bee541133c8b75e309'
+sha256sums=('eb0a103c67c4565403d9e6f84a1c708982a5e9e5b3c0d831e4d6f6451795d106'
'SKIP'
'21405992fa02411a7a5bbd88e8218cd3e4609fe18bee687bb5ad6bab81e3f783'
'SKIP'
@@ -47,7 +47,7 @@ sha256sums=('d0899933840369f07394b211cb0b53a5cd4634907633f0bee541133c8b75e309'
'SKIP'
'fe7e40786f6e013d471f2f8ed51ba268611122065930a6d5a10bf20146997270'
'SKIP'
- 'f7e2746025bb16ef091e1f9f94e853368bec9ed52480bf8b4818283e81750cbc')
+ 'e9c533229ec32ef55606fde07d7830c54c8bb30d3a691bf5e19c3b709af47d18')
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
backup=("opt/rust/cargo/config")
diff --git a/mingw-config.toml b/mingw-config.toml
index 68a05b3445a6..4b4085328059 100644
--- a/mingw-config.toml
+++ b/mingw-config.toml
@@ -534,6 +534,7 @@ ranlib = "i686-w64-mingw32-ranlib"
# Linker to be used to link Rust code. Note that the
# default value is platform specific, and if not specified it may also depend on
# what platform is crossing to what platform.
+# Setting this will override the `use-lld` option for Rust code.
linker = "i686-w64-mingw32-cc"
# Path to the `llvm-config` binary of the installation of a custom LLVM to link
@@ -591,6 +592,7 @@ ranlib = "x86_64-w64-mingw32-ranlib"
# Linker to be used to link Rust code. Note that the
# default value is platform specific, and if not specified it may also depend on
# what platform is crossing to what platform.
+# Setting this will override the `use-lld` option for Rust code.
linker = "x86_64-w64-mingw32-cc"
# Path to the `llvm-config` binary of the installation of a custom LLVM to link