summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD30
-rw-r--r--mingw-config.toml12
3 files changed, 51 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07ab53a96116..5aaea505883a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = mingw-w64-rust
pkgdesc = Systems programming language focused on safety, speed and concurrency (mingw-w64)
- pkgver = 1.27.0
+ pkgver = 1.27.1
pkgrel = 1
url = https://www.rust-lang.org
arch = x86_64
license = MIT
license = Apache
license = custom
- makedepends = rust
makedepends = gdb
makedepends = ninja
makedepends = libffi
@@ -20,17 +19,32 @@ pkgbase = mingw-w64-rust
depends = libgit2
depends = mingw-w64-gcc
optdepends = mingw-w64-wine: for cargo test support
+ noextract = rust-std-1.26.0-x86_64-unknown-linux-gnu.tar.gz
+ noextract = rustc-1.26.0-x86_64-unknown-linux-gnu.tar.gz
+ noextract = cargo-0.27.0-x86_64-unknown-linux-gnu.tar.gz
options = !strip
options = staticlibs
options = !buildflags
backup = opt/rust/cargo/config
- source = https://static.rust-lang.org/dist/rustc-1.27.0-src.tar.xz
- source = https://static.rust-lang.org/dist/rustc-1.27.0-src.tar.xz.asc
+ source = https://static.rust-lang.org/dist/rustc-1.27.1-src.tar.xz
+ source = https://static.rust-lang.org/dist/rustc-1.27.1-src.tar.xz.asc
+ source = https://static.rust-lang.org/dist/2018-05-10/rust-std-1.26.0-x86_64-unknown-linux-gnu.tar.gz
+ source = https://static.rust-lang.org/dist/2018-05-10/rust-std-1.26.0-x86_64-unknown-linux-gnu.tar.gz.asc
+ source = https://static.rust-lang.org/dist/2018-05-10/rustc-1.26.0-x86_64-unknown-linux-gnu.tar.gz
+ source = https://static.rust-lang.org/dist/2018-05-10/rustc-1.26.0-x86_64-unknown-linux-gnu.tar.gz.asc
+ source = https://static.rust-lang.org/dist/2018-05-10/cargo-0.27.0-x86_64-unknown-linux-gnu.tar.gz
+ source = https://static.rust-lang.org/dist/2018-05-10/cargo-0.27.0-x86_64-unknown-linux-gnu.tar.gz.asc
source = mingw-config.toml
validpgpkeys = 108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE
- sha256sums = 866b7409a67ff8324a73d9c5cecac2458e234d125cc3f22686412e35b3d750b4
+ sha256sums = 948e2645057960ee1c03d9f0e8f78133a5f73d9ca9a24bc56126e395a212d25c
sha256sums = SKIP
- sha256sums = c9916570220bd27c201d37ab9ac6470adeec6bacaca877fc68d3c0d6242189a0
+ sha256sums = e27cb5c21541a500c8df919e15c8d3b002456ebbe573122e7b058cf5b4c3c13a
+ sha256sums = SKIP
+ sha256sums = 7ca9a30010602aaf2244c376a3cc5baa89429d54da17b8ba1cb0cdfdc846cc61
+ sha256sums = SKIP
+ sha256sums = f50b64a7610401f4c1afe21de238663f33c621b7fc42c51401090ebd48e69fec
+ sha256sums = SKIP
+ sha256sums = 920b003929dd495d0887dd2db683a67cf8ff49bfde94d97c4d8c63ce69a0e801
pkgname = mingw-w64-rust
diff --git a/PKGBUILD b/PKGBUILD
index 9e9438928593..b4726e02c5c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,12 @@
# Contributor: userwithuid <userwithuid@gmail.com>
_pkgname=rust
+_date=2018-05-10
+_rustc=1.26.0
+_cargo=0.27.0
pkgname=mingw-w64-rust
-pkgver=1.27.0
+pkgver=1.27.1
pkgrel=1
pkgdesc="Systems programming language focused on safety, speed and concurrency (mingw-w64)"
arch=('x86_64')
@@ -18,8 +21,7 @@ depends=('gcc-libs'
'libgit2'
'mingw-w64-gcc')
optdepends=('mingw-w64-wine: for cargo test support')
-makedepends=('rust'
- 'gdb'
+makedepends=('gdb'
'ninja'
'libffi'
'perl'
@@ -28,10 +30,22 @@ makedepends=('rust'
'cmake')
options=('!strip' 'staticlibs' '!buildflags')
source=("https://static.rust-lang.org/dist/rustc-${pkgver}-src.tar.xz"{,.asc}
+ "https://static.rust-lang.org/dist/${_date}/rust-std-${_rustc}-x86_64-unknown-linux-gnu.tar.gz"{,.asc}
+ "https://static.rust-lang.org/dist/${_date}/rustc-${_rustc}-x86_64-unknown-linux-gnu.tar.gz"{,.asc}
+ "https://static.rust-lang.org/dist/${_date}/cargo-${_cargo}-x86_64-unknown-linux-gnu.tar.gz"{,.asc}
"mingw-config.toml")
-sha256sums=('866b7409a67ff8324a73d9c5cecac2458e234d125cc3f22686412e35b3d750b4'
+noextract=("rust-std-${_rustc}-x86_64-unknown-linux-gnu.tar.gz"
+ "rustc-${_rustc}-x86_64-unknown-linux-gnu.tar.gz"
+ "cargo-${_cargo}-x86_64-unknown-linux-gnu.tar.gz")
+sha256sums=('948e2645057960ee1c03d9f0e8f78133a5f73d9ca9a24bc56126e395a212d25c'
'SKIP'
- 'c9916570220bd27c201d37ab9ac6470adeec6bacaca877fc68d3c0d6242189a0')
+ 'e27cb5c21541a500c8df919e15c8d3b002456ebbe573122e7b058cf5b4c3c13a'
+ 'SKIP'
+ '7ca9a30010602aaf2244c376a3cc5baa89429d54da17b8ba1cb0cdfdc846cc61'
+ 'SKIP'
+ 'f50b64a7610401f4c1afe21de238663f33c621b7fc42c51401090ebd48e69fec'
+ 'SKIP'
+ '920b003929dd495d0887dd2db683a67cf8ff49bfde94d97c4d8c63ce69a0e801')
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
backup=("opt/${_pkgname}/cargo/config")
@@ -42,6 +56,12 @@ prepare() {
cp "${srcdir}"/mingw-config.toml config.toml
sed -i "s|\@PREFIX\@|/opt/${_pkgname}|" config.toml
+
+ cd "${srcdir}"
+ mkdir -p "${srcdir}/rustc-${pkgver}-src/build/cache/${_date}"
+ cp rust-std-${_rustc}-x86_64-unknown-linux-gnu.tar.gz "${srcdir}/rustc-${pkgver}-src/build/cache/${_date}"
+ cp rustc-${_rustc}-x86_64-unknown-linux-gnu.tar.gz "${srcdir}/rustc-${pkgver}-src/build/cache/${_date}"
+ cp cargo-${_cargo}-x86_64-unknown-linux-gnu.tar.gz "${srcdir}/rustc-${pkgver}-src/build/cache/${_date}"
}
build() {
diff --git a/mingw-config.toml b/mingw-config.toml
index c2f0537eaa0c..a17ec788075a 100644
--- a/mingw-config.toml
+++ b/mingw-config.toml
@@ -100,11 +100,11 @@ target = ["x86_64-unknown-linux-gnu", "i686-pc-windows-gnu", "x86_64-pc-windows-
# Instead of downloading the src/stage0.txt version of Cargo specified, use
# this Cargo binary instead to build all Rust code
-cargo = "/usr/bin/cargo"
+#cargo = "/usr/bin/cargo"
# Instead of downloading the src/stage0.txt version of the compiler
# specified, use this rustc binary instead as the stage0 snapshot compiler.
-rustc = "/usr/bin/rustc"
+#rustc = "/usr/bin/rustc"
# Flag to specify whether any documentation is built. If false, rustdoc and
# friends will still be compiled but they will not be used to generate any
@@ -252,10 +252,10 @@ codegen-units = 1
debug-assertions = false
# Whether or not debuginfo is emitted
-debuginfo = false
+debuginfo = true
# Whether or not line number debug information is emitted
-debuginfo-lines = false
+debuginfo-lines = true
# Whether or not to only build debuginfo for the standard library if enabled.
# If enabled, this will not compile the compiler with debuginfo, just the
@@ -292,7 +292,7 @@ channel = "stable"
# platforms to ensure that the compiler is usable by default from the build
# directory (as it links to a number of dynamic libraries). This may not be
# desired in distributions, for example.
-rpath = true
+rpath = false
# Suppresses extraneous output from tests to ensure the output of the test
# harness is relatively clean.
@@ -344,7 +344,7 @@ wasm-syscall = false
lld = true
# Whether to deny warnings in crates
-deny-warnings = true
+deny-warnings = false
# Print backtrace on internal compiler errors during bootstrap
backtrace-on-ice = false