summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD8
-rw-r--r--mingw-config.toml24
3 files changed, 27 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 813c9954065f..07ab53a96116 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-rust
pkgdesc = Systems programming language focused on safety, speed and concurrency (mingw-w64)
- pkgver = 1.26.2
- pkgrel = 2
+ pkgver = 1.27.0
+ pkgrel = 1
url = https://www.rust-lang.org
arch = x86_64
license = MIT
@@ -24,13 +24,13 @@ pkgbase = mingw-w64-rust
options = staticlibs
options = !buildflags
backup = opt/rust/cargo/config
- source = https://static.rust-lang.org/dist/rustc-1.26.2-src.tar.xz
- source = https://static.rust-lang.org/dist/rustc-1.26.2-src.tar.xz.asc
+ source = https://static.rust-lang.org/dist/rustc-1.27.0-src.tar.xz
+ source = https://static.rust-lang.org/dist/rustc-1.27.0-src.tar.xz.asc
source = mingw-config.toml
validpgpkeys = 108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE
- sha256sums = a1202800bd5621f5cac027177904da0b964eb43b93606d3e4c7b342a9f7473b4
+ sha256sums = 866b7409a67ff8324a73d9c5cecac2458e234d125cc3f22686412e35b3d750b4
sha256sums = SKIP
- sha256sums = 65445abc7b1f7c14896e05e5f147e56974e8ca0fde5aeed95e15adbd51951ae7
+ sha256sums = c9916570220bd27c201d37ab9ac6470adeec6bacaca877fc68d3c0d6242189a0
pkgname = mingw-w64-rust
diff --git a/PKGBUILD b/PKGBUILD
index 3b7e08d15a77..9e9438928593 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
_pkgname=rust
pkgname=mingw-w64-rust
-pkgver=1.26.2
-pkgrel=2
+pkgver=1.27.0
+pkgrel=1
pkgdesc="Systems programming language focused on safety, speed and concurrency (mingw-w64)"
arch=('x86_64')
url="https://www.rust-lang.org"
@@ -29,9 +29,9 @@ makedepends=('rust'
options=('!strip' 'staticlibs' '!buildflags')
source=("https://static.rust-lang.org/dist/rustc-${pkgver}-src.tar.xz"{,.asc}
"mingw-config.toml")
-sha256sums=('a1202800bd5621f5cac027177904da0b964eb43b93606d3e4c7b342a9f7473b4'
+sha256sums=('866b7409a67ff8324a73d9c5cecac2458e234d125cc3f22686412e35b3d750b4'
'SKIP'
- '65445abc7b1f7c14896e05e5f147e56974e8ca0fde5aeed95e15adbd51951ae7')
+ 'c9916570220bd27c201d37ab9ac6470adeec6bacaca877fc68d3c0d6242189a0')
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
backup=("opt/${_pkgname}/cargo/config")
diff --git a/mingw-config.toml b/mingw-config.toml
index 6911db941fcd..c2f0537eaa0c 100644
--- a/mingw-config.toml
+++ b/mingw-config.toml
@@ -120,7 +120,7 @@ submodules = true
# Update submodules only when the checked out commit in the submodules differs
# from what is committed in the main rustc repo.
-fast-submodules = false
+fast-submodules = true
# The path to (or name of) the GDB executable to use. This is only used for
# executing the debuginfo test suite.
@@ -245,14 +245,14 @@ optimize = true
# Number of codegen units to use for each compiler invocation. A value of 0
# means "the number of cores on this machine", and 1+ is passed through to the
# compiler.
-codegen-units = 0
+codegen-units = 1
# Whether or not debug assertions are enabled for the compiler and standard
# library. Also enables compilation of debug! and trace! logging macros.
debug-assertions = false
# Whether or not debuginfo is emitted
-debuginfo = true
+debuginfo = false
# Whether or not line number debug information is emitted
debuginfo-lines = false
@@ -260,7 +260,11 @@ debuginfo-lines = false
# Whether or not to only build debuginfo for the standard library if enabled.
# If enabled, this will not compile the compiler with debuginfo, just the
# standard library.
-debuginfo-only-std = true
+debuginfo-only-std = false
+
+# Enable debuginfo for the extended tools: cargo, rls, rustfmt
+# Adding debuginfo makes them several times larger.
+#debuginfo-tools = false
# Whether or not jemalloc is built and enabled
use-jemalloc = true
@@ -339,6 +343,12 @@ wasm-syscall = false
# rustc to execute.
lld = true
+# Whether to deny warnings in crates
+deny-warnings = true
+
+# Print backtrace on internal compiler errors during bootstrap
+backtrace-on-ice = false
+
# =============================================================================
# Options for specific targets
#
@@ -366,7 +376,7 @@ ar = "ar"
linker = "cc"
# Path to the `llvm-config` binary of the installation of a custom LLVM to link
-# against. Note that if this is specifed we don't compile LLVM at all for this
+# against. Note that if this is specified we don't compile LLVM at all for this
# target.
#llvm-config = "../path/to/llvm/root/bin/llvm-config"
@@ -416,7 +426,7 @@ ar = "i686-w64-mingw32-ar"
linker = "i686-w64-mingw32-cc"
# Path to the `llvm-config` binary of the installation of a custom LLVM to link
-# against. Note that if this is specifed we don't compile LLVM at all for this
+# against. Note that if this is specified we don't compile LLVM at all for this
# target.
#llvm-config = "../path/to/llvm/root/bin/llvm-config"
@@ -466,7 +476,7 @@ ar = "x86_64-w64-mingw32-ar"
linker = "x86_64-w64-mingw32-cc"
# Path to the `llvm-config` binary of the installation of a custom LLVM to link
-# against. Note that if this is specifed we don't compile LLVM at all for this
+# against. Note that if this is specified we don't compile LLVM at all for this
# target.
#llvm-config = "../path/to/llvm/root/bin/llvm-config"