summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
-rw-r--r--mingw-config.toml9
3 files changed, 30 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 261bff131d53..df5c48e2512c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-rust
pkgdesc = rust language prebuilt toolchain with mingw target (mingw-w64)
- pkgver = 1.23.0
- pkgrel = 2
+ pkgver = 1.24.0
+ pkgrel = 1
url = https://www.rust-lang.org/
arch = any
license = MIT
@@ -24,13 +24,13 @@ pkgbase = mingw-w64-rust
options = staticlibs
options = !strip
backup = opt/rust/cargo/config
- source = https://static.rust-lang.org/dist/rustc-1.23.0-src.tar.gz
- source = https://static.rust-lang.org/dist/rustc-1.23.0-src.tar.gz.asc
+ source = https://static.rust-lang.org/dist/rustc-1.24.0-src.tar.gz
+ source = https://static.rust-lang.org/dist/rustc-1.24.0-src.tar.gz.asc
source = mingw-config.toml
validpgpkeys = 108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE
- sha256sums = 7464953871dcfdfa8afcc536916a686dd156a83339d8ec4d5cb4eb2fe146cb91
+ sha256sums = bb8276f6044e877e447f29f566e4bbf820fa51fea2f912d59b73233ffd95639f
sha256sums = SKIP
- sha256sums = 4a63841b4c3be5de4ff11241bc45a4ac7ab03889af4f7ed64442c524be7f5d74
+ sha256sums = 22fe91f166703ea0bbf81a4d3d1cde7c8e5020540df3a1bb1b67c0c8160859f9
pkgname = mingw-w64-rust
diff --git a/PKGBUILD b/PKGBUILD
index 2e00ef599e3d..6ccd8fa1ba64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgname=mingw-w64-rust
_pkgname=rust
-pkgver=1.23.0
-pkgrel=2
+pkgver=1.24.0
+pkgrel=1
pkgdesc="rust language prebuilt toolchain with mingw target (mingw-w64)"
arch=('any')
url='https://www.rust-lang.org/'
@@ -23,9 +23,9 @@ makedepends=('rust' 'libffi' 'perl' 'python2' 'nodejs' 'cmake')
source=("https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz"{,.asc}
mingw-config.toml)
-sha256sums=('7464953871dcfdfa8afcc536916a686dd156a83339d8ec4d5cb4eb2fe146cb91'
+sha256sums=('bb8276f6044e877e447f29f566e4bbf820fa51fea2f912d59b73233ffd95639f'
'SKIP'
- '4a63841b4c3be5de4ff11241bc45a4ac7ab03889af4f7ed64442c524be7f5d74')
+ '22fe91f166703ea0bbf81a4d3d1cde7c8e5020540df3a1bb1b67c0c8160859f9')
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
backup=("opt/${_pkgname}/cargo/config")
@@ -43,7 +43,10 @@ build() {
unset LDFLAGS
export CFLAGS="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
export CXXFLAGS="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
- python2 ./x.py build
+ python2 ./x.py build \
+ src/rustc \
+ src/libstd \
+ src/tools/cargo
}
package() {
@@ -52,7 +55,10 @@ package() {
unset LDFLAGS
export CFLAGS="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
export CXXFLAGS="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
- DESTDIR="$pkgdir" python2 ./x.py install
+ DESTDIR="$pkgdir" python2 ./x.py install \
+ src/librustc \
+ src/libstd \
+ cargo
# license
install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"{rust,cargo}
@@ -60,24 +66,20 @@ package() {
rename '.old' '' "${pkgdir}/usr/share/licenses/${pkgname}/cargo/"*
mv "${pkgdir}"/opt/${_pkgname}/share/doc/rust/{LICENSE-*,COPYRIGHT} "${pkgdir}/usr/share/licenses/${pkgname}/rust/"
- # remove unused files, rust-doc, rls, rustfmt, rust-analysis, rust-src
+ # remove unused files
rm -r "${pkgdir}/etc/"
rm -r "${pkgdir}/opt/${_pkgname}/share"
- rm "${pkgdir}/opt/${_pkgname}/bin/"{rls,rustfmt}
- rm -r "${pkgdir}/opt/${_pkgname}/lib/rustlib/"{i686,x86_64}-pc-windows-gnu/analysis
- rm -r "${pkgdir}/opt/${_pkgname}/lib/rustlib/"x86_64-unknown-linux-gnu/analysis
rm "${pkgdir}/opt/${_pkgname}/lib/rustlib/"{manifest-*,install.log,uninstall.sh,components,rust-installer-version}
- rm -r "${pkgdir}/opt/${_pkgname}/lib/rustlib/src"
# link shared libraries
pushd "${pkgdir}/opt/${_pkgname}/lib"
ln -sf "rustlib/x86_64-unknown-linux-gnu/lib/"*.so .
popd
- pushd "${pkgdir}"
- install -dm755 "${pkgdir}/usr/i686-w64-mingw32/bin"
- ln -sf "opt/${_pkgname}/lib/rustlib/i686-pc-windows-gnu/lib/"*.dll "usr/i686-w64-mingw32/bin"
- install -dm755 "${pkgdir}/usr/x86_64-w64-mingw32/bin"
- ln -sf "opt/${_pkgname}/lib/rustlib/x86_64-pc-windows-gnu/lib/"*.dll "usr/x86_64-w64-mingw32/bin"
+ install -dm755 "${pkgdir}/usr/i686-w64-mingw32/bin" && pushd "${pkgdir}/usr/i686-w64-mingw32/bin"
+ ln -sf "../../../opt/${_pkgname}/lib/rustlib/i686-pc-windows-gnu/lib/"*.dll .
+ popd
+ install -dm755 "${pkgdir}/usr/x86_64-w64-mingw32/bin" && pushd "${pkgdir}/usr/x86_64-w64-mingw32/bin"
+ ln -sf "../../../opt/${_pkgname}/lib/rustlib/x86_64-pc-windows-gnu/lib/"*.dll .
popd
# strip
diff --git a/mingw-config.toml b/mingw-config.toml
index f04753b49328..1129c1b57095 100644
--- a/mingw-config.toml
+++ b/mingw-config.toml
@@ -60,9 +60,8 @@ targets = "X86"
# LLVM experimental targets to build support for. These targets are specified in
# the same format as above, but since these targets are experimental, they are
# not built by default and the experimental Rust compilation targets that depend
-# on them will not work unless the user opts in to building them. Possible
-# experimental LLVM targets include WebAssembly for the
-# wasm32-experimental-emscripten Rust target.
+# on them will not work unless the user opts in to building them. By default the
+# `WebAssembly` target is enabled when compiling LLVM from scratch.
experimental-targets = ""
# Cap the number of parallel linker invocations when compiling LLVM.
@@ -302,6 +301,10 @@ dist-src = false
# As a side-effect also generates MIR for all libraries.
test-miri = false
+# After building or testing extended tools (e.g. clippy and rustfmt), append the
+# result (broken, compiling, testing) into this JSON file.
+#save-toolstates = "/path/to/toolstates.json"
+
# =============================================================================
# Options for specific targets
#