summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD18
-rw-r--r--mingw-config.toml17
3 files changed, 38 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3291a5a761a2..e64fe322d554 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-rust
pkgdesc = Systems programming language focused on safety, speed and concurrency (mingw-w64)
- pkgver = 1.27.2
+ pkgver = 1.28.0
pkgrel = 1
url = https://www.rust-lang.org
arch = x86_64
@@ -19,32 +19,32 @@ pkgbase = mingw-w64-rust
depends = libgit2
depends = mingw-w64-gcc
optdepends = mingw-w64-wine: for cargo test support
- noextract = rust-std-1.26.0-x86_64-unknown-linux-gnu.tar.gz
- noextract = rustc-1.26.0-x86_64-unknown-linux-gnu.tar.gz
- noextract = cargo-0.27.0-x86_64-unknown-linux-gnu.tar.gz
+ noextract = rust-std-1.27.2-x86_64-unknown-linux-gnu.tar.gz
+ noextract = rustc-1.27.2-x86_64-unknown-linux-gnu.tar.gz
+ noextract = cargo-0.28.0-x86_64-unknown-linux-gnu.tar.gz
options = !strip
options = staticlibs
options = !buildflags
backup = opt/rust/cargo/config
- source = https://static.rust-lang.org/dist/rustc-1.27.2-src.tar.xz
- source = https://static.rust-lang.org/dist/rustc-1.27.2-src.tar.xz.asc
- source = https://static.rust-lang.org/dist/2018-05-10/rust-std-1.26.0-x86_64-unknown-linux-gnu.tar.gz
- source = https://static.rust-lang.org/dist/2018-05-10/rust-std-1.26.0-x86_64-unknown-linux-gnu.tar.gz.asc
- source = https://static.rust-lang.org/dist/2018-05-10/rustc-1.26.0-x86_64-unknown-linux-gnu.tar.gz
- source = https://static.rust-lang.org/dist/2018-05-10/rustc-1.26.0-x86_64-unknown-linux-gnu.tar.gz.asc
- source = https://static.rust-lang.org/dist/2018-05-10/cargo-0.27.0-x86_64-unknown-linux-gnu.tar.gz
- source = https://static.rust-lang.org/dist/2018-05-10/cargo-0.27.0-x86_64-unknown-linux-gnu.tar.gz.asc
+ source = https://static.rust-lang.org/dist/rustc-1.28.0-src.tar.xz
+ source = https://static.rust-lang.org/dist/rustc-1.28.0-src.tar.xz.asc
+ source = https://static.rust-lang.org/dist/2018-07-20/rust-std-1.27.2-x86_64-unknown-linux-gnu.tar.gz
+ source = https://static.rust-lang.org/dist/2018-07-20/rust-std-1.27.2-x86_64-unknown-linux-gnu.tar.gz.asc
+ source = https://static.rust-lang.org/dist/2018-07-20/rustc-1.27.2-x86_64-unknown-linux-gnu.tar.gz
+ source = https://static.rust-lang.org/dist/2018-07-20/rustc-1.27.2-x86_64-unknown-linux-gnu.tar.gz.asc
+ source = https://static.rust-lang.org/dist/2018-07-20/cargo-0.28.0-x86_64-unknown-linux-gnu.tar.gz
+ source = https://static.rust-lang.org/dist/2018-07-20/cargo-0.28.0-x86_64-unknown-linux-gnu.tar.gz.asc
source = mingw-config.toml
validpgpkeys = 108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE
- sha256sums = bf0228072ad60abd89dd81c8e25ae1e7b4b31e00e73612e7f4985e3144ad5bda
+ sha256sums = 8a899afd4b502b4ebff5cfc82cba77a8cb37113b5e6018f15c09545936081848
sha256sums = SKIP
- sha256sums = e27cb5c21541a500c8df919e15c8d3b002456ebbe573122e7b058cf5b4c3c13a
+ sha256sums = 68984f2233853d3e9c7c56edd72a91b5822157f28fdb42023fb311af68f842dd
sha256sums = SKIP
- sha256sums = 7ca9a30010602aaf2244c376a3cc5baa89429d54da17b8ba1cb0cdfdc846cc61
+ sha256sums = ec3efc17ddbe6625840957049e15ebae960f447c8e8feb7da40c28dd6adf655f
sha256sums = SKIP
- sha256sums = f50b64a7610401f4c1afe21de238663f33c621b7fc42c51401090ebd48e69fec
+ sha256sums = 35da884d43a8620534f6da1fbdd05f1e1f24823749f93d3d3be0eb46b3a6d884
sha256sums = SKIP
- sha256sums = 36962a9dd01b6d3d480fe17c8ba3c4620d5dd6b8cc6efc600991006e08917269
+ sha256sums = 766a6448a2ea589d43186db7911053913c2accf05ae8eefc1f04326816d04b8b
pkgname = mingw-w64-rust
diff --git a/PKGBUILD b/PKGBUILD
index 158f5731b3c5..071f3b150517 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
# Contributor: userwithuid <userwithuid@gmail.com>
_pkgname=rust
-_date=2018-05-10
-_rustc=1.26.0
-_cargo=0.27.0
+_date=2018-07-20
+_rustc=1.27.2
+_cargo=0.28.0
pkgname=mingw-w64-rust
-pkgver=1.27.2
+pkgver=1.28.0
pkgrel=1
pkgdesc="Systems programming language focused on safety, speed and concurrency (mingw-w64)"
arch=('x86_64')
@@ -37,15 +37,15 @@ source=("https://static.rust-lang.org/dist/rustc-${pkgver}-src.tar.xz"{,.asc}
noextract=("rust-std-${_rustc}-x86_64-unknown-linux-gnu.tar.gz"
"rustc-${_rustc}-x86_64-unknown-linux-gnu.tar.gz"
"cargo-${_cargo}-x86_64-unknown-linux-gnu.tar.gz")
-sha256sums=('bf0228072ad60abd89dd81c8e25ae1e7b4b31e00e73612e7f4985e3144ad5bda'
+sha256sums=('8a899afd4b502b4ebff5cfc82cba77a8cb37113b5e6018f15c09545936081848'
'SKIP'
- 'e27cb5c21541a500c8df919e15c8d3b002456ebbe573122e7b058cf5b4c3c13a'
+ '68984f2233853d3e9c7c56edd72a91b5822157f28fdb42023fb311af68f842dd'
'SKIP'
- '7ca9a30010602aaf2244c376a3cc5baa89429d54da17b8ba1cb0cdfdc846cc61'
+ 'ec3efc17ddbe6625840957049e15ebae960f447c8e8feb7da40c28dd6adf655f'
'SKIP'
- 'f50b64a7610401f4c1afe21de238663f33c621b7fc42c51401090ebd48e69fec'
+ '35da884d43a8620534f6da1fbdd05f1e1f24823749f93d3d3be0eb46b3a6d884'
'SKIP'
- '36962a9dd01b6d3d480fe17c8ba3c4620d5dd6b8cc6efc600991006e08917269')
+ '766a6448a2ea589d43186db7911053913c2accf05ae8eefc1f04326816d04b8b')
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
backup=("opt/${_pkgname}/cargo/config")
diff --git a/mingw-config.toml b/mingw-config.toml
index e1ffac1cfaf2..1c52bced8dd8 100644
--- a/mingw-config.toml
+++ b/mingw-config.toml
@@ -76,6 +76,10 @@ link-jobs = 0
# passed to prefer linking to shared libraries.
link-shared = false
+# On MSVC you can compile LLVM with clang-cl, but the test suite doesn't pass
+# with clang-cl, so this is special in that it only compiles LLVM with clang-cl
+#clang-cl = '/path/to/clang-cl.exe'
+
# =============================================================================
# General build configuration options
# =============================================================================
@@ -100,11 +104,11 @@ target = ["x86_64-unknown-linux-gnu", "i686-pc-windows-gnu", "x86_64-pc-windows-
# Instead of downloading the src/stage0.txt version of Cargo specified, use
# this Cargo binary instead to build all Rust code
-#cargo = "/usr/bin/cargo"
+#cargo = "/path/to/bin/cargo"
# Instead of downloading the src/stage0.txt version of the compiler
# specified, use this rustc binary instead as the stage0 snapshot compiler.
-#rustc = "/usr/bin/rustc"
+#rustc = "/path/to/bin/rustc"
# Flag to specify whether any documentation is built. If false, rustdoc and
# friends will still be compiled but they will not be used to generate any
@@ -275,6 +279,9 @@ debug-jemalloc = false
# Whether or not `panic!`s generate backtraces (RUST_BACKTRACE)
backtrace = true
+# Whether to always use incremental compilation when building rustc
+incremental = false
+
# Build rustc with experimental parallelization
experimental-parallel-queries = false
@@ -294,9 +301,9 @@ channel = "stable"
# desired in distributions, for example.
rpath = true
-# Suppresses extraneous output from tests to ensure the output of the test
-# harness is relatively clean.
-quiet-tests = false
+# Emits extraneous output from tests to ensure that failures of the test
+# harness are debuggable just from logfiles.
+verbose-tests = false
# Flag indicating whether tests are compiled with optimizations (the -O flag) or
# with debuginfo (the -g flag)