summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD37
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1aefb855492c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mingw-w64-sdl2_mixer
+ pkgdesc = A simple multi-channel audio mixer (mingw-w64)
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = http://www.libsdl.org/projects/SDL_mixer
+ arch = any
+ license = zlib
+ makedepends = sed
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-configure
+ depends = mingw-w64-crt
+ depends = mingw-w64-sdl2
+ depends = mingw-w64-libmodplug
+ depends = mingw-w64-libvorbis
+ depends = mingw-w64-flac
+ depends = mingw-w64-smpeg2
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://www.libsdl.org/projects/SDL_mixer/release/SDL2_mixer-2.0.0.tar.gz
+ md5sums = 65f6d80df073a1fb3bb537fbda031b50
+
+pkgname = mingw-w64-sdl2_mixer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab1907e08884
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Linus Probert <linus dot probert at gmail dot com>
+pkgname=mingw-w64-sdl2_mixer
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="A simple multi-channel audio mixer (mingw-w64)"
+arch=(any)
+url="http://www.libsdl.org/projects/SDL_mixer"
+license=("zlib")
+depends=(mingw-w64-crt mingw-w64-sdl2 mingw-w64-libmodplug mingw-w64-libvorbis mingw-w64-flac mingw-w64-smpeg2)
+makedepends=(sed mingw-w64-gcc mingw-w64-configure)
+options=(staticlibs !strip !buildflags)
+source=("http://www.libsdl.org/projects/SDL_mixer/release/SDL2_mixer-$pkgver.tar.gz")
+md5sums=('65f6d80df073a1fb3bb537fbda031b50')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/SDL2_mixer-${pkgver}"
+ sed -i 's/"modplug\.h"/"libmodplug\/modplug.h"/' music_modplug.h
+ sed -i 's/"modplug\.h"/"libmodplug\/modplug.h"/' dynamic_modplug.h
+ for _arch in ${_architectures}; do
+ export LIBMIKMOD_CONFIG=/usr/${_arch}/bin/libmikmod-config
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/SDL2_mixer-${pkgver}/build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}