summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fa2d5ee14ca..90e0c40e4c42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = mingw-w64-sdl2_ttf
pkgdesc = A library that allows you to use TrueType fonts in your SDL applications (Version 2) (mingw-w64)
- pkgver = 2.0.15
+ pkgver = 2.22.0
pkgrel = 1
url = http://libsdl.org
arch = any
license = MIT
- makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-configure
depends = mingw-w64-sdl2
- depends = mingw-w64-freetype2
- depends = mingw-w64-bzip2
options = staticlibs
options = !strip
options = !buildflags
- source = http://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-2.0.15.tar.gz
- sha256sums = a9eceb1ad88c1f1545cd7bd28e7cbc0b2c14191d40238f531a15b01b1b22cd33
+ source = https://github.com/libsdl-org/SDL_ttf/releases/download/release-2.22.0/SDL2_ttf-2.22.0.tar.gz
+ sha256sums = d48cbd1ce475b9e178206bf3b72d56b66d84d44f64ac05803328396234d67723
pkgname = mingw-w64-sdl2_ttf
-
diff --git a/PKGBUILD b/PKGBUILD
index f7a64cf03643..1be770c1b583 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,24 @@
+# Maintainer: jazztickets <jazztickets at gmail dot com>
pkgname=mingw-w64-sdl2_ttf
-pkgver=2.0.15
+pkgver=2.22.0
pkgrel=1
pkgdesc="A library that allows you to use TrueType fonts in your SDL applications (Version 2) (mingw-w64)"
arch=(any)
url="http://libsdl.org"
license=("MIT")
-depends=(mingw-w64-sdl2 mingw-w64-freetype2 mingw-w64-bzip2)
-makedepends=(mingw-w64-cmake)
+depends=(mingw-w64-sdl2)
+makedepends=(mingw-w64-configure)
options=(staticlibs !strip !buildflags)
-source=("http://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-$pkgver.tar.gz")
-sha256sums=('a9eceb1ad88c1f1545cd7bd28e7cbc0b2c14191d40238f531a15b01b1b22cd33')
+source=("https://github.com/libsdl-org/SDL_ttf/releases/download/release-${pkgver}/SDL2_ttf-${pkgver}.tar.gz")
+sha256sums=('d48cbd1ce475b9e178206bf3b72d56b66d84d44f64ac05803328396234d67723')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare () {
- cd "${srcdir}/SDL2_ttf-${pkgver}"
- # missing from archive ??
- curl -fSsLO http://hg.libsdl.org/SDL_ttf/raw-file/a86a6db70990/SDL2_ttfConfig.cmake
-}
-
build() {
cd "${srcdir}/SDL2_ttf-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake ..
+ LDFLAGS="-lssp" ${_arch}-configure ..
make
popd
done