summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--GWLP_USERDATA.patch20
-rw-r--r--PKGBUILD63
-rw-r--r--pidgin-silc-toolkit-1.1.12.patch23
4 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dad0bd2daa88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-silc-toolkit
+ pkgdesc = Toolkit for Secure Internet Live Conferencing
+ pkgver = 1.1.12
+ pkgrel = 1
+ url = http://silcnet.org
+ arch = any
+ license = GPL2
+ options = !strip
+ options = !buildflags
+ options = !emptydirs
+ source = https://downloads.sourceforge.net/project/silc/silc/toolkit/sources/silc-toolkit-1.1.12.tar.gz
+ source = pidgin-silc-toolkit-1.1.12.patch
+ source = GWLP_USERDATA.patch
+ sha512sums = 21393e9e7880670550e2325aa2eeda65a802bca87888b6d807ebed3a86844428b2a99f7434e6208ff61308df3767a12dd5d047dc546197bb78782811cf2b5e60
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = mingw-w64-silc-toolkit
diff --git a/GWLP_USERDATA.patch b/GWLP_USERDATA.patch
new file mode 100644
index 000000000000..8d1ef9b1758d
--- /dev/null
+++ b/GWLP_USERDATA.patch
@@ -0,0 +1,20 @@
+--- silc-toolkit-1.1.12.old/lib/silcutil/win32/silcwin32schedule.c 2014-05-13 10:20:17.000000000 +0400
++++ silc-toolkit-1.1.12/lib/silcutil/win32/silcwin32schedule.c 2021-12-07 00:12:05.363374849 +0300
+@@ -130,7 +130,7 @@
+ static LRESULT CALLBACK
+ silc_schedule_wnd_proc(HWND hwnd, UINT wMsg, WPARAM wParam, LPARAM lParam)
+ {
+- SilcSchedule schedule = (SilcSchedule)GetWindowLongPtr(hwnd, GWL_USERDATA);
++ SilcSchedule schedule = (SilcSchedule)GetWindowLongPtr(hwnd, GWLP_USERDATA);
+ SilcWin32Scheduler internal;
+ SilcUInt32 fd;
+ SilcTaskFd task;
+@@ -268,7 +268,7 @@
+ }
+
+ /* Set the scheduler as the window's context */
+- SetWindowLongPtr(internal->window, GWL_USERDATA, (void *)schedule);
++ SetWindowLongPtr(internal->window, GWLP_USERDATA, (void *)schedule);
+ SetWindowPos(internal->window, HWND_BOTTOM, 0, 0, 0, 0, SWP_FRAMECHANGED);
+
+ internal->wakeup_sema = CreateSemaphore(NULL, 0, 100, NULL);
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bda6155abf0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Ilya Basin <basinilya at gmail dot com>
+# Contributor: Mantas Mikulėnas <grawity@gmail.com>
+# Contributor: Ionut Biru <ionut@archlinux.ro>
+# Contributor: Vesa Kaihlavirta <vesa@archlinux.org>
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+options=(!strip !buildflags !emptydirs)
+
+_realname=silc-toolkit
+pkgname=mingw-w64-silc-toolkit
+pkgver=1.1.12
+pkgrel=1
+pkgdesc="Toolkit for Secure Internet Live Conferencing"
+url="http://silcnet.org"
+license=(GPL2)
+arch=('any')
+#depends=('libidn' 'perl')
+source=("https://downloads.sourceforge.net/project/silc/silc/toolkit/sources/$_realname-$pkgver.tar.gz"
+ pidgin-silc-toolkit-1.1.12.patch
+ GWLP_USERDATA.patch
+ )
+sha512sums=('21393e9e7880670550e2325aa2eeda65a802bca87888b6d807ebed3a86844428b2a99f7434e6208ff61308df3767a12dd5d047dc546197bb78782811cf2b5e60'
+ SKIP
+ SKIP
+ )
+
+prepare() {
+ cd "$srcdir/$_realname-$pkgver"
+ patch -Np1 -i ../pidgin-silc-toolkit-1.1.12.patch
+ patch -Np1 -i ../GWLP_USERDATA.patch
+ sed -i -e 's/AC_RUN_IFELSE/AC_LINK_IFELSE/g' configure.ac
+ autoreconf -if
+}
+
+build() {
+ cd "$srcdir"
+ for _arch in ${_architectures}; do
+ # VPATH Build broken
+ cp -aT "$_realname-$pkgver" "build-${_arch}" && pushd "build-${_arch}"
+
+ ${_arch}-configure \
+ --with-win32 \
+ "."
+
+ make
+
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ pushd "$srcdir/build-${_arch}"
+
+ make DESTDIR="$pkgdir" install
+ # remove 26 MB of developer-oriented documentation
+ rm -rf "$pkgdir"/usr/${_arch}/share/doc/$_realname
+
+ popd
+ done
+}
+
+# vim: ts=2:sw=2:et:nowrap
diff --git a/pidgin-silc-toolkit-1.1.12.patch b/pidgin-silc-toolkit-1.1.12.patch
new file mode 100644
index 000000000000..4f99492a577e
--- /dev/null
+++ b/pidgin-silc-toolkit-1.1.12.patch
@@ -0,0 +1,23 @@
+--- vanilla/silc-toolkit-1.1.12/includes/silcwin32.h 2014-05-13 02:20:22.000000000 -0400
++++ silc-toolkit-1.1.12/includes/silcwin32.h 2014-12-27 21:28:18.165096000 -0500
+@@ -71,7 +71,7 @@
+ #undef sleep
+ #define sleep(x) Sleep((x) * 1000)
+
+-#if _MSC_VER < 1300
++#if defined(_MSC_VER) && _MSC_VER < 1300
+ #define SetWindowLongPtr SetWindowLong
+ #define GetWindowLongPtr GetWindowLong
+ #endif /* _MSC_VER < 1300 */
+--- silc-toolkit-1.1.12/configure.ac.old 2021-12-07 00:02:24.180565726 +0300
++++ silc-toolkit-1.1.12/configure.ac 2021-12-07 00:03:18.051816830 +0300
+@@ -1233,7 +1233,8 @@
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([SILC_WIN32], [], [SILC_WIN32])
+ win32_support=true
+- CFLAGS="-mno-cygwin $CFLAGS"
++ #Remove -mno-cygwin, void having DLLAPI defined to import symbols while the library is being compiled
++ CFLAGS="-D_LIB $CFLAGS"
+ LIBS="$LIBS -lwsock32"
+ ],
+ [