summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea2cf81a03a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Aug 25 20:53:56 UTC 2017
+pkgbase = mingw-w64-sparsehash
+ pkgdesc = Library that contains several hash-map implementations, including implementations that optimize for space or speed. (mingw-w64)
+ pkgver = 2.0.3
+ pkgrel = 1
+ url = https://github.com/sparsehash/sparsehash
+ arch = any
+ license = BSD
+ makedepends = mingw-w64-configure
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = https://github.com/sparsehash/sparsehash/archive/sparsehash-2.0.3.tar.gz
+ sha256sums = 05e986a5c7327796dad742182b2d10805a8d4f511ad090da0490f146c1ff7a8c
+
+pkgname = mingw-w64-sparsehash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95f822dd6a78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+
+pkgname=mingw-w64-sparsehash
+pkgver=2.0.3
+pkgrel=1
+pkgdesc="Library that contains several hash-map implementations, including implementations that optimize for space or speed. (mingw-w64)"
+arch=("any")
+url="https://github.com/sparsehash/sparsehash"
+license=('BSD')
+makedepends=(mingw-w64-configure)
+options=(staticlibs !strip !buildflags)
+source=("https://github.com/sparsehash/sparsehash/archive/sparsehash-$pkgver.tar.gz")
+sha256sums=('05e986a5c7327796dad742182b2d10805a8d4f511ad090da0490f146c1ff7a8c')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "$srcdir"/sparsehash-sparsehash-$pkgver
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir"/sparsehash-sparsehash-$pkgver/build-${_arch}
+ make DESTDIR="$pkgdir" install
+ done
+}