summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD39
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3af1b08e7f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Nov 2 18:22:22 UTC 2016
+pkgbase = mingw-w64-sundials
+ pkgdesc = Suite of nonlinear differential/algebraic equation solvers (mingw-w64)
+ pkgver = 2.7.0
+ pkgrel = 1
+ url = https://computation.llnl.gov/casc/sundials/main.html
+ arch = any
+ license = BSD
+ makedepends = mingw-w64-cmake
+ depends = mingw-w64-lapack
+ options = !buildflags
+ options = staticlibs
+ options = !strip
+ source = http://computation.llnl.gov/projects/sundials/download/sundials-2.7.0.tar.gz
+ sha256sums = d39fcac7175d701398e4eb209f7e92a5b30a78358d4a0c0fcc23db23c11ba104
+
+pkgname = mingw-w64-sundials
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12b22a9a7db2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+
+pkgname=mingw-w64-sundials
+pkgver=2.7.0
+pkgrel=1
+pkgdesc="Suite of nonlinear differential/algebraic equation solvers (mingw-w64)"
+arch=('any')
+url="https://computation.llnl.gov/casc/sundials/main.html"
+license=('BSD')
+depends=('mingw-w64-lapack')
+makedepends=('mingw-w64-cmake')
+options=('!buildflags' 'staticlibs' '!strip')
+source=("http://computation.llnl.gov/projects/sundials/download/sundials-$pkgver.tar.gz")
+sha256sums=('d39fcac7175d701398e4eb209f7e92a5b30a78358d4a0c0fcc23db23c11ba104')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "$srcdir"/sundials-${pkgver}
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake \
+ -DEXAMPLES_ENABLE=OFF \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir"/sundials-${pkgver}/build-${_arch}
+ make install DESTDIR="$pkgdir"
+ install -d "$pkgdir"/usr/${_arch}/bin/
+ mv "$pkgdir"/usr/${_arch}/lib/*.dll "$pkgdir"/usr/${_arch}/bin/
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}
+