summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61a96ce01d02..61a8f2b4b5b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jun 19 13:44:32 UTC 2016
+# Wed Sep 14 20:10:49 UTC 2016
pkgbase = mingw-w64-tageditor
- pkgdesc = A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus and Matroska (mingw-w64).
- pkgver = 1.4.0
+ pkgdesc = A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus and Matroska
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/Martchus/tageditor
arch = any
@@ -19,8 +19,8 @@ pkgbase = mingw-w64-tageditor
options = staticlibs
options = !strip
options = !emptydirs
- source = tageditor-1.4.0.tar.gz::https://github.com/Martchus/tageditor/archive/v1.4.0.tar.gz
- sha256sums = 37281b85c633b2f91310c0747f6ae69a108961ee5de1fa5ad3ba27a1707359aa
+ source = tageditor-2.0.0.tar.gz::https://github.com/Martchus/tageditor/archive/v2.0.0.tar.gz
+ sha256sums = b3818112660b14b5e50c2b2f9521a1aaa1dafc12145e340fc5b210ee36056e41
pkgname = mingw-w64-tageditor
diff --git a/PKGBUILD b/PKGBUILD
index dccafbabc82f..8ef9e494fdd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
-# set the web view provider: either webkit, webengine or none
+# set the web view provider: either webkit, webengine, auto or none
_webview_provider=none
-# set the JavaScript provider: either script, qml or none
+# set the JavaScript provider: either script, qml, auto or none
_js_provider=script
-_name=tageditor
_reponame=tageditor
pkgname=mingw-w64-tageditor
-pkgver=1.4.0
+_name=${pkgname#mingw-w64-}
+pkgver=2.0.0
pkgrel=1
arch=('any')
-pkgdesc="A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus and Matroska (mingw-w64)."
+pkgdesc='A tag editor with Qt GUI and command-line interface supporting MP4/M4A/AAC (iTunes), ID3, Vorbis, Opus and Matroska'
license=('GPL')
depends=(mingw-w64-{crt,qtutilities,tagparser})
[[ $_webview_provider == none ]] && [[ $_js_provider == none ]] && depends+=('mingw-w64-qt5-base')
@@ -25,14 +25,13 @@ depends=(mingw-w64-{crt,qtutilities,tagparser})
[[ $_js_provider == qml ]] && depends+=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-cmake' 'mingw-w64-qt5-tools' 'ffmpeg')
url="https://github.com/Martchus/${_reponame}"
-source=("tageditor-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
-sha256sums=('37281b85c633b2f91310c0747f6ae69a108961ee5de1fa5ad3ba27a1707359aa')
+source=("${_reponame}-${pkgver}.tar.gz::https://github.com/Martchus/${_reponame}/archive/v${pkgver}.tar.gz")
+sha256sums=('b3818112660b14b5e50c2b2f9521a1aaa1dafc12145e340fc5b210ee36056e41')
options=(!buildflags staticlibs !strip !emptydirs)
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
build() {
cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame-$pkgver}"
- # build utilities for each architecture
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \