summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1a2697b691a..5370d98150b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-unifdef
pkgdesc = Remove #ifdef'ed lines (mingw-w64)
- pkgver = 2.11.23.1cca442
+ pkgver = 2.12
pkgrel = 1
url = http://dotat.at/prog/unifdef/
arch = any
@@ -10,8 +10,8 @@ pkgbase = mingw-w64-unifdef
options = !strip
options = !buildflags
options = staticlibs
- source = https://dotat.at/prog/unifdef/unifdef-2.11.23.1cca442.tar.xz
- sha256sums = a14bcc707cd6c145cca6a0f66a86afb7489c642a4ecc54d61137bb8c6aaf11e6
+ source = https://dotat.at/prog/unifdef/unifdef-2.12.tar.gz
+ sha256sums = fba564a24db7b97ebe9329713ac970627b902e5e9e8b14e19e024eb6e278d10b
pkgname = mingw-w64-unifdef
diff --git a/PKGBUILD b/PKGBUILD
index 2793a1e77a65..b02543eeecd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-unifdef
-pkgver=2.11.23.1cca442
+pkgver=2.12
pkgrel=1
pkgdesc="Remove #ifdef'ed lines (mingw-w64)"
arch=('any')
@@ -9,15 +9,15 @@ license=('BSD')
makedepends=('mingw-w64-gcc')
depends=('mingw-w64-crt')
options=('!strip' '!buildflags' 'staticlibs')
-source=("https://dotat.at/prog/unifdef/unifdef-$pkgver.tar.xz")
-sha256sums=('a14bcc707cd6c145cca6a0f66a86afb7489c642a4ecc54d61137bb8c6aaf11e6')
+source=("https://dotat.at/prog/unifdef/unifdef-$pkgver.tar.gz")
+sha256sums=('fba564a24db7b97ebe9329713ac970627b902e5e9e8b14e19e024eb6e278d10b')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
export CFLAGS="-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4"
export CXXFLAGS=${CFLAGS}
- for _arch in ${_architectures}; do
+ for _arch in ${_architectures}; do
[[ -d "build-${_arch}" ]] && rm -rf "build-${_arch}"
cp -rf "$srcdir/unifdef-${pkgver}" "${srcdir}/build-${_arch}"
export CC=${_arch}-gcc