summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD94
2 files changed, 76 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a517c4ee18f0..7ab3c45ee8a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = mingw-w64-unilib
pkgdesc = unilib, the ANSI C support library (MinGW-W64)
- pkgver = 1.2.1
+ pkgver = 1.3.5
pkgrel = 1
url = https://github.com/aquefir/{mingw-w64-unilib#mingw-w64-}
arch = any
license = BSD
makedepends = mingw-w64-gcc
+ makedepends = slick>=1.3.1
depends = mingw-w64-crt
provides = mingw-w64-unilib
conflicts = mingw-w64-unilib
options = !libtool
options = !buildflags
- source = https://github.com/aquefir/unilib/archive/v1.1.0-1.2.1.tar.gz
- sha1sums = 2f95b63cd63161bcfb11bd5e238978ad4ff02c09
+ source = https://github.com/aquefir/unilib/archive/v1.1.2-1.3.5.tar.gz
+ sha1sums = 47f300471b36dfbddf1bb48103d3bbcfa6072782
pkgname = mingw-w64-unilib
diff --git a/PKGBUILD b/PKGBUILD
index 50bc49714228..2d933a06805a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,93 @@
# Maintainer: Alexander Nicholi <me@nicholatian.com>
pkgname=mingw-w64-unilib
-pkgver=1.2.1
+pkgver=1.3.5
pkgrel=1
pkgdesc='unilib, the ANSI C support library (MinGW-W64)'
arch=('any')
url="https://github.com/aquefir/{$pkgname#mingw-w64-}"
license=('BSD')
-makedepends=(mingw-w64-gcc)
+makedepends=(mingw-w64-gcc 'slick>=1.3.1')
depends=(mingw-w64-crt)
options=(!libtool !buildflags)
provides=("$pkgname")
conflicts=("$pkgname")
-_symver=1.1.0
-source=("https://github.com/aquefir/${pkgname#mingw-w64-}/releases/download/v$pkgver/${pkgname#mingw-w64-}-$pkgver.tar.bz2")
+_symver=1.1.2
source=("https://github.com/aquefir/${pkgname#mingw-w64-}/archive/v${_symver}-$pkgver.tar.gz")
-sha1sums=('2f95b63cd63161bcfb11bd5e238978ad4ff02c09')
+sha1sums=('47f300471b36dfbddf1bb48103d3bbcfa6072782')
-_subprojects='arr chkmath decl endian err himem log str'
+_subprojects='arr chkmath decl endian err futils himem log str mt19937'
+
+prepare() {
+ cp -rp "$srcdir/${pkgname#mingw-w64-}-${_symver}-$pkgver" "$srcdir/win32"
+ mv "${pkgname#mingw-w64-}-${_symver}-$pkgver" "$srcdir/win64"
+}
build() {
- cd "$srcdir/${pkgname#mingw-w64-}-${_symver}-$pkgver"
+ cd "$srcdir/win64"
+
+ if [ "$(uname -s)" = 'Darwin' ]; then
+ _make=gmake
+ _cores=$(($(sysctl -n hw.ncpu) * 2))
+ else
+ _make=make
+ _cores=$(($(nproc) * 2))
+ fi
- for _subproj in ${_subprojects}; do
- cd "${_subproj}"
- make -j$(($(nproc) * 2)) release TP=Win64
- cd ..
- done
+ for _subproj in ${_subprojects}; do
+ cd "${_subproj}"
+ ${_make} -j${_cores} release TP=WIN64
+ cd ..
+ done
+
+ cd "$srcdir/win32"
+
+ # 32-bit Windows
+ for _subproj in ${_subprojects}; do
+ cd "${_subproj}"
+ ${_make} -j${_cores} release TP=Win32
+ cd ..
+ done
}
package() {
- cd "$srcdir/${pkgname#mingw-w64-}-${_symver}-$pkgver"
-
- cd log
- make -i install PREFIX="${pkgdir}/usr/agb-armv4t-eabi" TP=Win64
- cd ..
- for _subproj in ${_subprojects}; do
- cd "${_subproj}"
- make install PREFIX="${pkgdir}/usr/agb-armv4t-eabi" TP=Win64
- cd ..
- done
+ cd "$srcdir/win64"
+
+ if [ "$(uname -s)" = 'Darwin' ]; then
+ _make=gmake
+ _prefix="${pkgdir}/usr/local/x86_64-w64-mingw32"
+ else
+ _make=make
+ _prefix="${pkgdir}/usr/x86_64-w64-mingw32"
+ fi
+
+ mkdir -p "${_prefix}"
+
+ cd log
+ ${_make} -i install PREFIX="${_prefix}" TP=WIN64
+ cd ..
+ for _subproj in ${_subprojects}; do
+ cd "${_subproj}"
+ ${_make} install PREFIX="${_prefix}" TP=WIN64
+ cd ..
+ done
+
+ cd "$srcdir/win32"
+
+ if [ "$(uname -s)" = 'Darwin' ]; then
+ _prefix="${pkgdir}/usr/local/i686-w64-mingw32"
+ else
+ _prefix="${pkgdir}/usr/i686-w64-mingw32"
+ fi
+
+ mkdir -p "${_prefix}"
+
+ cd log
+ ${_make} -i install PREFIX="${_prefix}" TP=WIN32
+ cd ..
+ for _subproj in ${_subprojects}; do
+ cd "${_subproj}"
+ ${_make} install PREFIX="${_prefix}" TP=WIN32
+ cd ..
+ done
}