summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD32
2 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 330ecd777f8e..9a2f98f95115 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-waffle
pkgdesc = a library for choosing window system and OpenGL API at runtime (mingw-w64)
- pkgver = 1.7.2
+ pkgver = 1.8.0
pkgrel = 1
url = https://waffle.freedesktop.org
arch = any
@@ -11,10 +11,10 @@ pkgbase = mingw-w64-waffle
options = !strip
options = !buildflags
options = staticlibs
- source = https://waffle.freedesktop.org/files/release/waffle-1.7.2/waffle-1.7.2.tar.xz
- source = https://waffle.freedesktop.org/files/release/waffle-1.7.2/waffle-1.7.2.tar.xz.asc
+ source = https://waffle.freedesktop.org/files/release/waffle-1.8.0/waffle-1.8.0.tar.xz
+ source = https://waffle.freedesktop.org/files/release/waffle-1.8.0/waffle-1.8.0.tar.xz.asc
validpgpkeys = 8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D
- sha256sums = f676195cfea58cc75ef2441c5616b2f1d5565a7d371a6aa655aff3cc67c7c2c9
+ sha256sums = 29f462b5ea93510f585ae59b09f1aef6f9bad7287c7b82a7e8bd88f766e3afc7
sha256sums = SKIP
pkgname = mingw-w64-waffle
diff --git a/PKGBUILD b/PKGBUILD
index 4ea77d7b1783..ee13877338c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
+# Maintainer: Emil Velikov <emil.l.velikov@gmail.com>
+
pkgname=mingw-w64-waffle
-pkgver=1.7.2
+pkgver=1.8.0
pkgrel=1
pkgdesc='a library for choosing window system and OpenGL API at runtime (mingw-w64)'
arch=('any')
@@ -9,22 +11,25 @@ depends=('mingw-w64-crt')
makedepends=('mingw-w64-meson' 'cmake')
options=('!strip' '!buildflags' 'staticlibs')
source=(https://waffle.freedesktop.org/files/release/waffle-${pkgver}/waffle-${pkgver}.tar.xz{,.asc})
-sha256sums=('f676195cfea58cc75ef2441c5616b2f1d5565a7d371a6aa655aff3cc67c7c2c9'
+sha256sums=('29f462b5ea93510f585ae59b09f1aef6f9bad7287c7b82a7e8bd88f766e3afc7'
'SKIP')
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
+ local meson_args=(
+ -D b_lto=false
+ -D strip=false
+ -D build-manpages=false
+ -D build-htmldocs=false
+ -D build-examples=false
+ )
+
cd "waffle-$pkgver"
for _arch in ${_architectures}; do
- ${_arch}-meson build-${_arch} \
- -D b_lto=false \
- -D strip=false \
- -D build-manpages=false \
- -D build-htmldocs=false \
- -D build-examples=false
+ ${_arch}-meson build-${_arch} "${meson_args[@]}"
meson compile -C build-${_arch}
done
}
@@ -33,13 +38,10 @@ package() {
cd "waffle-$pkgver"
for _arch in ${_architectures}; do
- meson install -C build-${_arch} --destdir "$pkgdir"
-
- rm -r "$pkgdir"/usr/${_arch}/share
- ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
- ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ meson install -C "build-${_arch}" --destdir "$pkgdir"
- # To be fixed upstream with a later release
- mv "$pkgdir"/usr/${_arch}/bin/{lib,}waffle-1.dll
+ rm -r "$pkgdir/usr/${_arch}/share"
+ ${_arch}-strip --strip-unneeded "$pkgdir/usr/${_arch}/bin/"*.dll
+ ${_arch}-strip -g "$pkgdir/usr/${_arch}/lib/"*.a
done
}