summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD48
-rw-r--r--configure.patch71
3 files changed, 143 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..320273c459e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mingw-w64-zziplib
+ pkgdesc = A lightweight library that offers the ability to easily extract data from files archived in a single zip file (mingw-w64)
+ pkgver = 0.13.62
+ pkgrel = 6
+ url = http://zziplib.sourceforge.net
+ arch = any
+ license = LGPL, MPL
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-pkg-config
+ makedepends = python2
+ makedepends = mingw-w64-sdl
+ depends = mingw-w64-crt
+ depends = mingw-w64-zlib
+ optdepends = mingw-w64-sdl: SDL_rwops for ZZipLib
+ options = staticlibs
+ options = !strip
+ options = !buildflags
+ source = http://downloads.sourceforge.net/zziplib/zziplib-0.13.62.tar.bz2
+ source = configure.patch
+ md5sums = 5fe874946390f939ee8f4abe9624b96c
+ md5sums = 8c6e3c9526833140cea9390288756114
+
+pkgname = mingw-w64-zziplib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61ee814b62ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+pkgname=mingw-w64-zziplib
+pkgver=0.13.62
+pkgrel=6
+pkgdesc="A lightweight library that offers the ability to easily extract data from files archived in a single zip file (mingw-w64)"
+arch=(any)
+url="http://zziplib.sourceforge.net"
+license=("LGPL, MPL")
+makedepends=(mingw-w64-gcc mingw-w64-pkg-config python2 mingw-w64-sdl)
+depends=(mingw-w64-crt mingw-w64-zlib)
+optdepends=("mingw-w64-sdl: SDL_rwops for ZZipLib")
+options=(staticlibs !strip !buildflags)
+source=("http://downloads.sourceforge.net/zziplib/zziplib-${pkgver}.tar.bz2"
+"configure.patch")
+md5sums=('5fe874946390f939ee8f4abe9624b96c'
+ '8c6e3c9526833140cea9390288756114')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "$srcdir/zziplib-$pkgver"
+ patch -Np1 < ../configure.patch
+}
+
+build() {
+ for _arch in ${_architectures}; do
+ unset LDFLAGS
+ export PYTHON=/usr/bin/python2
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ "${srcdir}"/${pkgname#mingw-w64-}-${pkgver}/configure \
+ --prefix=/usr/${_arch} \
+ --build=$CHOST \
+ --host=${_arch} \
+ --enable-sdl
+ make
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.bat' -o -name '*.def' -o -name '*.exp' | xargs -rtl1 rm
+ find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip --strip-unneeded
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
+ rm -r "$pkgdir/usr/${_arch}/share"
+ done
+} \ No newline at end of file
diff --git a/configure.patch b/configure.patch
new file mode 100644
index 000000000000..a4636a5b429b
--- /dev/null
+++ b/configure.patch
@@ -0,0 +1,71 @@
+diff -ru zziplib-0.13.62/configure patched/configure
+--- zziplib-0.13.62/configure 2012-03-11 21:28:52.000000000 +0100
++++ patched/configure 2013-08-02 23:28:48.122420796 +0200
+@@ -5908,11 +5908,13 @@
+ # Base MSYS/MinGW do not provide the 'file' command needed by
+ # func_win32_libid shell function, so use a weaker test based on 'objdump',
+ # unless we find 'file', for example because we are cross-compiling.
+- if ( file / ) >/dev/null 2>&1; then
++ # func_win32_libid assumes BSD nm, so disallow it if using MS dumpbin.
++ if ( test "$lt_cv_nm_interface" = "BSD nm" && file / ) >/dev/null 2>&1; then
+ lt_cv_deplibs_check_method='file_magic ^x86 archive import|^x86 DLL'
+ lt_cv_file_magic_cmd='func_win32_libid'
+ else
+- lt_cv_deplibs_check_method='file_magic file format pei*-i386(.*architecture: i386)?'
++ # Keep this pattern in sync with the one in func_win32_libid.
++ lt_cv_deplibs_check_method='file_magic file format (pei*-i386(.*architecture: i386)?|pe-arm-wince|pe-x86-64)'
+ lt_cv_file_magic_cmd='$OBJDUMP -f'
+ fi
+ ;;
+@@ -13724,7 +13726,7 @@
+ ZZIPLIB_LDFLAGS=""
+ case "$host_os" in mingw*)
+ # we may assume that the backend is gnu-ld but DLLs need full resolution
+- ZZIPLIB_LDFLAGS="${wl}-no-undefined ${wl}-export-all-symbols -mconsole"
++ ZZIPLIB_LDFLAGS="-no-undefined ${wl}-no-undefined ${wl}-export-all-symbols -mconsole"
+ RESOLVES=' '
+ ;; darwin*)
+ # darwin never uses gnu-ld but the linker can do it anyway
+diff -ru zziplib-0.13.62/configure.ac patched/configure.ac
+--- zziplib-0.13.62/configure.ac 2012-03-11 21:28:35.000000000 +0100
++++ patched/configure.ac 2013-08-03 00:25:42.305761319 +0200
+@@ -294,7 +294,7 @@
+ ZZIPLIB_LDFLAGS=""
+ case "$host_os" in mingw*)
+ # we may assume that the backend is gnu-ld but DLLs need full resolution
+- ZZIPLIB_LDFLAGS="${wl}-no-undefined ${wl}-export-all-symbols -mconsole"
++ ZZIPLIB_LDFLAGS="-no-undefined ${wl}-no-undefined ${wl}-export-all-symbols -mconsole"
+ RESOLVES=' '
+ ;; darwin*)
+ # darwin never uses gnu-ld but the linker can do it anyway
+diff -ru zziplib-0.13.62/m4/libtool.m4 patched/m4/libtool.m4
+--- zziplib-0.13.62/m4/libtool.m4 2009-08-23 13:38:19.000000000 +0200
++++ patched/m4/libtool.m4 2013-08-02 22:57:24.381209038 +0200
+@@ -2999,11 +2999,13 @@
+ # Base MSYS/MinGW do not provide the 'file' command needed by
+ # func_win32_libid shell function, so use a weaker test based on 'objdump',
+ # unless we find 'file', for example because we are cross-compiling.
+- if ( file / ) >/dev/null 2>&1; then
++ # func_win32_libid assumes BSD nm, so disallow it if using MS dumpbin.
++ if ( test "$lt_cv_nm_interface" = "BSD nm" && file / ) >/dev/null 2>&1; then
+ lt_cv_deplibs_check_method='file_magic ^x86 archive import|^x86 DLL'
+ lt_cv_file_magic_cmd='func_win32_libid'
+ else
+- lt_cv_deplibs_check_method='file_magic file format pei*-i386(.*architecture: i386)?'
++ # Keep this pattern in sync with the one in func_win32_libid.
++ lt_cv_deplibs_check_method='file_magic file format (pei*-i386(.*architecture: i386)?|pe-arm-wince|pe-x86-64)'
+ lt_cv_file_magic_cmd='$OBJDUMP -f'
+ fi
+ ;;
+diff -ru zziplib-0.13.62/uses/ltmain.sh patched/uses/ltmain.sh
+--- zziplib-0.13.62/uses/ltmain.sh 2009-08-23 13:38:18.000000000 +0200
++++ patched/uses/ltmain.sh 2013-08-02 23:36:33.609957248 +0200
+@@ -2560,7 +2560,7 @@
+ ;;
+ *ar\ archive*) # could be an import, or static
+ if eval $OBJDUMP -f $1 | $SED -e '10q' 2>/dev/null |
+- $EGREP 'file format pe-i386(.*architecture: i386)?' >/dev/null ; then
++ $EGREP 'file format (pei*-i386(.*architecture: i386)?|pe-arm-wince|pe-x86-64)' >/dev/null ; then
+ win32_nmres=`eval $NM -f posix -A $1 |
+ $SED -n -e '
+ 1,100{ \ No newline at end of file