summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
-rw-r--r--mininet.install14
3 files changed, 21 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82f24e428a7e..23afdfd667c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = mininet
pkgdesc = Process-based network emulator (stable branch)
pkgver = 2.2.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/mininet/mininet/
+ install = mininet.install
arch = i686
arch = x86_64
license = custom
@@ -14,7 +15,7 @@ pkgbase = mininet
depends = net-tools
depends = iputils
depends = iperf
- optdepends = openvswitch
+ depends = openvswitch
optdepends = xorg-xhost
source = https://github.com/mininet/mininet/archive/2.2.1.tar.gz
sha256sums = e4c20a6ab4ddfe4d5cad06ba25742507967df67a845dbe2e90d627af7cd21705
diff --git a/PKGBUILD b/PKGBUILD
index 706ecf93c372..690cbc71b986 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@
pkgname=mininet
pkgver=2.2.1
-pkgrel=3
+pkgrel=4
pkgdesc="Process-based network emulator (stable branch)"
url="https://github.com/mininet/mininet/"
license=('custom')
-depends=('bash' 'python2' 'python2-networkx' 'net-tools' 'iputils' 'iperf')
-optdepends=('openvswitch' 'xorg-xhost')
+depends=('bash' 'python2' 'python2-networkx' 'net-tools' 'iputils' 'iperf' 'openvswitch')
+optdepends=('xorg-xhost')
makedepends=('help2man' 'python2-setuptools')
+install="${pkgname}.install"
arch=('i686' 'x86_64')
source=("https://github.com/mininet/mininet/archive/$pkgver.tar.gz")
sha256sums=('e4c20a6ab4ddfe4d5cad06ba25742507967df67a845dbe2e90d627af7cd21705')
diff --git a/mininet.install b/mininet.install
new file mode 100644
index 000000000000..1d6eb649ca15
--- /dev/null
+++ b/mininet.install
@@ -0,0 +1,14 @@
+post_install() {
+ cat << EOF
+
+ Mininet requires Open vSwitch to be running in order to
+ instantiate switches. To run it, just execute the following
+ commands (as root or using sudo):
+
+ # systemctl enable ovsdb-server.service
+ # systemctl start ovs-vswitchd.service
+ # systemctl enable ovsdb-server.service
+ # systemctl start ovs-vswitchd.service
+
+EOF
+}