summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
-rw-r--r--prefer_guile.patch30
3 files changed, 51 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7632e484e9be..f2e32499d796 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
-# Generated by mksrcinfo v8
-# Wed Jan 18 10:44:29 UTC 2017
pkgbase = minlog-git
pkgdesc = Interactive proof system based on first order natural deduction calculus.
- pkgver = 195.ff5c8ef
- pkgrel = 1
+ pkgver = r610.4a9a1e4
+ pkgrel = 2
url = http://www.mathematik.uni-muenchen.de/~logik/minlog/index.php
arch = any
license = GPL
makedepends = texlive-core
makedepends = git
depends = bash
+ options = !makeflags
source = git+http://www.mathematik.uni-muenchen.de/~minlogit/git/minlog.git
+ source = prefer_guile.patch
md5sums = SKIP
+ md5sums = 3066aa2dccf688b26d1c70ae8ebc3a7d
pkgname = minlog-git
diff --git a/PKGBUILD b/PKGBUILD
index 98e0d29a4ec9..5632441d5300 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=minlog-git
-pkgver=195.ff5c8ef
-pkgrel=1
+pkgver=r610.4a9a1e4
+pkgrel=2
pkgdesc="Interactive proof system based on first order natural deduction calculus."
arch=('any')
url="http://www.mathematik.uni-muenchen.de/~logik/minlog/index.php"
@@ -10,21 +11,27 @@ license=('GPL')
# in that order. I build with guile, because it is a dep of make and anyone has it
depends=('bash')
makedepends=('texlive-core' 'git')
-source=("git+http://www.mathematik.uni-muenchen.de/~minlogit/git/minlog.git")
-md5sums=('SKIP')
-_gitname="minlog"
+options=('!makeflags')
+source=("git+http://www.mathematik.uni-muenchen.de/~minlogit/git/minlog.git" prefer_guile.patch)
+md5sums=('SKIP'
+ '3066aa2dccf688b26d1c70ae8ebc3a7d')
pkgver() {
- cd "$srcdir"/"$_gitname"
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${pkgname%-git}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname%-git}
+ git apply "$srcdir"/prefer_guile.patch
}
build() {
- cd "$srcdir/$_gitname"
+ cd ${pkgname%-git}
make DESTDIR=usr
}
package() {
- cd "$srcdir/$_gitname"
+ cd ${pkgname%-git}
make install DESTDIR="$pkgdir/usr"
}
diff --git a/prefer_guile.patch b/prefer_guile.patch
new file mode 100644
index 000000000000..0c6e4c5ab800
--- /dev/null
+++ b/prefer_guile.patch
@@ -0,0 +1,30 @@
+diff --git a/src/Makefile b/src/Makefile
+index 5d39188..369831d 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -19,9 +19,9 @@ clean:
+
+ minitab.scm: grammar.scm lalr.scm
+ rm -f minitab.scm
+- if which scheme > /dev/null; then \
+- echo "Using Chez Scheme to build parser..."; \
+- scheme grammar.scm > grammar.log; \
++ if which guile > /dev/null; then \
++ echo "Using Guile to build parser..."; \
++ guile grammar.scm > grammar.log; \
+ elif which petite > /dev/null; then \
+ echo "Using petite to build parser..."; \
+ petite grammar.scm > grammar.log; \
+@@ -39,9 +39,9 @@ minitab.scm: grammar.scm lalr.scm
+ echo "Using mzscheme (< v4) to build parser..."; \
+ mzscheme -f grammar.scm > grammar.log; \
+ fi; \
+- elif which guile > /dev/null; then \
+- echo "Using guile to build parser..."; \
+- guile grammar.scm > grammar.log; \
++ elif which scheme > /dev/null; then \
++ echo "Using Chez Scheme to build parser..."; \
++ scheme grammar.scm > grammar.log; \
+ else \
+ echo "Please install either Chez Scheme, Petite Scheme, Racket, MzScheme, or Guile to build the parser!"; \
+ false; \