summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7632e484e9be..1d3464fa20a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
-# Generated by mksrcinfo v8
-# Wed Jan 18 10:44:29 UTC 2017
pkgbase = minlog-git
pkgdesc = Interactive proof system based on first order natural deduction calculus.
pkgver = 195.ff5c8ef
- pkgrel = 1
+ pkgrel = 2
url = http://www.mathematik.uni-muenchen.de/~logik/minlog/index.php
arch = any
license = GPL
makedepends = texlive-core
makedepends = git
depends = bash
+ options = !makeflags
source = git+http://www.mathematik.uni-muenchen.de/~minlogit/git/minlog.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 98e0d29a4ec9..9ed988c35c04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=minlog-git
pkgver=195.ff5c8ef
-pkgrel=1
+pkgrel=2
pkgdesc="Interactive proof system based on first order natural deduction calculus."
arch=('any')
url="http://www.mathematik.uni-muenchen.de/~logik/minlog/index.php"
@@ -10,21 +10,22 @@ license=('GPL')
# in that order. I build with guile, because it is a dep of make and anyone has it
depends=('bash')
makedepends=('texlive-core' 'git')
+options=(!makeflags)
+
source=("git+http://www.mathematik.uni-muenchen.de/~minlogit/git/minlog.git")
md5sums=('SKIP')
-_gitname="minlog"
pkgver() {
- cd "$srcdir"/"$_gitname"
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${pkgname%-git}
+printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/$_gitname"
+ cd ${pkgname%-git}
make DESTDIR=usr
}
package() {
- cd "$srcdir/$_gitname"
+ cd ${pkgname%-git}
make install DESTDIR="$pkgdir/usr"
}