summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 655446f7f26e..2e138280681f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = mint-themes-git
pkgdesc = Linux Mint themes
- pkgver = 1.9.6.r13.g4e19d767
- pkgrel = 1
+ pkgver = 2.1.6.r1.gb1dfbc54
+ pkgrel = 2
url = https://github.com/linuxmint/mint-themes
arch = any
license = GPL3
makedepends = git
makedepends = python
- makedepends = sassc
+ makedepends = python-libsass
provides = mint-themes
provides = mint-x-theme
provides = mint-y-theme
diff --git a/PKGBUILD b/PKGBUILD
index fee7a265800e..f5a4f2fe359f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,31 @@
-# Maintainer: hacker1024 <joshleivenzon at outlook dot com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: hacker1024 <joshleivenzon at outlook dot com>
-_pkgname=mint-themes
-pkgname=${_pkgname}-git
-pkgver=1.9.6.r13.g4e19d767
-pkgrel=1
+pkgname=mint-themes-git
+pkgver=2.1.6.r1.gb1dfbc54
+pkgrel=2
pkgdesc="Linux Mint themes"
arch=(any)
url="https://github.com/linuxmint/mint-themes"
license=(GPL3)
-makedepends=(git python sassc)
-conflicts=("${_pkgname}" 'mint-x-theme' 'mint-y-theme')
-provides=("${_pkgname}" 'mint-x-theme' 'mint-y-theme')
+makedepends=(git python python-libsass) #sassc pysass
+conflicts=(mint-themes mint-x-theme mint-y-theme)
+provides=(mint-themes mint-x-theme mint-y-theme)
options=(!strip)
source=("git+https://github.com/linuxmint/mint-themes.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "mint-themes"
+ git describe --long --tags --exclude master* | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/$_pkgname"
+build() {
+ cd "mint-themes"
make
- find "${srcdir}/${_pkgname}"/usr/share/themes -type f -name "metacity*xml" -exec sed -i 's:normal_dialog_style_set:normal_style_set:' {} \;
+ find "${srcdir}/mint-themes"/usr/share/themes -type f -name "metacity*xml" -exec sed -i 's:normal_dialog_style_set:normal_style_set:' {} \;
}
package() {
- cp -aR --no-preserve=ownership "${srcdir}/${_pkgname}"/usr "${pkgdir}"
+ cp -aR --no-preserve=ownership "${srcdir}/mint-themes"/usr "${pkgdir}"
}