summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
-rw-r--r--mint-y-icons.install15
3 files changed, 23 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75caa9f9941c..dd1f8801aaf2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
-# Generated by mksrcinfo v8
-# Wed Apr 13 21:06:47 UTC 2016
pkgbase = mint-y-icons-git
pkgdesc = New icons from LinuxMint 18 inspired by the Moka icon set
- pkgver = 37.262c757
- pkgrel = 2
+ pkgver = r489.69f5a032e
+ pkgrel = 1
+ epoch = 1
url = https://github.com/linuxmint/mint-y-icons
- install = mint-y-icons.install
arch = any
license = GPL3
+ makedepends = git
optdepends = mint-x-icons: Mint-Y inherits missing icons from Mint-X
provides = mint-y-icons
conflicts = mint-y-icons
- source = mint-y-icons::git+https://github.com/linuxmint/mint-y-icons.git
+ options = !strip
+ source = git+https://github.com/linuxmint/mint-y-icons.git
sha256sums = SKIP
pkgname = mint-y-icons-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f04d531d5c32..3e66f4f507dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
-# Maintainer: twa022 <twa022 at gmail dot com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: twa022 <twa022 at gmail dot com>
-_pkgname=mint-y-icons
-pkgname=${_pkgname}-git
-pkgver=37.262c757
-pkgrel=2
+pkgname=mint-y-icons-git
+pkgver=r489.69f5a032e
+pkgrel=1
+epoch=1
pkgdesc="New icons from LinuxMint 18 inspired by the Moka icon set"
-arch=('any')
+arch=(any)
url="https://github.com/linuxmint/mint-y-icons"
-license=('GPL3')
-depends=()
-makedepends=()
-optdepends=("mint-x-icons: Mint-Y inherits missing icons from Mint-X")
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
-source=("${_pkgname}"::git+https://github.com/linuxmint/mint-y-icons.git)
-install="$_pkgname.install"
+license=(GPL3)
+makedepends=(git)
+optdepends=('mint-x-icons: Mint-Y inherits missing icons from Mint-X')
+conflicts=(mint-y-icons)
+provides=(mint-y-icons)
+options=(!strip)
+source=("git+https://github.com/linuxmint/mint-y-icons.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ cd "${srcdir}/mint-y-icons"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd ${srcdir}/${_pkgname}
-
+ cd "${srcdir}/mint-y-icons"
cp -aR ./usr ${pkgdir}
}
diff --git a/mint-y-icons.install b/mint-y-icons.install
deleted file mode 100644
index 6621ffbbaf91..000000000000
--- a/mint-y-icons.install
+++ /dev/null
@@ -1,15 +0,0 @@
-post_install() {
- gtk-update-icon-cache -qtf /usr/share/icons/Mint-Y
-# for color in Aqua Blue Brown Dark Grey Orange Pink Purple Red Sand Teal Yellow; do
-# gtk-update-icon-cache -qtf /usr/share/icons/Mint-X-${color}
-# done
- gdk-pixbuf-query-loaders --update-cache
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}