summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bef04c816830..8e66ea0e6c53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = miopen
pkgdesc = AMD's Machine Intelligence Library
- pkgver = 1.7.1
+ pkgver = 2.3.0
pkgrel = 1
url = https://github.com/ROCmSoftwarePlatform/MIOpen
arch = x86_64
@@ -22,8 +22,8 @@ pkgbase = miopen
depends = rocblas
depends = boost>=1.58
depends = clang-ocl
- source = git+https://github.com/ROCmSoftwarePlatform/MIOpen.git#tag=1.7.1
- md5sums = SKIP
+ source = https://github.com/ROCmSoftwarePlatform/MIOpen/archive/roc-2.3.0.tar.gz
+ sha256sums = eba4dc29743ce35a3d3ce614c732c12e04356c6e0b1e33f5880e15f06b535ceb
pkgname = miopen
diff --git a/PKGBUILD b/PKGBUILD
index 61d12666ea3f..d459d14b0c39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jakub OkoĊ„ski <jakub@okonski.org>
pkgname=miopen
-pkgver=1.7.1
+pkgver=2.3.0
pkgrel=1
pkgdesc="AMD's Machine Intelligence Library"
arch=('x86_64')
@@ -8,8 +8,8 @@ url="https://github.com/ROCmSoftwarePlatform/MIOpen"
license=('NCSAOSL')
depends=(ocl-icd hip hcc rocblas "boost>=1.58" clang-ocl)
makedepends=(git opencl-headers cmake gcc ninja ocl-icd hip hcc rocblas "boost>=1.58" miopengemm)
-source=("git+https://github.com/ROCmSoftwarePlatform/MIOpen.git#tag=1.7.1")
-md5sums=('SKIP')
+source=("https://github.com/ROCmSoftwarePlatform/MIOpen/archive/roc-$pkgver.tar.gz")
+sha256sums=('eba4dc29743ce35a3d3ce614c732c12e04356c6e0b1e33f5880e15f06b535ceb')
build() {
mkdir -p "$srcdir/build"
@@ -25,7 +25,7 @@ build() {
-DCMAKE_PREFIX_PATH="/opt/rocm/hcc;/opt/rocm/hip" \
-DHALF_INCLUDE_DIR="$startdir" \
-G Ninja \
- "$srcdir/MIOpen"
+ "$srcdir/MIOpen-roc-$pkgver"
ninja
}