summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
-rw-r--r--miru-bin.install25
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b632cc19fc1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = miru-bin
+ pkgdesc = Bittorrent streaming software for cats
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://github.com/ThaUnknown/miru
+ install = miru-bin.install
+ arch = x86_64
+ groups =
+ license = GPL-3.0
+ depends = xdg-utils
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://github.com/ThaUnknown/miru/releases/download/v2.3.0/linux-Miru-2.3.0.deb
+ sha512sums_x86_64 = 7899d6fbd395452d1c6a8b662ec263e83ad19f1f81d4bbbedff605268314b81e252d029ce10023807a118fd770934181c074d83cd608e88342d9d7b08ac37833
+
+pkgname = miru-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c31dcc4d6c36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Look <notkool@protonmail.com>
+pkgname=miru-bin
+pkgver=2.3.0
+pkgrel=1
+pkgdesc="Bittorrent streaming software for cats"
+arch=('x86_64')
+url="https://github.com/ThaUnknown/miru"
+license=('GPL-3.0')
+groups=('')
+depends=('xdg-utils')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://github.com/ThaUnknown/miru/releases/download/v2.3.0/linux-Miru-2.3.0.deb")
+sha512sums_x86_64=('7899d6fbd395452d1c6a8b662ec263e83ad19f1f81d4bbbedff605268314b81e252d029ce10023807a118fd770934181c074d83cd608e88342d9d7b08ac37833')
+
+package(){
+
+ # Extract package data
+ tar -xJ -f data.tar.xz -C "${pkgdir}"
+
+ install -D -m644 "${pkgdir}/opt/Miru/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}
diff --git a/miru-bin.install b/miru-bin.install
new file mode 100644
index 000000000000..b9848121f556
--- /dev/null
+++ b/miru-bin.install
@@ -0,0 +1,25 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf '/opt/Miru/miru' '/usr/bin/miru'
+
+ # SUID chrome-sandbox for Electron 5+
+ chmod 4755 '/opt/Miru/chrome-sandbox' || true
+
+ update-mime-database /usr/share/mime || true
+ update-desktop-database /usr/share/applications || true
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Delete the link to the binary
+ rm -f '/usr/bin/miru'
+ update-desktop-database -q
+}