summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
-rw-r--r--Terms.txt41
-rw-r--r--misti.install20
5 files changed, 123 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..c14ed7d54de2
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = misti-fonts
+ pkgdesc = Misti's fonts (ttf)
+ pkgver = 2014
+ pkgrel = 3
+ url = http://mistifonts.com/
+ install = misti.install
+ arch = any
+ license = free for personal use
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://mistifonts.com/all%20fonts/all%20misti%27s%20fonts.zip
+ source = Terms.txt
+ source = misti.install
+ md5sums = 5b4fb253f92ee23b57521f6b87aecdd1
+ md5sums = cc9d7b475c85b4c662fc23e6b43ece8c
+ md5sums = a1a8cdd720dc8b3e1129714b72440610
+
+pkgname = misti-fonts
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c14ed7d54de2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = misti-fonts
+ pkgdesc = Misti's fonts (ttf)
+ pkgver = 2014
+ pkgrel = 3
+ url = http://mistifonts.com/
+ install = misti.install
+ arch = any
+ license = free for personal use
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://mistifonts.com/all%20fonts/all%20misti%27s%20fonts.zip
+ source = Terms.txt
+ source = misti.install
+ md5sums = 5b4fb253f92ee23b57521f6b87aecdd1
+ md5sums = cc9d7b475c85b4c662fc23e6b43ece8c
+ md5sums = a1a8cdd720dc8b3e1129714b72440610
+
+pkgname = misti-fonts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ea2e5248e53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Lara Maia <lara@craft.net.br>
+
+pkgname=misti-fonts
+pkgver=2014
+pkgrel=3
+pkgdesc="Misti's fonts (ttf)"
+arch=('any')
+url="http://mistifonts.com/"
+license=('free for personal use')
+depends=('fontconfig' 'xorg-font-utils')
+install=misti.install
+source=('http://mistifonts.com/all%20fonts/all%20misti%27s%20fonts.zip'
+ 'Terms.txt'
+ 'misti.install')
+md5sums=('5b4fb253f92ee23b57521f6b87aecdd1'
+ 'cc9d7b475c85b4c662fc23e6b43ece8c'
+ 'a1a8cdd720dc8b3e1129714b72440610')
+
+package() {
+ install -Dm644 Terms.txt "$pkgdir"/usr/share/licenses/$pkgname/Terms
+ mkdir -p "$pkgdir"/usr/share/fonts/TTF/
+ install -m644 *.ttf "$pkgdir"/usr/share/fonts/TTF/
+}
+
diff --git a/Terms.txt b/Terms.txt
new file mode 100644
index 000000000000..76925479b3b3
--- /dev/null
+++ b/Terms.txt
@@ -0,0 +1,41 @@
+Terms Of Use
+
+My fonts are free for PERSONAL use only. For any commercial use (anything you make money from), you must send a paypal donation.
+Please see below for affordable packages.
+
+Important Notes
+
+ I don’t charge extra for additional styles. For example- Love & Trust font has both regular and hearted versions.
+ They get counted as one font when donating for commercial use.
+ A user is the amount of people in your business (company, project, etc.) that are accessing the font file itself.
+ You do not need a paypal account to donate. You only need a credit or debit card to donate through paypal.
+ Your paypal receipt is your license. However, if you need me to send you an invoice or some other form of a license, please let me know.
+
+Font Packages
+
+ For an individual or small businesses (under 10 users): $5 per font
+ For businesses of 10 users or more: $10 per font
+ For charity or non-profit use: My fonts are free for you, but donations and/or credit is greatly appreciated (not required though). Thanks!
+ All Misti’s Fonts (plus any I make in the future): $300
+ This price applies for an individual or businesses of any size.
+ Note: if you have previously donated for commercial use, and would like to upgrade to this package, then
+ just deduct what you have already paid from this amount.
+
+Other Uses
+
+Apps, webfonts, embroidery fonts, or redistribution for profit: Contact me
+
+Additional Terms Of Use
+
+ You MAY NOT sell my fonts or claim them as your own.
+ You MAY NOT edit or rename my fonts with intent to redistribute or sell them.
+ You MAY redistribute my fonts if:
+ 1. You credit me (Misti’s Fonts or Misti Hammers).
+ 2. Keep the READ ME file intact within the zip folder.
+ 3. Provide a link back to this website (www.mistifonts.com).
+
+Note: These terms of use were updated on 08/30/2014.
+Terms of use are frequently updated as needed. Thanks for understanding!
+Contact me if you have any questions.
+
+http://mistifonts.com/contact-me/
diff --git a/misti.install b/misti.install
new file mode 100644
index 000000000000..4f5212ef22ba
--- /dev/null
+++ b/misti.install
@@ -0,0 +1,20 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*