summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
2 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c80423c1cee5..78b3a5d26986 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mkinitcpio-bluetooth
pkgdesc = This is an initcpio hook for bluetooth connectivity during boot / in initramfs.
- pkgver = 1.3
+ pkgver = 1.4
pkgrel = 1
url = https://github.com/irreleph4nt/mkinitcpio-bluetooth/
arch = x86_64
@@ -10,8 +10,9 @@ pkgbase = mkinitcpio-bluetooth
depends = bluez
depends = bluez-utils
depends = dbus
- source = git+https://github.com/irreleph4nt/mkinitcpio-bluetooth.git#tag=v1.3
- md5sums = SKIP
+ replaces = mkinitcpio-btinput
+ source = https://github.com/irreleph4nt/mkinitcpio-bluetooth/archive/v1.4.tar.gz
+ md5sums = a794ec95f1d37a56c824b7adc729ad96
pkgname = mkinitcpio-bluetooth
diff --git a/PKGBUILD b/PKGBUILD
index 24fe4d47ad98..08794bfbd9ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,27 @@
# Contributor: Aline Freitas <aline AT alinefreitas DOT com DOT br>
pkgname=mkinitcpio-bluetooth
-pkgver=1.3
+pkgver=1.4
pkgrel=1
pkgdesc="This is an initcpio hook for bluetooth connectivity during boot / in initramfs."
url="https://github.com/irreleph4nt/mkinitcpio-bluetooth/"
-arch=('x86_64' 'i686')
+arch=(
+ 'x86_64'
+ 'i686'
+)
license=('GPLv2')
-depends=('bluez' 'bluez-utils' 'dbus')
+depends=(
+ 'bluez'
+ 'bluez-utils'
+ 'dbus'
+)
+replaces=('mkinitcpio-btinput')
makedepends=('git')
-source=("git+https://github.com/irreleph4nt/mkinitcpio-bluetooth.git#tag=v${pkgver}")
-md5sums=('SKIP')
+source=("https://github.com/irreleph4nt/mkinitcpio-bluetooth/archive/v${pkgver}.tar.gz")
+md5sums=('a794ec95f1d37a56c824b7adc729ad96')
package() {
- cd "$srcdir/${pkgname}"
+ cd "$srcdir/${pkgname}-${pkgver}"
install -Dm644 bluetooth_install "${pkgdir}/usr/lib/initcpio/install/bluetooth"
install -Dm644 bluetooth_hook "${pkgdir}/usr/lib/initcpio/hooks/bluetooth"