summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--README.adoc14
-rw-r--r--wireguard_hook1
4 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89da3a19db28..2ffcb5cff6f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mkinitcpio-wireguard
pkgdesc = mkinitcpio hook that initialises Wireguard to assist in the remote unlocking of encrypted partitions.
- pkgver = 0.3.0
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/dharrigan/mkinitcpio-wireguard
install = mkinitcpio-wireguard.install
@@ -12,7 +12,7 @@ pkgbase = mkinitcpio-wireguard
source = wireguard_hook
source = wireguard_install
source = wireguard_config
- sha256sums = 0d173d068d440ab423386994c3bb3e7acef6a1380db3586adbded129d1e3975b
+ sha256sums = 3aea7f1cedfd5194de93ef1755b545e994df20a40dcf358f3c0727ce63fe652a
sha256sums = 563e42ce30179df55132c10b295604e0a5a68d925890db55153764b4c3f959fe
sha256sums = e7a034b4239610be33ccb1001a0df947fb14cbe758b8f2825d8b890f2bfc043e
diff --git a/PKGBUILD b/PKGBUILD
index 59b610b319f9..9bf41e4eb3b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: David Harrigan <dharrigan [@] gmail [dot] com>
pkgname=mkinitcpio-wireguard
-pkgver=0.3.0
+pkgver=0.4.0
pkgrel=1
pkgdesc='mkinitcpio hook that initialises Wireguard to assist in the remote unlocking of encrypted partitions.'
url='https://github.com/dharrigan/mkinitcpio-wireguard'
@@ -19,7 +19,7 @@ package() {
}
sha256sums=(
-'0d173d068d440ab423386994c3bb3e7acef6a1380db3586adbded129d1e3975b'
+'3aea7f1cedfd5194de93ef1755b545e994df20a40dcf358f3c0727ce63fe652a'
'563e42ce30179df55132c10b295604e0a5a68d925890db55153764b4c3f959fe'
'e7a034b4239610be33ccb1001a0df947fb14cbe758b8f2825d8b890f2bfc043e'
)
diff --git a/README.adoc b/README.adoc
index 30d6305500b9..b85bfedab280 100644
--- a/README.adoc
+++ b/README.adoc
@@ -25,10 +25,14 @@ WARNING: Read the warning above.
|===
|Version | Note
+| *0.4.0*
+a|
+* Add a route based upon the ALLOWED_IPS.
+
| *0.3.0*
a|
-* Various tidy ups and script improvements
-* Rename PRIVATE_KEY_FILE to PRIVATE_KEYFILE
+* Various tidy ups and script improvements.
+* Rename PRIVATE_KEY_FILE to PRIVATE_KEYFILE - BREAKING CHANGE!
| *0.2.0*
a|
@@ -36,7 +40,7 @@ a|
| *0.1.0*
a|
-* Initial Release
+* Initial Release.
|===
@@ -155,6 +159,10 @@ to SSH to the machine (you did remember to set that all up before doing this,
right?) and unlock any encrypted partitions and thus enable the continuation
of your boot process! FTW!
+NOTE: It could take a minute or two for your Wireguard interface to
+authenticate and be recognised by the remote peer. Please be patient and hang
+on in there!
+
== Unlicensed
Find the full unlicense in the UNLICENSE file, but here's a snippet.
diff --git a/wireguard_hook b/wireguard_hook
index d82729134a6f..5d5becf1166a 100644
--- a/wireguard_hook
+++ b/wireguard_hook
@@ -80,6 +80,7 @@ run_hook()
allowed-ips $ALLOWED_IPS
ip addr add $INTERFACE_ADDR dev $INTERFACE
ip link set $INTERFACE up
+ ip route add $ALLOWED_IPS dev $INTERFACE
}
run_cleanuphook() {