summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--wireguard_hook2
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ffcb5cff6f6..c6317e8d8932 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mkinitcpio-wireguard
pkgdesc = mkinitcpio hook that initialises Wireguard to assist in the remote unlocking of encrypted partitions.
- pkgver = 0.4.0
+ pkgver = 0.4.1
pkgrel = 1
url = https://github.com/dharrigan/mkinitcpio-wireguard
install = mkinitcpio-wireguard.install
@@ -12,7 +12,7 @@ pkgbase = mkinitcpio-wireguard
source = wireguard_hook
source = wireguard_install
source = wireguard_config
- sha256sums = 3aea7f1cedfd5194de93ef1755b545e994df20a40dcf358f3c0727ce63fe652a
+ sha256sums = 57357aeec99d9fd60ff9bbef2e17502be4b31f5d6b472a678978b4dddc094cf5
sha256sums = 563e42ce30179df55132c10b295604e0a5a68d925890db55153764b4c3f959fe
sha256sums = e7a034b4239610be33ccb1001a0df947fb14cbe758b8f2825d8b890f2bfc043e
diff --git a/PKGBUILD b/PKGBUILD
index 9bf41e4eb3b5..8037cf4db9ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: David Harrigan <dharrigan [@] gmail [dot] com>
pkgname=mkinitcpio-wireguard
-pkgver=0.4.0
+pkgver=0.4.1
pkgrel=1
pkgdesc='mkinitcpio hook that initialises Wireguard to assist in the remote unlocking of encrypted partitions.'
url='https://github.com/dharrigan/mkinitcpio-wireguard'
@@ -13,13 +13,13 @@ backup=('etc/wireguard/initcpio/unlock')
source=('wireguard_hook' 'wireguard_install' 'wireguard_config')
package() {
- install -o root -g root -D ${srcdir}/wireguard_hook ${pkgdir}/usr/lib/initcpio/hooks/wireguard
- install -o root -g root -D ${srcdir}/wireguard_install ${pkgdir}/usr/lib/initcpio/install/wireguard
- install -o root -g root -D ${srcdir}/wireguard_config ${pkgdir}/etc/wireguard/initcpio/unlock
+ install -Dm644 ${srcdir}/wireguard_hook ${pkgdir}/usr/lib/initcpio/hooks/wireguard
+ install -Dm644 ${srcdir}/wireguard_install ${pkgdir}/usr/lib/initcpio/install/wireguard
+ install -Dm644 ${srcdir}/wireguard_config ${pkgdir}/etc/wireguard/initcpio/unlock
}
sha256sums=(
-'3aea7f1cedfd5194de93ef1755b545e994df20a40dcf358f3c0727ce63fe652a'
+'57357aeec99d9fd60ff9bbef2e17502be4b31f5d6b472a678978b4dddc094cf5'
'563e42ce30179df55132c10b295604e0a5a68d925890db55153764b4c3f959fe'
'e7a034b4239610be33ccb1001a0df947fb14cbe758b8f2825d8b890f2bfc043e'
)
diff --git a/wireguard_hook b/wireguard_hook
index 5d5becf1166a..df8d5fcbfc45 100644
--- a/wireguard_hook
+++ b/wireguard_hook
@@ -1,4 +1,4 @@
-#!/bin/ash
+#!/bin/bash
#
# This is free and unencumbered software released into the public domain.
#