summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
-rw-r--r--mkinitcpio-ykfde.install10
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a922192ba278
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = mkinitcpio-ykfde-git
+ pkgdesc = Full disk encryption with Yubikey (Yubico key) - git checkout
+ pkgver = 0.5.0.r15.g06fc9a2
+ pkgrel = 1
+ url = https://github.com/eworm-de/mkinitcpio-ykfde
+ install = mkinitcpio-ykfde.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = markdown
+ depends = yubikey-personalization
+ depends = cryptsetup
+ depends = iniparser
+ depends = libarchive
+ provides = mkinitcpio-ykfde
+ conflicts = mkinitcpio-ykfde
+ backup = etc/ykfde.conf
+ source = git://github.com/eworm-de/mkinitcpio-ykfde.git
+ sha256sums = SKIP
+
+pkgname = mkinitcpio-ykfde-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12df023bdc01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=mkinitcpio-ykfde-git
+pkgver=0.5.0.r15.g06fc9a2
+pkgrel=1
+pkgdesc="Full disk encryption with Yubikey (Yubico key) - git checkout"
+arch=('i686' 'x86_64')
+url="https://github.com/eworm-de/mkinitcpio-ykfde"
+license=('GPL')
+conflicts=('mkinitcpio-ykfde')
+provides=('mkinitcpio-ykfde')
+depends=('yubikey-personalization' 'cryptsetup' 'iniparser' 'libarchive')
+makedepends=('git' 'markdown')
+install=mkinitcpio-ykfde.install
+source=('git://github.com/eworm-de/mkinitcpio-ykfde.git')
+sha256sums=('SKIP')
+backup=('etc/ykfde.conf')
+
+pkgver() {
+ cd mkinitcpio-ykfde/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+build() {
+ cd mkinitcpio-ykfde/
+
+ make
+}
+
+package() {
+ cd mkinitcpio-ykfde/
+
+ make DESTDIR=${pkgdir} install-mkinitcpio
+}
+
diff --git a/mkinitcpio-ykfde.install b/mkinitcpio-ykfde.install
new file mode 100644
index 000000000000..c6e7faf6f8f6
--- /dev/null
+++ b/mkinitcpio-ykfde.install
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+post_install() {
+ echo " > Please read documentation in /usr/share/doc/ykfde/ or"
+ echo " > online: https://github.com/eworm-de/mkinitcpio-ykfde/#usage"
+}
+
+post_remove() {
+ echo " > Please remove 'ykfde' from your HOOKS array in /etc/mkinitcpio.conf."
+}