summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD42
-rw-r--r--mkxp.install11
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4a6190482b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = mkxp-git
+ pkgdesc = Open source implementation of the Ruby Game Scripting System of RPG Maker XP
+ pkgver = r319.b8fc5e2
+ pkgrel = 1
+ url = https://github.com/Ancurio/mkxp
+ install = mkxp.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = boost
+ makedepends = cmake
+ makedepends = mesa
+ makedepends = vim
+ depends = ruby
+ depends = physfs-hg
+ depends = sdl2_image
+ depends = sdl2_ttf
+ depends = sdl_sound-patched-hg
+ depends = pixman
+ depends = glew
+ depends = openal
+ depends = boost-libs
+ depends = libgl
+ depends = libsigc++
+ provides = mkxp
+ conflicts = mkxp
+ source = mkxp::git+https://github.com/Ancurio/mkxp.git
+ md5sums = SKIP
+
+pkgname = mkxp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d18f9d604728
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+
+_pkgbase=mkxp
+pkgname=$_pkgbase-git
+pkgver=r319.b8fc5e2
+pkgrel=1
+pkgdesc="Open source implementation of the Ruby Game Scripting System of RPG Maker XP"
+arch=('i686' 'x86_64')
+url="https://github.com/Ancurio/mkxp"
+license=('GPL2')
+depends=('ruby' 'physfs-hg' 'sdl2_image' 'sdl2_ttf' 'sdl_sound-patched-hg'
+ 'pixman' 'glew' 'openal' 'boost-libs' 'libgl' 'libsigc++')
+makedepends=('git' 'boost' 'cmake' 'mesa' 'vim')
+conflicts=('mkxp')
+provides=('mkxp')
+install=$_pkgbase.install
+source=($_pkgbase::"git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgbase
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgbase
+
+ cmake ./
+ make
+}
+
+package() {
+ cd $_pkgbase
+
+ # install architecture dependent executeable
+ install -Dm755 $_pkgbase.bin.x* "$pkgdir"/usr/bin/$_pkgbase
+
+ # install documentation
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$_pkgbase/README.md
+ install -m644 mkxp.conf.sample "$pkgdir"/usr/share/doc/$_pkgbase
+}
diff --git a/mkxp.install b/mkxp.install
new file mode 100644
index 000000000000..708511b87036
--- /dev/null
+++ b/mkxp.install
@@ -0,0 +1,11 @@
+
+post_install() {
+ echo "Currently, you have to copy /usr/bin/mkxp to the directory of the"
+ echo "RPG Maker XP game you want to play, after that you can launch it"
+ echo "with ./mkxp in it's directory. You may want to add a mkxp.conf to game"
+ echo "directory for customisation, see sample file in /usr/share/doc/mkxp"
+}
+
+post_upgrade() {
+ post_install
+}