summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1199472e9897..b4e8f7aa8208 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = mlvwm
- pkgdesc = Macintosh-Like Virtual Window Manager, it attempts to emulate the pre-Mac OS X Macintosh look and feel in its layout and window design.
- pkgver = 0.9.1
- pkgrel = 2
+ pkgdesc = Unoffical package for Macintosh-Like Virtual Window Manager, it attempts to emulate the pre-Mac OS X Macintosh look and feel in its layout and window design.
+ pkgver = 0.9.4
+ pkgrel = 3
url = http://www2u.biglobe.ne.jp/~y-miyata/mlvwm.html
arch = i686
arch = x86_64
license = mit
makedepends = imake
- source = http://www2u.biglobe.ne.jp/~y-miyata/mlvwm/mlvwm091.tar.gz
- md5sums = 0ac2a6f9981742b05509f7b8d00a7e52
+ depends = libxpm
+ source = https://github.com/morgant/mlvwm/releases/download/0.9.4/mlvwm-0.9.4.tar.gz
+ md5sums = 09cd57abecb65a2cc0bd35d623dae953
pkgname = mlvwm
-
diff --git a/PKGBUILD b/PKGBUILD
index 813bc78b6289..40f862a912f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,29 @@
-# Maintainer : chrisl echo archlinux@c2h0r1i2s4t5o6p7h8e9r-l3u4n1a.com|sed 's/[0-9]//g'
+# Maintainer : Evan
+# Contributor: Chris L
pkgname=mlvwm
-pkgver=0.9.1
-pkgrel=2
-pkgdesc='Macintosh-Like Virtual Window Manager, it attempts to emulate the pre-Mac OS X Macintosh look and feel in its layout and window design.'
+pkgver=0.9.4
+pkgrel=3
+pkgdesc='Unoffical package for Macintosh-Like Virtual Window Manager, it attempts to emulate the pre-Mac OS X Macintosh look and feel in its layout and window design.'
arch=('i686' 'x86_64')
url="http://www2u.biglobe.ne.jp/~y-miyata/mlvwm.html"
license=('mit')
+depends=('libxpm')
makedepends=('imake')
-source=(http://www2u.biglobe.ne.jp/~y-miyata/mlvwm/mlvwm091.tar.gz)
-md5sums=('0ac2a6f9981742b05509f7b8d00a7e52')
+source=(https://github.com/morgant/mlvwm/releases/download/0.9.4/mlvwm-0.9.4.tar.gz)
+md5sums=('09cd57abecb65a2cc0bd35d623dae953')
build() {
- cd mlvwm091
- xmkmf -a
+ cd mlvwm-0.9.4
+ cd man && xmkmf && cd -
+ cd sample_rc && xmkmf && cd -
+ cd mlvwm && xmkmf && cd -
+ xmkmf
make
#make PREFIX="$pkgdir"/usr BINARY=$pkgname install man
}
package () {
- cd mlvwm091
+ cd mlvwm-0.9.4
sed -n '1,34 p'< mlvwm/mlvwm.c >license
mkdir -p "$pkgdir"/usr/share/licenses/$pkgname/
mkdir -p "$pkgdir"/usr/share/man/man1/