summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--fix-mmastart-path.patch11
3 files changed, 22 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 561aef9c9f3c..b1758231f42b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = mma
pkgdesc = Musical MIDI Accompaniment (MMA) is an accompaniment generator
pkgver = 12.10
- pkgrel = 1
+ pkgrel = 2
url = http://www.mellowood.ca/mma/
install = mma.install
arch = any
license = GPL
depends = python2>=2.5.0
depends = timidity++
+ options = !strip
+ options = !zipman
source = http://www.mellowood.ca/mma/mma-bin-12.10.tar.gz
+ source = fix-mmastart-path.patch
source = mmarc
md5sums = 1c34126c092ca07aab1b606c73670a64
+ md5sums = 75c3eeac52d846d5ff2050346e48d2d8
md5sums = 7cdddd5de515539cf66f0d8d9613dcdc
pkgname = mma
diff --git a/PKGBUILD b/PKGBUILD
index 35e1db72df1c..8b969ddd0921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mma
pkgver=12.10
-pkgrel=1
+pkgrel=2
pkgdesc="Musical MIDI Accompaniment (MMA) is an accompaniment generator"
url="http://www.mellowood.ca/mma/"
depends=('python2>=2.5.0' 'timidity++')
@@ -13,13 +13,17 @@ arch=('any')
install=mma.install
DLAGENTS=('http::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 --user-agent "Mozilla/4.0" -o %o %u ')
source=("http://www.mellowood.ca/mma/mma-bin-$pkgver.tar.gz"
+ fix-mmastart-path.patch
mmarc)
md5sums=('1c34126c092ca07aab1b606c73670a64'
+ '75c3eeac52d846d5ff2050346e48d2d8'
'7cdddd5de515539cf66f0d8d9613dcdc')
+options=(!strip !zipman)
build () {
-
cd $srcdir/$pkgname-bin-$pkgver
+
+ patch -p1 -i "${srcdir}/fix-mmastart-path.patch"
for file in $(grep -rl 'env python *$' .); do sed -i 's/env python *$/env python2/g' $file ;done
}
diff --git a/fix-mmastart-path.patch b/fix-mmastart-path.patch
new file mode 100644
index 000000000000..008fe1d205cb
--- /dev/null
+++ b/fix-mmastart-path.patch
@@ -0,0 +1,11 @@
+--- mma-bin-12.10/MMA/main.py.orig 2012-10-20 19:29:35.000000000 -0400
++++ mma-bin-12.10/MMA/main.py 2013-08-03 19:48:46.820508239 -0400
+@@ -156,7 +156,7 @@
+ # First the mmastart files
+
+ for f in gbl.mmaStart:
+- fn = MMA.file.locFile(f, MMA.paths.incPath)
++ fn = MMA.paths.findIncFile(f)
+ if not fn:
+ warning("MmaStart file '%s' not found/processed" % fn)
+ MMA.parse.parseFile(fn)