summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--mmaker-resetarea.diff10
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4ae69c5753a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mmaker
+ pkgdesc = MagicPoint Preprocessor
+ pkgver = 1.24.2
+ pkgrel = 2
+ url = http://www.icir.org/mallman/software/mmaker
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = magicpoint
+ depends = perl
+ source = http://www.icir.org/mallman/software/mmaker/mmaker-1.24.2.tar.gz
+ source = mmaker-resetarea.diff
+ md5sums = e6ed3aa51fce1126994df84c1f24dc22
+ md5sums = 3f5a84a9e508d88befb225d089ce6d6a
+
+pkgname = mmaker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5161d79e5c60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Volker Schatz <arch@my-name-without-hyphen.com>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+pkgname=mmaker
+pkgver=1.24.2
+pkgrel=2
+pkgdesc="MagicPoint Preprocessor"
+url="http://www.icir.org/mallman/software/mmaker"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('magicpoint' 'perl')
+source=(http://www.icir.org/mallman/software/mmaker/$pkgname-$pkgver.tar.gz
+ mmaker-resetarea.diff )
+md5sums=('e6ed3aa51fce1126994df84c1f24dc22'
+ '3f5a84a9e508d88befb225d089ce6d6a')
+
+prepare() {
+ cd "$srcdir"
+ patch -p0 < mmaker-resetarea.diff
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 mmaker "$pkgdir"/usr/bin/mmaker
+ install -d "$pkgdir"/usr/share/doc/$pkgname
+ cp Example/* RANT README "$pkgdir"/usr/share/doc/$pkgname
+ chmod a+r "$pkgdir"/usr/share/doc/$pkgname/*
+}
+
diff --git a/mmaker-resetarea.diff b/mmaker-resetarea.diff
new file mode 100644
index 000000000000..47cdddf2b0d6
--- /dev/null
+++ b/mmaker-resetarea.diff
@@ -0,0 +1,10 @@
+--- mmaker.orig 2003-06-11 15:10:45.000000000 +0200
++++ mmaker 2013-11-20 15:48:08.144855219 +0100
+@@ -302,6 +302,7 @@
+ print OUT "\n";
+ }
+ }
++ print OUT "%area 100 100\n";
+ }
+
+ ## Start a new slide.