summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD49
3 files changed, 29 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0e41449e402..531610719882 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = mobsh
- pkgdesc = Smooth git handover during remote mob programming
- pkgver = 1.2.0
+ pkgdesc = Tool for smooth git handover
+ pkgver = 4.5.0
pkgrel = 1
url = https://github.com/remotemobprogramming/mob
arch = x86_64
+ arch = i686
license = MIT
makedepends = go
+ depends = glibc
depends = git
optdepends = espeak-ng-espeak: Multi-lingual software speech synthesizer
optdepends = mbrola-voices-us1: An American English female voice for the MBROLA synthesizer
- provides = mobsh
- conflicts = mobsh
conflicts = mob
- source = https://github.com/remotemobprogramming/mob/archive/v1.2.0.tar.gz
- sha256sums = bfbcb6a865a26b4eb94ebaec4a0a9adeceefe42e2210cf3d8fe6d4267ee46c79
+ source = mobsh-4.5.0.tar.gz::https://github.com/remotemobprogramming/mob/archive/v4.5.0.tar.gz
+ sha256sums = 492bf6170b944956cbdc98f6b13c1588f243179e185d64e5119258b3ef2e7606
pkgname = mobsh
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index a953696b69e3..92d1d3f73ff5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,33 @@
-# Maintainer: Patrick Drechsler <socialcoding at pdrechsler dot de>
+# Maintainer: Jeff Henson <jeff@henson.io>
pkgname=mobsh
-pkgver=1.2.0
+pkgver=4.5.0
pkgrel=1
-pkgdesc="Smooth git handover during remote mob programming"
-arch=('x86_64')
+pkgdesc="Tool for smooth git handover"
+arch=('x86_64' 'i686')
url="https://github.com/remotemobprogramming/mob"
license=('MIT')
-depends=("git")
+depends=('glibc' 'git')
optdepends=('espeak-ng-espeak: Multi-lingual software speech synthesizer'
'mbrola-voices-us1: An American English female voice for the MBROLA synthesizer')
makedepends=('go')
-provides=('mobsh')
-conflicts=('mobsh' 'mob')
-source=("$url/archive/v${pkgver}.tar.gz")
-sha256sums=('bfbcb6a865a26b4eb94ebaec4a0a9adeceefe42e2210cf3d8fe6d4267ee46c79')
-
-prepare(){
- cd "mob-$pkgver"
- mkdir -p build/
-}
+conflicts=('mob')
+source=("$pkgname-$pkgver.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('492bf6170b944956cbdc98f6b13c1588f243179e185d64e5119258b3ef2e7606')
build() {
- cd "mob-$pkgver"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build -o build mob.go
-}
-
-check() {
- cd "mob-$pkgver"
- ./create-testbed
- go test
+ cd "mob-${pkgver}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o mob
}
package() {
- cd "mob-$pkgver"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm755 build/mob "$pkgdir"/usr/bin/mob
+ cd "mob-${pkgver}"
+ install -vDm 755 mob -t "${pkgdir}/usr/bin/"
+ install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -vDm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
}