summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
-rw-r--r--moc-https.patch10
3 files changed, 37 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f737c7773fe3..76a76e18737f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,43 +1,42 @@
pkgbase = moc-pulse-svn
pkgdesc = An ncurses console audio player with support for pulseaudio (SVN)
- pkgver = r2963
- pkgrel = 1
+ pkgver = r3005
+ pkgrel = 3
url = http://moc.daper.net
arch = i686
arch = x86_64
license = GPL
makedepends = speex
- makedepends = ffmpeg
+ makedepends = ffmpeg4.4
makedepends = taglib
makedepends = libmpcdec
makedepends = wavpack
makedepends = libmodplug
- makedepends = subversion
makedepends = faad2
- makedepends = pulseaudio
+ makedepends = subversion
depends = libmad
depends = libid3tag
depends = jack
depends = curl
depends = libltdl
depends = file
- depends = pulseaudio
+ depends = sndio
optdepends = speex: for using the speex plugin
- optdepends = ffmpeg: for using the ffmpeg plugin
+ optdepends = ffmpeg4.4: for using the ffmpeg plugin
optdepends = taglib: for using the musepack plugin
optdepends = libmpcdec: for using the musepack plugin
optdepends = wavpack: for using the wavpack plugin
optdepends = libmodplug: for using the modplug plugin
optdepends = faad2: for use the aac plugin
+ optdepends = pulseaudio: for using the pulseaudio plugin
provides = moc
conflicts = moc
options = !libtool
source = moc-pulse-svn::svn://daper.net/moc/trunk
source = 0001-Pulseaudio-backend.patch
- source = moc-ffmpeg4.patch
+ source = moc-https.patch
sha1sums = SKIP
sha1sums = d86a04606eaa0960f3b59626070cd231d37b6430
- sha1sums = 007a0580ac754e1c318a0d0b6f0d403883797eaf
+ sha1sums = e3362ddd41126e2be874cd372a053fdaccf0f616
pkgname = moc-pulse-svn
-
diff --git a/PKGBUILD b/PKGBUILD
index bb789bda3b00..7d2e384018cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,34 @@
-#Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
+#Maintainer: Hans-Nikolai Viessmann <hans AT viess DOT mn>
#Contributor: Øyvind 'MrElendig' Heggstad <mrelendig@har-ikkje.net>
#Contributor: jsteel <mail at jsteel dot org>
_pkgname=moc
pkgname="${_pkgname}-pulse-svn"
-pkgver=r2963
-pkgrel=1
+pkgver=r3005
+pkgrel=3
pkgdesc='An ncurses console audio player with support for pulseaudio (SVN)'
url='http://moc.daper.net'
arch=('i686' 'x86_64')
license=('GPL')
-depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file' 'pulseaudio')
-makedepends=('speex' 'ffmpeg' 'taglib' 'libmpcdec' 'wavpack'
- 'libmodplug' 'subversion' 'faad2' 'pulseaudio')
+depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file' 'sndio')
+makedepends=('speex' 'ffmpeg4.4' 'taglib' 'libmpcdec' 'wavpack' 'libmodplug' 'faad2' 'subversion')
optdepends=('speex: for using the speex plugin'
- 'ffmpeg: for using the ffmpeg plugin'
+ 'ffmpeg4.4: for using the ffmpeg plugin'
'taglib: for using the musepack plugin'
'libmpcdec: for using the musepack plugin'
'wavpack: for using the wavpack plugin'
'libmodplug: for using the modplug plugin'
- 'faad2: for use the aac plugin')
+ 'faad2: for use the aac plugin'
+ 'pulseaudio: for using the pulseaudio plugin')
conflicts=('moc')
provides=('moc')
options=('!libtool')
source=("${pkgname}::svn://daper.net/moc/trunk"
'0001-Pulseaudio-backend.patch'
- 'moc-ffmpeg4.patch')
+ 'moc-https.patch')
sha1sums=('SKIP'
'd86a04606eaa0960f3b59626070cd231d37b6430'
- '007a0580ac754e1c318a0d0b6f0d403883797eaf')
+ 'e3362ddd41126e2be874cd372a053fdaccf0f616')
pkgver() {
cd "$srcdir/$pkgname"
@@ -38,18 +38,21 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgname"
- # Fix build with ffmpeg 4 (taken from official release on ArchLinux)
- patch -p0 -i ../moc-ffmpeg4.patch
+ # Allow https for urls https://moc.daper.net/node/1872 (taken from official release on ArchLinux)
+ patch -p0 -i ../moc-https.patch
# Add pulseaudio backend
patch -p1 -i ../0001-Pulseaudio-backend.patch
# re-configure
- autoreconf -f -i -Wall,no-obsolete
+ autoreconf -i -f
}
build() {
cd "$srcdir/$pkgname"
+
+ export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
+
./configure --prefix=/usr --without-rcc --with-pulse \
--with-alsa --with-oss --with-jack --with-aac --with-mp3 \
--with-musepack --with-vorbis --with-flac --with-wavpack \
@@ -62,3 +65,5 @@ package() {
cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir" install
}
+
+# vim: ts=2 sw=2
diff --git a/moc-https.patch b/moc-https.patch
new file mode 100644
index 000000000000..5ff304df944f
--- /dev/null
+++ b/moc-https.patch
@@ -0,0 +1,10 @@
+--- files.c.orig
++++ files.c
+@@ -93,6 +93,7 @@
+ inline int is_url (const char *str)
+ {
+ return !strncasecmp (str, "http://", sizeof ("http://") - 1)
++ || !strncasecmp (str, "https://", sizeof ("https://") - 1)
+ || !strncasecmp (str, "ftp://", sizeof ("ftp://") - 1);
+ }
+