summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD15
-rw-r--r--moc-ffmpeg4.patch33
4 files changed, 10 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5871c7a6d03c..c8eb951b8798 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = moc-svn
pkgdesc = A powerful & easy to use console audio player
- pkgver = r2963
+ pkgver = r2992
pkgrel = 1
url = http://moc.daper.net
arch = i686
@@ -31,9 +31,7 @@ pkgbase = moc-svn
conflicts = moc
options = !libtool
source = moc::svn://daper.net/moc/trunk
- source = moc-ffmpeg4.patch
sha1sums = SKIP
- sha1sums = 007a0580ac754e1c318a0d0b6f0d403883797eaf
pkgname = moc-svn
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e98f8ab11f5f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+moc
+*.tar.xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 6ecbb0d6832f..613d17cfd028 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
+#Maintainer : Daniel T. Borelli <danieltborelli@gmail.com>
#Contributor: Fabio 'Lolix' Loli <lolix@disroot.org>
#Contributor: Øyvind 'MrElendig' Heggstad <mrelendig@har-ikkje.net>
#Contributor: jsteel <mail at jsteel dot org>
pkgname=moc-svn
-pkgver=r2963
+pkgver=r2992
pkgrel=1
pkgdesc='A powerful & easy to use console audio player'
url="http://moc.daper.net"
arch=('i686' 'x86_64')
license=('GPL')
depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file')
-source=('moc::svn://daper.net/moc/trunk'
- 'moc-ffmpeg4.patch')
-sha1sums=('SKIP'
- '007a0580ac754e1c318a0d0b6f0d403883797eaf')
+source=('moc::svn://daper.net/moc/trunk')
+sha1sums=('SKIP')
makedepends=('speex' 'ffmpeg' 'taglib' 'libmpcdec' 'wavpack'
'libmodplug' 'subversion' 'faad2')
optdepends=('speex: for using the speex plugin'
@@ -34,14 +33,10 @@ pkgver() {
}
-prepare() {
- cd moc
- patch -p0 -i ../moc-ffmpeg4.patch # Fix build with ffmpeg 4
-}
build() {
cd moc
- autoreconf -f -i -Wall,no-obsolete
+ autoreconf -f -i
./configure --prefix=/usr --without-rcc \
--with-alsa --with-jack --with-aac --with-mp3 \
--with-musepack --with-vorbis --with-flac --with-wavpack \
diff --git a/moc-ffmpeg4.patch b/moc-ffmpeg4.patch
deleted file mode 100644
index c1e43a7c2f3e..000000000000
--- a/moc-ffmpeg4.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Index: decoder_plugins/ffmpeg/ffmpeg.c
-===================================================================
---- decoder_plugins/ffmpeg/ffmpeg.c (revisión: 2963)
-+++ decoder_plugins/ffmpeg/ffmpeg.c (copia de trabajo)
-@@ -697,7 +697,7 @@
- * FFmpeg/LibAV in use. For some versions this will be caught in
- * *_find_stream_info() above and misreported as an unfound codec
- * parameters error. */
-- if (data->codec->capabilities & CODEC_CAP_EXPERIMENTAL) {
-+ if (data->codec->capabilities & AV_CODEC_CAP_EXPERIMENTAL) {
- decoder_error (&data->error, ERROR_FATAL, 0,
- "The codec is experimental and may damage MOC: %s",
- data->codec->name);
-@@ -705,8 +705,8 @@
- }
-
- set_downmixing (data);
-- if (data->codec->capabilities & CODEC_CAP_TRUNCATED)
-- data->enc->flags |= CODEC_FLAG_TRUNCATED;
-+ if (data->codec->capabilities & AV_CODEC_CAP_TRUNCATED)
-+ data->enc->flags |= AV_CODEC_FLAG_TRUNCATED;
-
- if (avcodec_open2 (data->enc, data->codec, NULL) < 0)
- {
-@@ -725,7 +725,7 @@
-
- data->sample_width = sfmt_Bps (data->fmt);
-
-- if (data->codec->capabilities & CODEC_CAP_DELAY)
-+ if (data->codec->capabilities & AV_CODEC_CAP_DELAY)
- data->delay = true;
- data->seek_broken = is_seek_broken (data);
- data->timing_broken = is_timing_broken (data->ic);