summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
-rw-r--r--moc-ffmpeg4.patch33
3 files changed, 53 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0396d0f1823..5871c7a6d03c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = moc-svn
pkgdesc = A powerful & easy to use console audio player
- pkgver = 2758
+ pkgver = r2963
pkgrel = 1
url = http://moc.daper.net
arch = i686
@@ -13,7 +13,6 @@ pkgbase = moc-svn
makedepends = wavpack
makedepends = libmodplug
makedepends = subversion
- makedepends = sidplay2
makedepends = faad2
depends = libmad
depends = libid3tag
@@ -27,13 +26,14 @@ pkgbase = moc-svn
optdepends = libmpcdec: for using the musepack plugin
optdepends = wavpack: for using the wavpack plugin
optdepends = libmodplug: for using the modplug plugin
- optdepends = sidplay2: for playing c64 sid files
optdepends = faad2: for use the aac plugin
provides = moc
conflicts = moc
options = !libtool
source = moc::svn://daper.net/moc/trunk
+ source = moc-ffmpeg4.patch
sha1sums = SKIP
+ sha1sums = 007a0580ac754e1c318a0d0b6f0d403883797eaf
pkgname = moc-svn
diff --git a/PKGBUILD b/PKGBUILD
index 2ed26a4aa7a2..6ecbb0d6832f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
-#Maintainer: Øyvind 'MrElendig' Heggstad <mrelendig@har-ikkje.net>
+#Contributor: Fabio 'Lolix' Loli <lolix@disroot.org>
+#Contributor: Øyvind 'MrElendig' Heggstad <mrelendig@har-ikkje.net>
#Contributor: jsteel <mail at jsteel dot org>
pkgname=moc-svn
-pkgver=2758
+pkgver=r2963
pkgrel=1
pkgdesc='A powerful & easy to use console audio player'
url="http://moc.daper.net"
arch=('i686' 'x86_64')
license=('GPL')
depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file')
-source=('moc::svn://daper.net/moc/trunk')
-sha1sums=('SKIP')
+source=('moc::svn://daper.net/moc/trunk'
+ 'moc-ffmpeg4.patch')
+sha1sums=('SKIP'
+ '007a0580ac754e1c318a0d0b6f0d403883797eaf')
makedepends=('speex' 'ffmpeg' 'taglib' 'libmpcdec' 'wavpack'
- 'libmodplug' 'subversion' 'sidplay2' 'faad2')
+ 'libmodplug' 'subversion' 'faad2')
optdepends=('speex: for using the speex plugin'
'ffmpeg: for using the ffmpeg plugin'
'taglib: for using the musepack plugin'
'libmpcdec: for using the musepack plugin'
'wavpack: for using the wavpack plugin'
'libmodplug: for using the modplug plugin'
- 'sidplay2: for playing c64 sid files'
'faad2: for use the aac plugin')
conflicts=('moc')
provides=('moc')
@@ -27,7 +29,14 @@ options=('!libtool')
pkgver() {
cd moc
- svnversion
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+
+prepare() {
+ cd moc
+ patch -p0 -i ../moc-ffmpeg4.patch # Fix build with ffmpeg 4
}
build() {
@@ -37,7 +46,7 @@ build() {
--with-alsa --with-jack --with-aac --with-mp3 \
--with-musepack --with-vorbis --with-flac --with-wavpack \
--with-sndfile --with-modplug --with-ffmpeg --with-speex \
- --with-samplerate --with-curl --with-sidplay2 --disable-debug
+ --with-samplerate --with-curl --disable-debug
make
}
diff --git a/moc-ffmpeg4.patch b/moc-ffmpeg4.patch
new file mode 100644
index 000000000000..c1e43a7c2f3e
--- /dev/null
+++ b/moc-ffmpeg4.patch
@@ -0,0 +1,33 @@
+Index: decoder_plugins/ffmpeg/ffmpeg.c
+===================================================================
+--- decoder_plugins/ffmpeg/ffmpeg.c (revisión: 2963)
++++ decoder_plugins/ffmpeg/ffmpeg.c (copia de trabajo)
+@@ -697,7 +697,7 @@
+ * FFmpeg/LibAV in use. For some versions this will be caught in
+ * *_find_stream_info() above and misreported as an unfound codec
+ * parameters error. */
+- if (data->codec->capabilities & CODEC_CAP_EXPERIMENTAL) {
++ if (data->codec->capabilities & AV_CODEC_CAP_EXPERIMENTAL) {
+ decoder_error (&data->error, ERROR_FATAL, 0,
+ "The codec is experimental and may damage MOC: %s",
+ data->codec->name);
+@@ -705,8 +705,8 @@
+ }
+
+ set_downmixing (data);
+- if (data->codec->capabilities & CODEC_CAP_TRUNCATED)
+- data->enc->flags |= CODEC_FLAG_TRUNCATED;
++ if (data->codec->capabilities & AV_CODEC_CAP_TRUNCATED)
++ data->enc->flags |= AV_CODEC_FLAG_TRUNCATED;
+
+ if (avcodec_open2 (data->enc, data->codec, NULL) < 0)
+ {
+@@ -725,7 +725,7 @@
+
+ data->sample_width = sfmt_Bps (data->fmt);
+
+- if (data->codec->capabilities & CODEC_CAP_DELAY)
++ if (data->codec->capabilities & AV_CODEC_CAP_DELAY)
+ data->delay = true;
+ data->seek_broken = is_seek_broken (data);
+ data->timing_broken = is_timing_broken (data->ic);