summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b1258ca6171..da17e259d665 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = mockito
pkgdesc = A java mocking framework that lets you write beautiful tests with a clean and simple API
- pkgver = 1.10.19
+ pkgver = 2.2.8
pkgrel = 1
url = https://github.com/mockito/mockito
arch = any
license = MIT
depends = java-runtime
- noextract = mockito-all-1.10.19.jar
- source = https://bintray.com/artifact/download/szczepiq/maven/org/mockito/mockito-all/1.10.19/mockito-all-1.10.19.jar
+ noextract = mockito-all-2.2.8.jar
+ source = https://dl.bintray.com/mockito/maven/org/mockito/mockito-core/2.2.8/mockito-core-2.2.8.jar
source = LICENSE
- sha256sums = d1a7a7ef14b3db5c0fc3e0a63a81b374b510afe85add9f7984b97911f4c70605
+ sha256sums = ae43d37d26b9100145f098750a2d7bbde2d39d2fd6e419ac72a2c90db29c4d9c
sha256sums = c91362ba4ffbea02d2ed5b7104893d56142479ea58068c95eee17925e25372da
pkgname = mockito
diff --git a/PKGBUILD b/PKGBUILD
index bba73aeb837f..59129902d5b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Snark1994 <sna rk 1994 at google mail dot com> (no spaces)
pkgname=mockito
-pkgver=1.10.19
+pkgver=2.2.8
pkgrel=1
pkgdesc="A java mocking framework that lets you write beautiful tests with a clean and simple API"
arch=('any')
url="https://github.com/mockito/mockito"
license=('MIT')
depends=('java-runtime')
-source=("https://bintray.com/artifact/download/szczepiq/maven/org/mockito/mockito-all/${pkgver}/mockito-all-${pkgver}.jar" \
+source=("https://dl.bintray.com/mockito/maven/org/mockito/mockito-core/${pkgver}/mockito-core-${pkgver}.jar" \
"LICENSE")
noextract=("mockito-all-${pkgver}.jar")
-sha256sums=('d1a7a7ef14b3db5c0fc3e0a63a81b374b510afe85add9f7984b97911f4c70605'
- 'c91362ba4ffbea02d2ed5b7104893d56142479ea58068c95eee17925e25372da')
+sha256sums=('ae43d37d26b9100145f098750a2d7bbde2d39d2fd6e419ac72a2c90db29c4d9c'
+ 'c91362ba4ffbea02d2ed5b7104893d56142479ea58068c95eee17925e25372da')
package() {
- install -D -m644 "${srcdir}/mockito-all-${pkgver}.jar" "${pkgdir}/usr/share/java/${pkgname}.jar"
+ install -D -m644 "${srcdir}/mockito-core-${pkgver}.jar" "${pkgdir}/usr/share/java/${pkgname}.jar"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}